Cannot load library icui18n | epson-printer-utility

I recently installed epson-printer-utility using yay. The instalation worked fine, however, when trying to open the utility I get the following error:

Unable to load library icui18n "Cannot load library icui18n: (icui18n: não é possível abrir arquivo compartilhado: Arquivo ou diretório inexistente)"

Which translates to:

Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"

I have checked and icu is installed (67.1-1) and everything is up to date. Pacman mirrors included

Any ideas?

System:    Kernel: 5.6.10-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=ca0327a4-b8a3-40c5-8824-f498da4a2518 rw 
           quiet udev.log_priority=3 
           Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P5G41T-M LX2/BR v: Rev X.0x serial: <filter> 
           BIOS: American Megatrends v: 0407 date: 01/17/2011 
CPU:       Topology: Quad Core model: Intel Core2 Quad Q8200 bits: 64 type: MCP arch: Penryn family: 6 
           model-id: 17 (23) stepping: A (10) microcode: A0B L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 bogomips: 18705 
           Speed: 2003 MHz min/max: 2003/2336 MHz Core speeds (MHz): 1: 2005 2: 2004 3: 2003 4: 2003 
           Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Gigabyte driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.8 driver: modesetting alternate: ati,fbdev,vesa 
           compositor: kwin_x11 resolution: 1024x768~60Hz, 1360x768~60Hz 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.36.0 5.6.10-3-MANJARO LLVM 10.0.0) 
           v: 4.6 Mesa 20.0.6 direct render: Yes 
Audio:     Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:27d8 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Gigabyte 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aaf0 
           Sound Server: ALSA v: k5.6.10-3-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK M4A785/P7P55 
           driver: r8169 v: kernel port: e800 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 652.08 GiB used: 146.83 GiB (22.5%) 
           ID-1: /dev/sda vendor: Western Digital model: WD5000AAKX-003CA0 size: 465.76 GiB block size: 
           physical: 512 B logical: 512 B speed: <unknown> serial: <filter> rev: 1H15 scheme: MBR 
           ID-2: /dev/sdb vendor: Samsung model: HD080HJ size: 74.53 GiB block size: physical: 512 B 
           logical: 512 B speed: <unknown> serial: <filter> rev: 0-33 scheme: MBR 
           ID-3: /dev/sdc vendor: Kingston model: SA400S37120G size: 111.79 GiB block size: physical: 512 B 
           logical: 512 B speed: <unknown> serial: <filter> rev: B1E1 scheme: MBR 
Partition: ID-1: / raw size: 59.07 GiB size: 57.89 GiB (98.01%) used: 38.87 GiB (67.1%) fs: ext4 
           dev: /dev/sdc3 
Sensors:   System Temperatures: cpu: 33.0 C mobo: N/A gpu: amdgpu temp: 21 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 2556 
Info:      Processes: 208 Uptime: 1m Memory: 5.81 GiB used: 1.78 GiB (30.6%) Init: systemd v: 244 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.16 running in: deepin-terminal inxi: 3.0.37

You may want to read this thread on how to provide more information.

I'm having the same problem,
Installed it using pamac


System:    Kernel: 5.6.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x serial: <filter> UEFI: American Megatrends 
           v: 1201 date: 09/09/2019 
Battery:   Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming Mouse serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
Memory:    RAM: total: 31.34 GiB used: 12.63 GiB (40.3%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen L2 cache: 4096 KiB bogomips: 129653 
           Speed: 4050 MHz min/max: 2200/4050 MHz boost: enabled Core speeds (MHz): 1: 4050 2: 4050 3: 4050 4: 4050 5: 4050 
           6: 4050 7: 4050 8: 4050 9: 4050 10: 4050 11: 4050 12: 4050 13: 4050 14: 4050 15: 4050 16: 4050 
           Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 bpext cat_l3 cdp_l3 clflush 
           clflushopt clwb clzero cmov cmp_legacy constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
           cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht 
           hw_pstate ibpb ibs irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
           nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core 
           perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev 
           sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce 
           topoext tsc tsc_scale umip v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr 
           xsaveopt xsaves 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: ASUSTeK driver: nvidia v: 440.82 bus ID: 07:00.0 
           chip ID: 10de:1b80 
           Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 07:00.1 
           chip ID: 10de:10f0 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 09:00.4 chip ID: 1022:1487 
           Device-3: Blue Microphones Yeti Stereo Microphone type: USB driver: snd-usb-audio bus ID: 1-5:6 chip ID: b58e:9e84 
           Device-4: Valve type: USB driver: cdc_acm,hid-generic,usbhid bus ID: 1-2.3.3:10 chip ID: 28de:2102 serial: <filter> 
           Device-5: Valve type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k5.6.11-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: f000 
           bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 2.27 TiB used: 47.46 GiB (2.0%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO M.2 500GB size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 4B6Q scheme: GPT 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 2TB size: 1.82 TiB speed: 6.0 Gb/s serial: <filter> rev: 2B6Q 
           scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 200.00 GiB used: 21.46 GiB (10.7%) fs: btrfs dev: /dev/sda2 label: N/A 
           uuid: 59b9e242-c237-4287-a9bf-6724bfef7846 
           ID-2: /boot/efi size: 1022.0 MiB used: 580 KiB (0.1%) fs: vfat dev: /dev/sda1 label: N/A uuid: 1708-07B4 
           ID-3: /home size: 264.63 GiB used: 26.00 GiB (9.8%) fs: xfs dev: /dev/sda3 label: N/A 
           uuid: a958690e-11a8-4007-a339-7065e83481d0 
           ID-4: /run/timeshift/backup size: 200.00 GiB used: 21.46 GiB (10.7%) fs: btrfs dev: /dev/sda2 label: N/A 
           uuid: 59b9e242-c237-4287-a9bf-6724bfef7846 
           ID-5: /var/lib/snapd/snap/authy/3 raw size: 61.3 MiB size: <root required> used: <root required> fs: squashfs 
           dev: /dev/loop2 label: N/A uuid: N/A 
           ID-6: /var/lib/snapd/snap/core18/1754 raw size: 54.9 MiB size: <root required> used: <root required> fs: squashfs 
           dev: /dev/loop1 label: N/A uuid: N/A 
           ID-7: /var/lib/snapd/snap/gnome-3-28-1804/116 raw size: 160.2 MiB size: <root required> used: <root required> 
           fs: squashfs dev: /dev/loop4 label: N/A uuid: N/A 
           ID-8: /var/lib/snapd/snap/gtk-common-themes/1506 raw size: 62.1 MiB size: <root required> used: <root required> 
           fs: squashfs dev: /dev/loop3 label: N/A uuid: N/A 
           ID-9: /var/lib/snapd/snap/snapd/7264 raw size: 27.1 MiB size: <root required> used: <root required> fs: squashfs 
           dev: /dev/loop0 label: N/A uuid: N/A 
Unmounted: ID-1: /dev/sdb1 size: 128.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-2: /dev/sdb2 size: 1.82 TiB fs: ntfs label: 850 Evo uuid: 3692C81892C7DA8F 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-1:2 info: Alcor Micro Multimedia Card Reader type: Mass Storage driver: usb-storage interfaces: 1 
           rev: 2.0 speed: 480 Mb/s chip ID: 058f:6361 serial: <filter> 
           Hub: 1-2:3 info: Valve ports: 3 rev: 2.0 speed: 480 Mb/s chip ID: 28de:2613 
           Hub: 1-2.3:5 info: Microchip (formerly SMSC) Hub ports: 5 rev: 2.1 speed: 480 Mb/s chip ID: 0424:2744 
           Device-2: 1-2.3.1:8 info: Valve Mass Storage Device type: HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0 
           speed: 12 Mb/s chip ID: 28de:2300 serial: <filter> 
           Device-3: 1-2.3.2:9 info: Valve type: HID,Abstract (modem),CDC-Data driver: cdc_acm,hid-generic,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 28de:2102 serial: <filter> 
           Device-4: 1-2.3.3:10 info: Valve type: HID,Audio driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 2.0 
           speed: 12 Mb/s chip ID: 28de:2102 serial: <filter> 
           Device-5: 1-2.3.5:11 info: Microchip (formerly SMSC) Yeti Stereo Microphone type: <vendor specific> driver: N/A 
           interfaces: 1 rev: 2.0 speed: 480 Mb/s chip ID: 0424:2740 
           Device-6: 1-4:4 info: Logitech USB Receiver type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 046d:c53f 
           Device-7: 1-5:6 info: Blue Microphones Yeti Stereo Microphone type: Audio driver: snd-usb-audio interfaces: 3 
           rev: 2.0 speed: 12 Mb/s chip ID: b58e:9e84 
           Device-8: 1-6:7 info: Broadcom BCM20702A0 Bluetooth 4.0 type: <vendor specific> driver: btusb interfaces: 4 
           rev: 2.0 speed: 12 Mb/s chip ID: 0a5c:21e8 serial: <filter> 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 2-2:2 info: Microchip (formerly SMSC) Hub ports: 4 rev: 3.2 speed: 5 Gb/s chip ID: 0424:5744 
           Device-9: 2-2.1:3 info: Valve type: Video driver: uvcvideo interfaces: 2 rev: 3.2 speed: 5 Gb/s chip ID: 28de:2400 
           serial: <filter> 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-10: 3-6:2 info: ASUSTek AURA LED Controller type: <vendor specific> driver: hid-generic,usbhid interfaces: 2 
           rev: 2.0 speed: 12 Mb/s chip ID: 0b05:18f3 serial: <filter> 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-11: 5-3:2 info: Logitech G710 Gaming Keyboard type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 
           rev: 2.0 speed: 12 Mb/s chip ID: 046d:c24d 
           Hub: 6-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 86.1 C mobo: N/A gpu: nvidia temp: 64 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 80% 
Info:      Processes: 584 Uptime: 1d 9h 41m Init: systemd v: 245 Compilers: gcc: 9.3.0 alt: 8 Shell: bash v: 5.0.16 
           running in: yakuake inxi: 3.0.37

I've asked the AUR maintainer of the epson-printer-utility package for some insight. Otherwise an issue has to be opened at the Epson support page.

I've installed the package and can reproduce this error.

EDIT: Just installed it on my Arch machine and get also the error:

Communication daemon down, Error code = -1
1 Like

This package needs a daemon to work, please do:

sudo systemctl enable --now ecbd.service

Then start the program. It now runs on both of my machines.

1 Like

Yep! Can confirm that fixes it! Guess that will be changed in the pckbuild?

No, I don't think so. It was mentioned in the very first comment on the package. I didn't go down that far either, though it is much more visible now... You should check the AUR page of every AUR package that you install anyway!

https://wiki.manjaro.org/index.php/Arch_User_Repository

why not though?
It's just one line of code to add that fixes the actual application from being able to launch. You shouldn't have to go to the aur page every time to know how to launch an application I think

You should check the AUR page for many reasons, some of which are

  • Is the package maintained?
  • When has it last been updated?
  • Are there issues that I should know of? (!)
  • Are there weird dependencies?

Besides these you may want to discuss this with the maintainer :wink:

https://aur.archlinux.org/packages/epson-printer-utility/#news

1 Like

I guess,
I always check when it was last updated in pamac gui and depending on that I'll open the aur page or not

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by