Cannot mount boot/efi after forced shutdown with manual power off

thanks! I would like to understand how to do it!
I can boot from a manjaro live image on a usb stick if needed.
thanks again!

this is what I did:

  • started parted
  • deleted sda1
  • created a new sda1 of 150 MB
  • added boot and efi flags
  • exited gparted
  • formatted sda1 with fat32
  • updated /etc/fstab using nano (I did not actually understand why you suggested to use a livecd image to do this, it is necessary?)
  • rebooted

what happened is that the manjaro boot option disappeared from the boot menu (I don't know how the menu works).

maurizio

UEFI Boot menu reads ESP. Now you have it new and formatted, so no menu entries. You need to install bootloader to be able to boot.
Also, recommended way is to use PARTUUID with GPT and not UUID.

Now, if there is other OS (debian/ubuntu). Ah... saw your post, okay then use manjaro live usb stick then.
Boot up this manjaro live usb, And at terminal, recheck (always be sure, ya) where the partitions are and sda is sda and sdb is sdb. Always use correct sda/sdb and always use what the output tells you. If the 1 TG is sda by the output, use 'sda'. If it says the 1 TB is sdb, then use 'sdb'.

Check using either

lsblk -f
sudo parted -l
sudo blkid

or whatever you like. But be clear and be correct.

I am going to use sda here for the 1 TB and the new $esp partition as sda5, and the Manjaro OS partition as sda3.
Change accordingly if the output shows otherwise. (numbering may change, so be very very sure)

Now at live terminal,

sudo mount /dev/sda3 /mnt
sudo mount /dev/sda5 /mnt/boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --bootloader-id=manjaro --boot-directory=/mnt/boot --recheck --debug

Note there are 3 commands above. The last command is long and gets wrapped to the next line in this small screen.

That's it.

Now I will continue next post if when booted up, you get to a grub prompt and not a menu. Unlikely, but I want to be sure.

thanks, I now have problems to boot in the CLI from the usb live (the graphic driver has some problems so it gets stuck during boot). can you please help me to find out how I can boot into the CLI from a manjaro livecd? sorry for asking, I can not quickly find it on the web.
maurizio

If booted up to a grub prompt instead of a menu, at grub prompt,

grub> search.file /boot/intel-ucode.img root
grub> configfile /boot/grub/grub.cfg

Manjaro grub menu will then appear, enter at the first (top) entry and we will boot into Manjaro.

I always like to be certain, so after booting up,
Check if findmnt /boot/efi is listed

findmnt /boot/efi

If listed, do again grub-install and update-grub.
There is really no harm doing these, even if everything is working fine.
And when there is a possibility of a problem, doing these always fixes the problem.
{And I am puzzled why people are reluctant to do these and question why they need to do these. :smirk: }

This time, grub-install is simpler (only for uefi).

sudo grub-install
sudo update-grub

Good luck.

Use non-free drivers (or vice-versa). You can boot to prompt only by adding '3' to the linux line - wait, I always boot livecd using grub2 to boot isofiles, not really sure if it can be done from usb boots. But try, okay? Maybe somebody here can help/correct or confirm.

It booted again!
But I get the same error :frowning:[FAILED] Failed to mount /boot/efi

Great![quote="mauman, post:28, topic:5109"]
But I get the same error :frowning:[FAILED] Failed to mount /boot/efi
[/quote]

:confounded:

Alright, Your sda1 is really bonked. We can use sdb $esp (since it is always fixed) instead.
But whatever you do, do not format this sdb $esp

Method as follows.
While booted up at Manjaro, change fstab to that of sdb (128 GB) $esp uuid.
And at terminal,

sudo umount /boot/efi

Disclosure: Caveats I have not done this. Try it and see if it gets unmounted.
If no error message, check with findmnt /boot/efi if it is really unmounted (it won't show output if unmounted)

findmnt /boot/efi

Then at Manjaro terminal,

sudo mount /dev/sdb1 /boot/efi

Of course, always recheck if $esp of 128 GB disk is sdb1. Change accordingly if not.
Check if findmnt /boot/efi shows sdb1 at this point, if yes, continue

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

by the way, are you sure that the problem regarding 'vfat' is not important?
when the boot fails I get the message: see sytemctl status boot-efi.mount for details.
then when I type the above command I get:

boot-efi.mount - /boot/efi
Loaded: loaded (/etc/fstab; bad; vendor preset: disabled)
Active: failed (Result: exit-code) since Sat 2016-07-02 00:38:48 CEST; 1min 3s ago
Where: /boot/efi
What: /dev/disk/by-uuid/0E91-E9B5
Docs: man:fstab(5)
man:systemd-fstab-generator(8)
Process: 303 ExecMount=/usr/bin/mount /dev/disk/by-uuid/0E91-E9B5 /boot/efi -t vfat -o defaults,noatime (code=exited, status=32)

Jul 02 00:38:48 maurizio-rog systemd[1]: Mounting /boot/efi...
Jul 02 00:38:48 maurizio-rog mount[303]: mount: unknown filesystem type 'vfat'
Jul 02 00:38:48 maurizio-rog systemd[1]: boot-efi.mount: Mount process exited, code=exited status=32
Jul 02 00:38:48 maurizio-rog systemd[1]: Failed to mount /boot/efi.
Jul 02 00:38:48 maurizio-rog systemd[1]: boot-efi.mount: Unit entered failed state.

also, the sda1 that is failing now is new, how is it possible that it is already corrupted?
and what happens if also sdb $esp will get corrupted?

another maybe useful information: both sda and sdb are ssd. is it possible that sda gets corrupted because of wrong partition settings?

the partition is not mounted, so the output of this command is "umount: /boot/efi: not mounted

Note my edit is done for above post. Please proceed.
A short note (will follow with longer notes if you require) on the things you brought up.[quote="mauman, post:30, topic:5109"]
by the way, are you sure that the problem regarding 'vfat' is not important?when the boot fails I get the message: see sytemctl status boot-efi.mount for details.
[/quote]
Short answer : normal error message when we try to 'simple' mount a fat32 partition.
We can successfully mount a fat32 using specific command mounts.

A possibility is when the device is not set up properly, especially if we do not set partition tables (gpt/msdos) beforehand and before we create partitions in the device. But not specifically due to use of ssd devices, but there has been cases of ssd devices failures due to trim/noatime/etc... issues
Hey I need to reply on your new post.

no way, the output is: mount: unknown filesystem type 'vfat'

:astonished:

Good. (and I should have expected that).
So continue to mount sdb1 partition as /boot/efi.

Go. Good luck,

my message got published before yours:

And I should have expected that too. Sorry. Just didn't do much of mounting windows partitions.
As I was just saying[quote="gohlip, post:33, topic:5109"]
Short answer : normal error message when we try to 'simple' mount a fat32 partition.We can successfully mount a fat32 using specific command mounts.
[/quote]

Try this....

mount -t vfat /dev/sdb1 /boot/efi 

Caveats; Haven't done much of these things.

same output: unknown filesystem

:disappointed:

Okay. Maybe there's a command that works.

Let's take a break here (it's really late here) and if any of us or those lurking around :relaxed: knows, please give a shout out. Thanks.

Catch up with you later, ya. Well, at least it boots. (same as at the beginning though :kissing_smiling_eyes: )

yes, at least it boots, we are back at the beginning but things are slightly clearer now.
thank you very much for your help, I hope we will find a way to fix it!
maurizio

Forum kindly sponsored by