Cannot mount certain removable media like SDXC card

This issue seems to exist in OpenRC installations only. I can mount other memory cards but trying to mount SDXC card gives me an error ending with this suggestion:
stderr: `fuse: device not found, try 'modprobe fuse' first
Indeed, if I run modprobe fuse first I can mount the card.

How can I get around this? How can I put this command in startup (XFCE) to run as root if that is only solution?

Thanks.

There is a fuse-openrc package; do you have that installed?

Then try sudo rc-service fuse start (and it should start at boot). I don't use it, but I'd guess it's needed in your case.

Thank you.
I have it installed but service does not start at reboot.
It works when started as you suggest but after reboot service is not running.

Oh yes, it also needs to be added to the default runlevel:

sudo rc-update add fuse default

That worked!
Thank you so much. This has been torturing me for months, since started using Manjaro OpenRC. Could not find an answer anywhere.
:triumph:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by