Cannot pair or connect bluetooth headphones

Cannot pair or connect bluetooth headphones Philips SHB2505. Tried using bluetoothctl, blueman, blueberry, reboot, reinstall packages, different kernels (4.19.125-1, 5.4.43-1, 5.6.15-1), enable or disable wifi, ethernet. Phone connects to laptop and works fine (can send files, stream music). Headphones also connects to phone fine.
Aslo tried solutions from here https://wiki.archlinux.org/index.php/Bluetooth

Everything works fine if i load Linux Mint 19.3 from USB, but not in Manjaro.

-Fxxxz

System:
  Host: lotus-pc Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Cinnamon 4.6.2 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: G5 5587 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 03PVDF v: A00 serial: <filter> UEFI: Dell v: 1.5.0 
  date: 09/27/2018 
Battery:
  ID-1: BAT0 charge: 44.7 Wh condition: 44.7/56.0 Wh (80%) volts: 16.9/15.2 
  model: BYD DELL 7FHHV88 type: Li-ion serial: <filter> status: Full 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 901 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 901 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 9: 900 10: 900 11: 900 12: 900 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell 
  driver: nvidia v: 440.82 bus ID: 01:00.0 chip ID: 10de:1c8c 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel port: 5000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlp0s20f3 state: down mac: <filter> 
  Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell 
  driver: alx v: kernel port: 3000 bus ID: 3b:00.0 chip ID: 1969:e0a1 
  IF: enp59s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.03 TiB used: 471.34 GiB (44.9%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM3 
  ID-2: /dev/sdb vendor: SK Hynix model: SC311 SATA 128GB size: 119.24 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 0P10 scheme: GPT 
Partition:
  ID-1: / size: 22.26 GiB used: 11.92 GiB (53.5%) fs: ext4 dev: /dev/sdb4 
  ID-2: /home size: 78.24 GiB used: 4.97 GiB (6.4%) fs: ext4 dev: /dev/sdb3 
  ID-3: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 57 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 294 Uptime: 11h 17m Memory: 15.35 GiB used: 1.54 GiB (10.0%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 
  running in: gnome-terminal inxi: 3.0.37 

rfkill list

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

bluetoothctl

Agent registered
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# agent on
Agent is already registered
[bluetooth]# scan on
Discovery started
[CHG] Controller [MAC] Discovering: yes
[CHG] Device [MAC] RSSI: -54
[bluetooth]# scan off
Discovery stopped
[CHG] Controller [MAC] Discovering: no
[CHG] Device [MAC] RSSI is nil
[bluetooth]# trust [MAC] 
Changing [MAC] trust succeeded
[bluetooth]# pair [MAC] 
Attempting to pair with [MAC]
Failed to pair: org.bluez.Error.AuthenticationTimeout
[bluetooth]# connect [MAC] 
Attempting to connect to [MAC]
Failed to connect: org.bluez.Error.Failed
[bluetooth]# remove [MAC] 
[DEL] Device [MAC] Philips SHB2505
Device has been removed
[bluetooth]# power off
Changing power off succeeded
[CHG] Controller [MAC] Powered: no
[CHG] Controller [MAC] Discovering: no
[CHG] Controller [MAC] Class: 0x00000000
[bluetooth]# quit

pamac search -i blue

pulseaudio-bluetooth                       13.0-3                     extra 
    Bluetooth support for PulseAudio
manjaro-bluetooth                          20200126-1                 extra 
    manjaro bluetooth support (Meta-PKG)
bluez-utils                                5.54-2                     extra 
    Development and debugging utilities
    for the bluetooth protocol stack
bluez-tools                                0.2.0-4                    community 
    A set of tools to manage Bluetooth
    devices for Linux
bluez-qt-git                               5.71.0.r594.gfa02bc0-1     community 
    Qt wrapper for Bluez 5 DBus API
bluez-plugins                              5.54-2                     extra 
    bluez plugins (PS3 Sixaxis controller)
bluez-libs                                 5.54-2                     extra 
    Deprecated libraries for the
    bluetooth protocol stack
bluez-hid2hci                              5.54-2                     extra 
    Put HID proxying bluetooth HCI's into
    HCI mode
bluez-cups                                 5.54-2                     extra 
    CUPS printer backend for Bluetooth
    printers
bluez                                      5.54-2                     extra 
    Daemons for the bluetooth protocol
    stack
blueman                                    2.1.3-1                    community 
    GTK+ Bluetooth Manager
bluedevil-git                              5.19.80.r2118.gf8247d4e-1  community 
    Integrate the Bluetooth technology
    within KDE workspace and applications

journalctl -u bluetooth -n 10

июн 05 07:32:36 lotus-pc systemd[1]: Starting Bluetooth service...
июн 05 07:32:36 lotus-pc bluetoothd[1014]: Bluetooth daemon 5.54
июн 05 07:32:36 lotus-pc systemd[1]: Started Bluetooth service.
июн 05 07:32:36 lotus-pc bluetoothd[1014]: Starting SDP server
июн 05 07:32:36 lotus-pc bluetoothd[1014]: Bluetooth management interface 1.15 initialized
июн 05 07:32:58 lotus-pc bluetoothd[1014]: Endpoint registered: sender=:1.34 path=/MediaEndpoint/A2DPSink/sbc
июн 05 07:32:58 lotus-pc bluetoothd[1014]: Endpoint registered: sender=:1.34 path=/MediaEndpoint/A2DPSource/sbc
июн 05 18:43:24 lotus-pc bluetoothd[1014]: Unable to get io data for :1.34/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: getpeername: Transport endpoint is not connected (107)
июн 05 18:43:24 lotus-pc bluetoothd[1014]: No matching connection for device
июн 05 18:54:59 lotus-pc bluetoothd[1014]: [MAC]: error updating services: Function not implemented (38)
1 Like

I have Yiman earbuds, never got them to connect, so am interested in this.

Sony WH1000 XM2 here. They connect fine but no audio. It did play audio after resetting bluetooth with

sudo systemctl restart bluetooth.service

and then reconnect but that no longer does it. Been going through hundreds of posts, tried all tips and tricks I found to no avail. Any solution is welcome!

Is there any feature in the headphones' instructions for pairing (visibility or something)?
I have some headphones that sometimes don't connect as the resource is unavailable, so I have to long-press a button to make them visible.

There is no such thing in the headphones's instraction. Just turn them on. Only one thing mentiond in instraction - you should remove headphones from priviously paired device before you try to pair them to another one. I did it twice. No changes.

Tried today booting from usb Linux Mint 20 Beta. Failed to pair or connect headphones. Now I'm pretty sure that the problem is new version of bluez and/or libbluetooth.

@lotus I'm on the same boat ... I'm trying to connect my bluetooth headset on dell with a Wireless-AC 9462 card.
I seems to come from the a low level but you managed to make it works under Mint 19.3, so it means that the drive iwlwifi is not the cause.
I tried to use older version of bluez from 5.54.2 to 5.50 and with kernel from 5.4 to 5.7 but it didn't seems to change anything ...

(I also tried with another dell laptop athk10, it works on manjaro but it doesn't help ...)

Just tried Mint (ventoy USB) - same problem, connect then disconnect in a couple of seconds.

I saw some troubleshoots about that in the arch wiki.

Also:

  • Tried with the live version of fedora 32 (doesn't work), they were using bluez 5.54 too.
  • Tried with Mint 19.3 (Kernel 5.0 and bluez 5.48), it works and didn't get disconnected for me. I tried to mimic this on my manjaro, I compiled my own version of bluez (version 5.48, didn't find a package) and didn't find a kernel with the version 5.0 (I tried with a previous one but it didn't boot :slight_smile:). With a kernel in 5.4 it didn't improve anything.

We may be should try to reach the bluez dev, they might know from where it comes ...

Or just give up :smiley: Cheap Amazon earbuds, work with my phone, I can live with it.

Here is the historic packages:

https://archive.org/download/archlinux_pkg_bluez

5.48 is in there. Download sig as well.

1 Like

I had a lot of trouble, but got my cheap Bluetooth buds working. The gnome extension for picking audio in/out was the only thing correctly changed the audio destination for me. I also added them using the gnome Bluetooth manager, the pane in the system settings didn't help.

Making sure the buds were in pairing mode, and selecting to connect them to a serial port were also things I got hung up on.

@Sauce which extension?

Sound Input & Output Device Chooser

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by