Cannot stream or record in OBS Studio

I cannot stream or record in obs-studio. When I click record or stream I receive the following error:

Starting the output failed. Please check the log for details.

Note: If you are using the NVENC or AMD encoders, make sure your video drivers are up to date.

This is after the latest upgrade. However I get the exact same error regardless of whether I use the Flatpak, Snap or native version of the package. Software encoding works perfectly as it should. My initial thinking it might be a setting or bug in the Nvidia drivers. I'm using a GeForce GTX 1050 Ti with the latest drivers available in Manjaro. The rest of my 'lspci' can be found here on Pastebin.

I have attached the OBS logs below.

10:01:39.557: ==== Startup complete ===============================================
10:01:39.557: Service '' not found
10:01:39.558: All scene data cleared
10:01:39.558: ------------------------------------------------
10:01:39.560: pulse-input: Server name: 'pulseaudio 13.0'
10:01:39.560: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
10:01:39.560: pulse-input: Started recording from 'alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo.monitor'
10:01:39.569: pulse-input: Server name: 'pulseaudio 13.0'
10:01:39.569: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
10:01:39.569: pulse-input: Started recording from 'alsa_input.usb-C-Media_Electronics_Inc._USB_Advanced_Audio_Device-00.analog-stereo'
10:01:39.569: Switched to scene 'Scene'
10:01:39.569: ------------------------------------------------
10:01:39.569: Loaded scenes:
10:01:39.569: - scene 'Scene':
10:01:39.569: ------------------------------------------------
10:01:42.104: adding 23 milliseconds of audio buffering, total audio buffering is now 23 milliseconds (source: Desktop Audio)
10:01:52.699: ---------------------------------
10:01:52.699: [NVENC encoder: 'simple_h264_stream'] settings:
10:01:52.699: 	rate_control: CBR
10:01:52.699: 	bitrate:      2500
10:01:52.699: 	cqp:          0
10:01:52.699: 	keyint:       250
10:01:52.699: 	preset:       hq
10:01:52.699: 	profile:      high
10:01:52.699: 	width:        1280
10:01:52.699: 	height:       720
10:01:52.699: 	2-pass:       false
10:01:52.699: 	b-frames:     2
10:01:52.699: 	GPU:          0
10:01:52.702: [NVENC encoder: 'simple_h264_stream'] Failed to open NVENC codec: Unknown error occurred

Post title edited. Please don't paste long error messages in the topic title. Keep it clear and concise.

1 Like

inxi -Fxxxza --no-host
so we know what we are dealing with ...
Also, it seems you are using simple settings. Try Advanced, so then you should use this option instead


Whatever settings i use, i can't reproduce your issue and i have GeForce GTX 960/PCIe/SSE2 with the video-nvidia-440xx drivers

I experienced the same problem. I used to timeshift to restore the latest driver and kernel updates but it didn't help. Anyway, I was using obs from the snap store. The window capture worked properly in that build but the recording didn't start.

I uninstalled it and installed the obs studio from the arch community repository. The recording in this build is working fine but the window capture isn't working well - all windows say unknown and i am unable to record cs go gameplay. I hope this information helps.

I have the same issue on my GTX 1060. Tested with AUR, Flatpak and Snapcraft.
This seems a driver regression to me, because it already happened in the past and did not affected all gpu models.
I opened an issue report on nvidia forums. Fingers crossed! :crossed_fingers:

So it turned out the mhwd script generates a misconfigured? conf file that doesn't load nvidia-uvm module at boot, which is required by NVENC encoder to work.
PS: the nvidia customer support is very fast! :flushed:

Hey @Leprotto79 would you mind to post here the link for you post on Nvidia forums? I'm having the same issue and would love to follow there

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by