Cannot upgrade dropbox, key issue

this is what happens trying to upgrade the dropbox package (AUR) using pamac:

==> Validating source_x86_64 files with sha256sums...
    dropbox-lnx.x86_64-64.4.141.tar.gz ... Passed
    dropbox-lnx.x86_64-64.4.141.tar.gz.asc ... Skipped
==> Verifying source file signatures with gpg...
    dropbox-lnx.x86_64-64.4.141.tar.gz ... FAILED (unknown public key FC918B335044912E)
==> ERROR: One or more PGP signatures could not be verified!

As @jonathon suggests in the FAQ AUR package fails to verify PGP/GPG key
I tried to add the key in my keyring, but fails with this error:

$ gpg --recv-key FC918B335044912E
gpg: keyserver receive failed: Server indicated a failure

Now I'm not sure how to deal with this, any advice?


See if you define the server:
gpg --recv-key --keyserver hkp:// FC918B335044912E
gpg --recv-key --keyserver FC918B335044912E

If doesn't work, check the DNS or make a change to use as DNS.


Notice - these URLs are safe, but do not use random keyservers.

as to the DNS the suggested DNS above is google, but others are available too, such as for cloudflare. (probably my first suggestion)

sometimes one or either of these can fix it.
sometimes, such as behind certain university networks or similar, you are simply blocked and that is an issue for your network administrator or ISP. We will hope it is not that. :slight_smile:

[PS - since this is marked as solution.. apparently switching to cloudflare's DNS solved the issue]


Didn't expect a so fast reply! Thank you!
Specifying the server as you told me:

$ gpg --recv-key --keyserver hkp:// FC918B335044912E
gpg: keyserver receive failed: Server indicated a failure

$ gpg --recv-key --keyserver FC918B335044912E
gpg: keyserver receive failed: Server indicated a failure

I'm using DHCP, my DNS seems to be fe80::1

$ nmcli dev show | grep DNS
IP6.DNS[1]:       fe80::1
$ cat /etc/resolv.conf 
nameserver fe80::1%enp3s2

Trying to ping the servers you gave me:

$ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=50 time=121 ms
64 bytes from ( icmp_seq=2 ttl=50 time=121 ms
64 bytes from ( icmp_seq=3 ttl=50 time=122 ms
64 bytes from ( icmp_seq=4 ttl=50 time=121 ms
--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 6ms
rtt min/avg/max/mdev = 121.157/121.433/122.045/0.556 ms

$ ping
PING ( 56(84) bytes of data.
--- ping statistics ---
12 packets transmitted, 0 received, 100% packet loss, time 151ms

Then following your kind suggestione, I changed my DNS to

$ cat /etc/resolv.conf 
# Generated by NetworkManager
nameserver fe80::1%enp3s2

$ nslookup

The preceding commands now give a different result:

$ gpg --recv-key --keyserver hkp:// FC918B335044912E
gpg: keyserver receive failed: No data

$ gpg --recv-key --keyserver FC918B335044912E
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

So your indication about DNS has importance, but I'm still clueless

There it is! Setting the DNS to solved.

$ gpg --recv-key FC918B335044912E
gpg: key FC918B335044912E: 3 signatures not checked due to missing keys
gpg: key FC918B335044912E: public key "Dropbox Automatic Signing Key <>" imported
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   2  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 2u
gpg: next trustdb check due at 2019-04-16
gpg: Total number processed: 1
gpg:               imported: 1

Thank you both @cscs and @bogdancovaciu !


Wow. I didnt expect that. But, nice. chalk that up as another win for
Note - secondary servers are, IPV6 addresses are available too.
See more here:


Well, thank YOU :smiley:
Now i'll make some test with this DNS.
Ans also i wonder i i didn't had a typo when i put http:// instead of hkp:// :thinking: or in reverse ...

1 Like

With I didn't try to give the command without specifying the server, maybe could have been worked. I tried to split the solution between you and @cscs but that's not possible!
However, thank you again.

Well, then i'll mark your post as solution :wink:
Edit: i was a bit behind with the source of the DNS ...
I put the rightful solution mark now :slight_smile:

1 Like


Learned something again, thank you.

Pi-Hole should write the IP behind the name :slight_smile:

Hi guys,

I want to note that I was having the same issue as the original post while using OpenDNS as my DNS server, changing my DNS IP address to goggle's ( fixed the issue and I was able to upgrade dropbox. I love Manjaro 's friendly geeky community keep it up :+1:

1 Like

Glad you got it fixed as I was having the same issue but my was solved in a different way. What wrapper are you using for AUR? Because I was using yaourt until I saw that development for it has ended. When I installed and used yay to update dropbox, it asked if I wanted to download a new key and then it was able to update.

I never thought the DNS IP address would affect something like that though.

Hi myndflyte,
I'm not using a wrapper at the moment I installed dropbox using git and pacman ($ git clone

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by