Cannot upgrade kernel beyond 414

tried booting 4.17 with all deepin packs uninstalled.

it couldn't boot.

Deepin is not the issue here. Our development editions have newer kernels pre-installed. Maybe the live-ISO may boot. Also what is the output of mhwd and mhwd -lh?

mhdw:

> 0000:01:00.0 (0300:1002:6939) Display controller ATI Technologies Inc:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI



mhwd -lh:

> PCI devices:
--------------------------------------------------------------------------------
                          TYPE            BUS   CLASS  VENDOR  DEVICE   CONFIGS
--------------------------------------------------------------------------------
       Mass storage controller   0000:00:17.0    0106    8086    a102         0
             Memory controller   0000:00:1f.2    0580    8086    a121         0
     Generic system peripheral   0000:00:08.0    0880    8086    1911         0
  Signal processing controller   0000:00:15.1    1180    8086    a161         0
                        Bridge   0000:00:1f.0    0601    8086    a143         0
                        Bridge   0000:00:01.0    0604    8086    1901         0
      Communication controller   0000:00:16.0    0780    8086    a13a         0
            Display controller   0000:01:00.0    0300    1002    6939         2
  Signal processing controller   0000:00:1e.0    1180    8086    a127         0
         Multimedia controller   0000:00:1f.3    0403    8086    a170         0
                        Bridge   0000:00:00.0    0600    8086    191f         0
  Signal processing controller   0000:00:15.0    1180    8086    a160         0
         Multimedia controller   0000:01:00.1    0403    1002    aad8         0
  Signal processing controller   0000:00:14.2    1180    8086    a131         0
            Network controller   0000:00:1f.6    0200    8086    15b8         0
         Serial bus controller   0000:00:14.0    0c03    8086    a12f         0
         Serial bus controller   0000:00:1f.4    0c05    8086    a123         0


> USB devices:
--------------------------------------------------------------------------------
                          TYPE            BUS   CLASS  VENDOR  DEVICE   CONFIGS
--------------------------------------------------------------------------------
           Mass Storage Device        4:0:0:0   10600    0951    1666         0
            Network controller        1-2:1.0    0200    0bda    0811         0
                         Mouse        1-1:1.1   10503    046d    c534         0
                           Hub        1-0:1.0   10a00    1d6b    0002         0
                      Keyboard        1-1:1.0   10800    046d    c534         0
                           Hub        2-0:1.0   10a00    1d6b    0003         0

Seems to be similar to this. What is the output of hwinfo --gfx?

14: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: VCu0.k_0KSzFkQn9
  Parent ID: vSkL.ejyMagArxX2
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "ATI Tonga PRO [Radeon R9 285/380]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x6939 "Tonga PRO [Radeon R9 285/380]"
  SubVendor: pci 0x174b "PC Partner Limited / Sapphire Technology"
  SubDevice: pci 0xe305 
  Revision: 0xf1
  Driver: "amdgpu"
  Driver Modules: "amdgpu"
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  Memory Range: 0xd0000000-0xd01fffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xe0ff (rw)
  Memory Range: 0xdfe00000-0xdfe3ffff (rw,non-prefetchable)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 126 (1735375 events)
  I/O Port: 0x00 (rw)
  Module Alias: "pci:v00001002d00006939sv0000174Bsd0000E305bc03sc00i00"
  Driver Info #0:
    Driver Status: amdgpu is active
    Driver Activation Cmd: "modprobe amdgpu"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #12 (PCI bridge)

Primary display adapter: #14

So maybe the xorg config fails to know my BusId address of my graphics card?

The question is rather what the exact issue is. Any kernel beyond 414 doesn't boot into a graphical environment, but you're still able to boot into a TTY (console)? Checked already the Arch Wiki about AMDGPU ?

I set 3 on boot config in grub. I couldn't get into linux 417 into No-GUI mode.

The only thing that the wiki page may explain is that maybe the screen depth is totally incompatible with my drivers on recent versions of linux? Or that maybe the Xorg configs just doesn't work on newer versions of linux? Other than checking if my drivers are installed, i don't see any other part of the wiki page that is related to my problem.

EDIT: i can't boot into the iso-live beta version of manjaro. What is going on?

curiously enough, the only config text file i see in /etc/X11/xorg.conf.d/ is keyboard.conf

How is your monitor connected? I had a similar issue with a VGA connection, but DVI / HDMI worked.

I have a VGA connection. Are you telling me i have to buy a DVI/HDMI connection to use newer versions of linux? Why?

Try to add the kernel parameter amdgpu.dc=0
Take a look on my topic

Why? I have no idea why VGA doesn't work with DC enabled.

sorry, but how do i add the kernel parameter? in grub?

Edit /etc/default/grub, the parameter to GRUB_CMDLINE_LINUX_DEFAULT="quiet amdgpu.dc=0"
Then run sudo update-grub

3 Likes

OMG IT WORKED! Thank you so much. Who thought the responsible of all of this is the VGA? Could a patch resolve that issue in the future for future AMD users with the same problem as i? I can't thank you enough!

1 Like

There are several bug reports with AMDGPU and DC with a VGA connection: https://bugs.freedesktop.org/buglist.cgi?quicksearch=amdgpu%20dc%20vga
Let's hope they can fix it.

2 Likes

I had the same issue with manjaro deepin and vfs_monitor

maybe this one helps: Kernel 4.17, systemd-modules-load.service is failed to start

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by