Cannot upgrade neither jre nor jdk to 14-1 from the AUR because upgrading one would break the other.

Upgrading jre and jdk from version 13.0.2-1 to 14-1 is impossible, as upgrading jre would break jdk 13's requirement of jre < 14, and similarly upgrading jdk would break jre 13's requirement of jdk < 14.

The exact message is:
error: failed to prepare transaction (could not satisfy dependencies) :: installing jre (14-1) breaks dependency 'jre<14' required by jdk.

I have tried to run yay -S jdk jre to no avail.

Is this fixable or is it just a problem with the packages?

yay is not a package manager, but a wrapper and AUR helper.

In official extra repositories and by default you have jdk-openjdk and jre-openjdk both at version 13 ... Will not go away the way you think
For jre and jdk version 14 please read the comments in the AUR package
https://aur.archlinux.org/packages/jre
https://aur.archlinux.org/packages/jdk

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by