Canon GM4000 printing

Hey there,

I got a new Canon GM4000 printer and I would like to print with it over Wifi.

I managed to get it working on my Mom's PC (Kubuntu 20.04) over USB with some weird installer Canon offers on the asian market, but on Manjaro this installer doesn't work.
I tried various PPD's out of the installer archive but non of them worked for me (I honestly don't know what PPD this installer used on the other PC).
I tried the generic drivers, they don't work.
Does anyone of you know what else I can try?

Our old Canon IP printer worked out of the box on Manjaro. I didn't even needed to install it, it was just there.

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.3
KDE Frameworks Version: 5.72.0
Qt Version: 5.15.0
Kernel Version: 5.7.9-1-MANJARO
OS Type: 64-bit
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: Radeon RX Vega 64

Please tell me, if you need anything else.
Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by