Canon MG2900 wi-fi printer's scan doesn't work

Hello.
The network printing function works fine, but the scanner function doesn't. As I try to scan with Skanlite or Gscan2pdf I get an error message Invalid argument that can be seen here in the output of journalctl:

jun 24 02:04:00 alice-pc skanlite[3159]: qt5ct: using qt5ct plugin
jun 24 02:04:00 alice-pc skanlite[3159]: "deviceOption value="
jun 24 02:04:00 alice-pc skanlite[3159]: ("image/bmp", "image/jpeg", "image/png", "image/vnd.microsoft.icon", "image/x-portable-bitmap>
jun 24 02:04:10 alice-pc skanlite[3159]: "pixma:MG2900_5B77C6000000"
jun 24 02:04:10 alice-pc skanlite[3159]: "pixma:MG2900_5B77C6000000"
jun 24 02:04:13 alice-pc skanlite[3159]: "pixma:MG2900_5B77C6000000"
jun 24 02:04:13 alice-pc skanlite[3159]: "button-1" optDesc->cap = 68
jun 24 02:04:13 alice-pc skanlite[3159]: "button-2" optDesc->cap = 68
jun 24 02:04:13 alice-pc skanlite[3159]: "original" optDesc->cap = 68
jun 24 02:04:13 alice-pc skanlite[3159]: "target" optDesc->cap = 68
jun 24 02:04:13 alice-pc skanlite[3159]: "scan-resolution" optDesc->cap = 68
jun 24 02:04:13 alice-pc skanlite[3159]: "1 instead of 0 arguments to message { %} supplied before conversion."
jun 24 02:04:13 alice-pc skanlite[3159]: "pixma:MG2900_5B77C6000000"
jun 24 02:04:35 alice-pc skanlite[3159]: sane_read= 4 = Invalid argument
jun 24 02:04:38 alice-pc skanlite[3159]: sane_read= 4 = Invalid argument

The output of scanimage -L is

device `pixma:MG2900_5B77C6000000' is a CANON Canon PIXMA MG2900 Series multi-function peripheral

I tried to do these instructions here https://wiki.archlinux.org/index.php/SANE#Invalid_argument , but I don't know what to do.

If anyone here have this printer working over network, please tell me how to make it work. Thanks a lot.

Have a look here

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by