CanoScan LIDE 300 only scans with scangearmp2 from AUR

Hello folks,

so i recently switched over to Manjaro from Mint ;).
While I'm really liking it, I struggle to get my CanoScan LIDE 300 working...

After some time i figured out that the AUR Package (scangearmp2) is working (same driver you get from canon, but working :wink: ). Unfortunately the GUI is just awful...

I then tried to get it working with SimpleScan and xSane or others, but none of them is able to find the scanner...

Is this a driver related problem or the software?! Or the Scanner?
Didn't find the scanner in the sane documentation either... (Sane)

  • Linux DeskPc 4.19.49-1-MANJARO #1 SMP PREEMPT Sun Jun 9 20:24:20 UTC 2019 x86_64 GNU/Linux
  • Bus 003 Device 003: ID 04a9:10dc Canon, Inc. <=== this should be the scanner... (or the printer xD)
  • Bus 004 Device 003: ID 04a9:1913 Canon, Inc.

Searched the forum for an answer and there are several CanoScan Lide topics...
But didn't find a hint in them what I could try out next.

I would really appreciate some help from you Linux Pros - I'm still a newbie yet and try to figure out how everything works :slight_smile:

https://wiki.archlinux.org/index.php/SANE

Hello,

thank you for replying :blush:
I tried the sane-find-scanner and it found the scanner I guess:

sudo sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not fetch string descriptor: Pipe error
found USB scanner (vendor=0x04a9 [Canon], product=0x1913 [LiDE 300]) at libusb:004:003
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

I then tried the scanimage -L command:

sudo scanimage -L
Created directory: /var/net-snmp
Created directory: /var/net-snmp/mib_indexes

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

I just read, that you can edit the /etc/default/tlp file and blacklist the usb device (no success...) and that you can try to force usage of a device id /etc/sane.d/canon_dr.conf (no success either...).

I found the Scanner in the list you provided with the link, but I've no idea how to get it running... Lists under backend: pixma (0.23.0) .

Any help is appreciated :smiley:

As my previous post is kind of misleading:
The scanner does work, but only with the scangearmp application and with limited functionality...
Just 300 dpi, one paper to pdf at a time (you have to use pdfsam or else to merge them).

I got it working with Mint but dont know how i did it :wink:

I had an LiDE 50 up until recently which worked fine with xsane and standard sane backends, not pixma. The only reason I don't have it is because I have an HP multifunction now so no longer need a separate flatbed.

Is your scanner part of a multi-function printer? If not, why use pixma?

Nope - it's just the flatbed scanner, no multifunction device. Sane just lists it under the pixma backend Sane: Backend (Drivers) Version pixma (0.23.0). You should find it there (see screenshot attached).

screenshot

So - the next idea I'll try is to clone the sane git project, make install it with the pixma 0.23.0 backend.
Do you think it's worth a shot? Or is there a easier way to get this working via AUR or something ?

before you go to all that effort, please fire up the Live ISO and install xsane in the live environment (it may add some dependencies to that install list but you should have more than enough RAM to deal with it). see if the scanner is recognised and works okay like that with just sane backends alone. that page may be out of date, stranger things have happened. It's worth a shot anyhow even if it goes nowhere.

The AUR driver package you installed does not contain the right profile for your scanner, that's why it won't work properly with it.

Hello @anon71843593,

i'll try that for sure, thanks for the suggestion! :blush:

Got the idea to set up a small Lubuntu or Mint VM and forward the USB port to it... as said before it worked properly with Mint (with the .deb file from canon) for a while. Really not sure if that works, but should be the least effort I think (having to start a vm for scanning is not the preferred variant but better than using scangear + pdfsam every time... :slight_smile: .)

I'll let you know what I've achieved in a few days.

Forum kindly sponsored by