Can't access forum directly from url on PC

i had a suspicion on the timing: waterfox 56 was installed 12/2. downgrading to 55 solved the problem. that doesn't tell me what the problem IS, though, and not everyone having it is on waterfox.

Hai @all,

if i try to connect direct to the Forum site i often get:

"
Cannot load app

It looks like you are offline! Please check your network connection and try again.
"

If i load my complete "daily dir" from Fx 57 favorites it works perfect!

Maybe this is a problem since the new established Network connecton inside the Kernel is handled(?)

I hope this can help:
https://kernelnewbies.org/Linux_4.14#head-215daabb65fc6088e3858048fd71f10fb6aa8041

Sorry if this is no help, i'm not a professional supporter.

inxi

System:    Host: manjaro Kernel: 4.14.7-1-MANJARO x86_64 bits: 64 gcc: 7.2.1
           Desktop: Xfce 4.12.4 (Gtk 2.24.31) info: xfce4-panel dm: lightdm Distro: Manjaro Linux
Machine:   Device: desktop System: Dell product: Precision WorkStation T3500 serial: N/A
           Mobo: Dell model: 09KPNV v: A00 serial: N/A BIOS: Dell v: A17 date: 05/28/2013
           Chassis: type: 7 serial: N/A
CPU:       6 core Intel Xeon W3680 (-MT-MCP-) arch: Nehalem rev.2 cache: 12288 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 40018
           clock speeds: min/max: 1596/3326 MHz 1: 1596 MHz 2: 1596 MHz 3: 3326 MHz 4: 1596 MHz 5: 1596 MHz
           6: 1596 MHz 7: 3326 MHz 8: 3326 MHz 9: 3326 MHz 10: 1596 MHz 11: 1596 MHz 12: 1596 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 960] bus-ID: 02:00.0 chip-ID: 10de:1401
           Display Server: x11 (X.Org 1.19.5 ) driver: nvidia Resolution: 2560x1440@59.95hz
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 version: 4.5.0 NVIDIA 384.98 Direct Render: Yes
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel bus-ID: 02:00.1 chip-ID: 10de:0fba
           Card-2 Intel 82801JI (ICH10 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:3a3e
           Sound: Advanced Linux Sound Architecture v: k4.14.7-1-MANJARO
Network:   Card: Broadcom Limited NetXtreme BCM5761 Gigabit Ethernet PCIe
           driver: tg3 v: 3.137 bus-ID: 05:00.0 chip-ID: 14e4:1681
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 7065.4GB (60.1% used)
           ID-1: /dev/sda model: ADATA_SP900 size: 64.0GB serial: <filter>
           ID-2: /dev/sdc model: WDC_WD2003FYPS size: 2000.4GB serial: <filter>
           ID-3: /dev/sdd model: WDC_WD2003FYPS size: 2000.4GB serial: <filter>
           ID-4: /dev/sdb model: ST3000VX000 size: 3000.6GB serial: <filter>
Partition: ID-1: / size: 48G used: 20G (42%) fs: btrfs dev: /dev/sda2
           ID-2: /boot size: 976M used: 153M (16%) fs: ext3 dev: /dev/sda1
           ID-3: /home size: 2.7T used: 1.4T (54%) fs: ext4 dev: /dev/sdb1
           ID-4: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 30.8C mobo: N/A gpu: 0.0:48C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 278 Uptime: 2 days Memory: 7042.8/12010.3MB Init: systemd v: 235 Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121 running in xfce4-terminal) inxi: 2.3.53 

If more informations are needed please ask for it.

Thanks in advance
LAZA

that's a new take on the problem, i might try switching kernels and see if it helps.

edit: nope, 4.9 has the same problem.

But it (must?) have to do something with the internet speed or answer times of the website.
And it might, that the faster access on websites was backported to the older LTS kernels.

In my daily dir, which i open up all at once with a middle click, the site is everytime(!) there.
And if the connection is established it works a second, third, ... time.

But not the other way round.

Other idea:
I'm permanent logged in, might this cause problems?

*arrrrrrrrrrrrgggggggggggggggghhh

This is really annoying cause i can write here in this Fx window but cannot reload a written text inside the forum - all it get is this fücking Cannot load app.

I can't debug this unless I can replicate it, and I've never had this issue.

If one browser (or a clean profile) works but another doesn't, then it's something you've configured in that browser. If no browsers work, then it moves it towards something network-related.

Given this:

I suspect it's browser-related.

more specifically browser version related. waterfox 56 pulled in a bunch of patches from firefox 57. i don't have the problem with waterfox 55. is anyone using a firefox other than 57 having the problem? did those patches get pulled into the latest ff 52 esr as well?

Not sure how I missed this first time round. Can you provide an example? When i click an external link it opens in a new tab so there's no"back" to the forum.

in interface: " Open all external links in a new tab".

1 Like

Huh... I just looked there and missed that entirely. :slight_smile:

Edit:

After a quick test (clicked the Waterfox link above, clicked the back button), I can't replicate by this method either... :slightly_frowning_face:

The only reliable way for me to cause that is when my WWAN (LTE) drops (the modem thends to sometimes dissconnect from USB BUS) and modemmanager has not yet fully realized that there isn't a f*kn modem anymore.

But than the client/server connection is of course terminated... but as part of the forum must be client side (I learned) I do not get the 404 but rather that "can't load app" - another forum I frequent that uses phpBB just throws the 404 when I click a link (eg. newest)

I have noticed this occuring when I log in to the Manjaro forum and then without logging out open and browse another site from within the same tab. Then the problem manifests when I return to the forum using back button. (This with FF57.)

Well - it was triggered by the todays forum downtime, but with every browser I once successfully accessed the forum (and had not cleared the cache) I got the "Cannot load app" page - with Google Chrome (which I rarely use) I got "ERR_CONNECTION_REFUSED".

So it turns out rather - obvious - that when ever the server isn't responding (due to what ever reason) discourse shows the "Cannot load app" client side;

forum_error
(Firefox above - google chrome below)

2 Likes

Happened to me yesterday evening every time i reload the browser (F5, Firefox).

Opening up a new window and type partly the URL i could connect again - switching back still the same error!

Oh the frustration! :disappointed:

Screenshot_2018-01-08_15-40-33

seems to be fixed with today's waterfox-bin 56.0.2.

....but it's not remembering my text zoom settings, ugh...

ah, that's my own fault.

got it, @jonathon. setting

extensions.e10sMultiBlockedByAddons
extensions.e10sBlockedByAddons

to true enables e10s even though i supposedly have add-ons conflicting with it. setting them to false disables e10s. the forum works properly when it's disabled. it's not the add-ons themselves, they're active either way.

2 Likes

I can't solve this problem. In the about:config:
extensions.e10sMultiBlockedByAddons false
extensions.e10sBlockedByAddons false
don't get me free of this problem. I still got Cannot Load App every time I tried to access a tab I let to be open when I close Firefox

does about:support still show multiprocess windows as enabled?

Yes, enabled by default

Forum kindly sponsored by