Can't access forum directly from url on PC

I can't debug this unless I can replicate it, and I've never had this issue.

If one browser (or a clean profile) works but another doesn't, then it's something you've configured in that browser. If no browsers work, then it moves it towards something network-related.

Given this:

I suspect it's browser-related.

more specifically browser version related. waterfox 56 pulled in a bunch of patches from firefox 57. i don't have the problem with waterfox 55. is anyone using a firefox other than 57 having the problem? did those patches get pulled into the latest ff 52 esr as well?

Not sure how I missed this first time round. Can you provide an example? When i click an external link it opens in a new tab so there's no"back" to the forum.

in interface: " Open all external links in a new tab".

1 Like

Huh... I just looked there and missed that entirely. :slight_smile:


After a quick test (clicked the Waterfox link above, clicked the back button), I can't replicate by this method either... :slightly_frowning_face:

The only reliable way for me to cause that is when my WWAN (LTE) drops (the modem thends to sometimes dissconnect from USB BUS) and modemmanager has not yet fully realized that there isn't a f*kn modem anymore.

But than the client/server connection is of course terminated... but as part of the forum must be client side (I learned) I do not get the 404 but rather that "can't load app" - another forum I frequent that uses phpBB just throws the 404 when I click a link (eg. newest)

I have noticed this occuring when I log in to the Manjaro forum and then without logging out open and browse another site from within the same tab. Then the problem manifests when I return to the forum using back button. (This with FF57.)

Well - it was triggered by the todays forum downtime, but with every browser I once successfully accessed the forum (and had not cleared the cache) I got the "Cannot load app" page - with Google Chrome (which I rarely use) I got "ERR_CONNECTION_REFUSED".

So it turns out rather - obvious - that when ever the server isn't responding (due to what ever reason) discourse shows the "Cannot load app" client side;

(Firefox above - google chrome below)


Happened to me yesterday evening every time i reload the browser (F5, Firefox).

Opening up a new window and type partly the URL i could connect again - switching back still the same error!

Oh the frustration! :disappointed:


seems to be fixed with today's waterfox-bin 56.0.2.

....but it's not remembering my text zoom settings, ugh...

ah, that's my own fault.

got it, @jonathon. setting


to true enables e10s even though i supposedly have add-ons conflicting with it. setting them to false disables e10s. the forum works properly when it's disabled. it's not the add-ons themselves, they're active either way.


I can't solve this problem. In the about:config:
extensions.e10sMultiBlockedByAddons false
extensions.e10sBlockedByAddons false
don't get me free of this problem. I still got Cannot Load App every time I tried to access a tab I let to be open when I close Firefox

does about:support still show multiprocess windows as enabled?

Yes, enabled by default

that's what you're trying to disable

1/1 (Habilitado por padrão)

change to what? disable? 0/1
does not solve

There are now two threads for this:


Can people please try with clean browser profiles. Disabling multiprocess, which only doesn't work with "old" extensions, isn't a real answer.

1 Like

The answer for ME was to ALSO clear off-site data when clearing cache & shutting down.
Only worked for shutting down & restarting but not for closing tab & re-opening it in the same browser session.

UPDATE: Now it's ALL working, go figure!

What's new in Waterfox 56.2.2?

Large amounts of security fixes and bug fixes are in this release and should solve two main issues:


  • Corrupted Content issue on website that use service workers.
1 Like

Forum kindly sponsored by