Can't access grub nor Windows after installing Manjaro

Hi everyone,
After using Ubuntu 18.04 and Windows 10 in dual boot I decided to replace the Ubuntu partition with Manjaro, and now I cannot boot into Windows because my laptop boots automatically to Manjaro and GRUB is gone. The Windows partition is untouched and I can browse the files using Dolphin.

I followed the instructions to restore GRUB in the wiki and then I tried this method by @gohlip including the UEFI section, but unfortunately I'm still not able to boot into GRUB. I even tried enabling and disabling secure boot, as recommended for Acer machines, but it's still not working :pensive:

I'm using an Acer E15 E5-575G, and I also gathered following info:

$ efibootmgr -v

BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0006,0000,0001,0002,0004,2001,2002,2003
Boot0000* manjaro       HD(1,GPT,286a9108-6081-4821-9199-540ee6b59f12,0x16daf800,0x12c000)/File(\EFI\manjaro\grubx64.efi)
Boot0001* grubx64       PciRoot(0x0)/Pci(0x17,0x0)/Sata(2,0,0)/HD(1,GPT,286a9108-6081-4821-9199-540ee6b59f12,0x16daf800,0x12c000)/File(\EFI\Manjaro\grubx64.efi)A01 ..
Boot0002* grubefi       PciRoot(0x0)/Pci(0x17,0x0)/Sata(2,0,0)/HD(1,GPT,286a9108-6081-4821-9199-540ee6b59f12,0x16daf800,0x12c000)/File(\grub\x86_64-efi\grub.efi)A01 ).
Boot0003* usbm  PciRoot(0x0)/Pci(0x14,0x0)/USB(13,0)/HD(1,MBR,0x0,0x4c7688,0x2000)/File(\efi\boot\bootx64.efi)A01 ..
Boot0004* coreefi       PciRoot(0x0)/Pci(0x17,0x0)/Sata(2,0,0)/HD(1,GPT,286a9108-6081-4821-9199-540ee6b59f12,0x16daf800,0x12c000)/File(\grub\x86_64-efi\core.efi)A01 9.
Boot0005* USB HDD: Samsung Flash Drive  PciRoot(0x0)/Pci(0x14,0x0)/USB(13,0)/HD(1,MBR,0x0,0x4c7688,0x2000)RC
Boot0006* manjaro       HD(1,GPT,286a9108-6081-4821-9199-540ee6b59f12,0x16daf800,0x12c000)/File(\EFI\Manjaro\grubx64.efi)
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC

$ sudo parted -l
 
Model: ATA KINGSTON RBU-SNS (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start  End    Size    File system  Name                          Flags
 2      106MB  123MB  16,8MB               Microsoft reserved partition  msftres
 3      123MB  196GB  196GB   ntfs         Basic data partition          msftdata
 1      196GB  197GB  629MB   fat32                                      msftdata
 4      197GB  256GB  58,6GB  ext4
 6      256GB  256GB  524MB   ntfs         Basic data partition          hidden, diag


Model: Samsung Flash Drive (scsi)
Disk /dev/sdb: 32,1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2566MB  2570MB  4194kB  primary               esp

$ sudo blkid

/dev/sda1: UUID="33F5-C231" TYPE="vfat" PARTUUID="286a9108-6081-4821-9199-540ee6b59f12"
/dev/sda3: UUID="01D42DD349606330" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="c426d291-fd62-4cf5-bd26-5fd4f14451be"
/dev/sda4: UUID="bb2428f4-23a0-426d-86c7-8e58712ad96e" TYPE="ext4" PARTUUID="54ee66b0-2a67-452e-abc8-3b0d089b4d95"
/dev/sda6: LABEL="Recovery" UUID="140688D60688B9EE" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="c7b9f5ee-5529-4cd0-8670-726ee0554330"
/dev/sdb1: UUID="2019-10-15-10-44-06-00" LABEL="MJRO1811" TYPE="iso9660"
/dev/sdb2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="1279-4CF4" TYPE="vfat"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="6c446e9f-d9a7-483a-902d-a9268751e00d"

$ findmnt -s

TARGET    SOURCE                                               FSTYPE OPTIONS
/boot/efi   UUID=33F5-C231                            vfat   umask=0077
/                  UUID=bb2428f4-23a0-426d-86c7-8e58712ad96e ext4           defaults,noatime,discard
/tmp             tmpfs                                     tmpfs  defaults,noatime,mode=1777

$ findmnt /boot/efi
TARGET        SOURCE    FSTYPE OPTIONS
/boot/efi     /dev/sda1    vfat   rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=r

I really appreciate any help :slight_smile:

First, at starting computer, try tapping 'esc' key and let us know if grub menu appears.
Second, when you install Manjaro, did you format $esp (sda1)?

Lastly...
From manjaro terminal, print out output

ls /boot/efi/
ls /boot/efi/efi/
ls /boot/efi/efi/Microsoft/

Then from manjaro's file manager, go to the ntfs partition sda3
look at the the base partition (not in any folder) and see if there is any file called 'bootmgr'

Or if you are sure ntfs is sda3 (use lsblk -f) and comfortable with following command, it may be easier to do this. Print output. Say 'none' if no output.

sudo mount -t ntfs-3g -o remove_hiberfile /dev/sda3 /mnt
ls /mnt/bootmgr

ps: I think you formatted sda1 when installing manjaro. There is no 'ubuntu' entry either in your 'efibootmgr'.

3 Likes

Thanks for replying so quickly :blush: !!

When I press esc at booting then there's GRUB, but I can only choose between Manjaro and Advanced Options for Manjaro.

The first time I installed Manjaro, I didn't touch the sda1 (106 MB big) partition at all, but since it did boot directly to Manjaro, I thought it had to do with the size (in the docs is recommended to have a /boot/efi partition with at least 512 MB) so I reinstalled Manjaro, formatted the sda1 partition and created a new /boot/efi one with 512 MB and the esp flag ...

Did I make it worse by formatting the sda1 partition in the first place?

This is the output:

$ sudo ls /boot/efi/

EFI  grub

$ sudo ls /boot/efi/efi

boot  Manjaro

$ sudo ls /boot/efi/efi/Microsoft/

ls: cannot access '/boot/efi/efi/Microsoft/': No such file or directory

As for the NTFS sda3 partition, I executed the commands and it prints a blinking /mnt/bootmgr ?
So I checked with the file manager and there's no bootmgr file. I used Alt+. to show hidden files, and I found a file called BOOTNXT but I guess that's something different...

Yes. You will need to reinstall Windows bootloader. Then reinstall Manjaro bootloader. I cannot help with reinstalling Windows bootloader, but we can help with reinstalling Manjaro bootloader when that's done.

As for grub not showing up, we can fix that, remember with Windows and Manjaro only, you will also not see grub. But keep tapping esc key first. We'll fix that later.

Good luck.

So I reinstalled the Windows bootloader , unfortunately I had to delete Manjaro in the process to make free space for the EFI and the MSR partitions, then reinstall Manjaro, added GRUB to the secure boot files in the UEFI Settings and moved it to the top boot order list, and now everything is working as it should =) GRUB boots on start and I can correctly switch when needed.

If it wasn't because Adobe Acrobat Pro, I wouldn't have tried so badly to get access to the Windows partition.

Million thanks for your kind help :smile: I hope to keep learning
Have a nice Weekend

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by