Can't auto-resize guest display in VirtualBox

I've installed Manjaro 18.0.3 in VirtualBox on Windows 10 host. After I installed virtualbox-guest-utils and vitual-box-guest-modules.

local/linux419-virtualbox-guest-modules 6.0.4-6 (linux419-extramodules)
    Guest kernel modules for VirtualBox
local/virtualbox-guest-utils 6.0.4-1
    VirtualBox Guest userspace utilities

Some parts like shared clipboard work just fine, but I can't auto-resize the guest. I'm running VirtualBox 6.0.4. What can be the cause?

System:    Host: Manjaro-KDE Kernel: 4.19.24-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: KDE Plasma 5.15.1 Distro: Manjaro Linux 
Machine:   Type: Virtualbox System: innotek product: VirtualBox v: 1.2 serial: <filter> 
           Mobo: Oracle model: VirtualBox v: 1.2 serial: <filter> BIOS: innotek v: VirtualBox 
           date: 12/01/2006 
CPU:       Topology: Quad Core model: Intel Core i5-6400 bits: 64 type: MCP arch: Skylake-S 
           rev: 3 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 21707 
           Speed: 2712 MHz min/max: N/A Core speeds (MHz): 1: 2712 2: 2712 3: 2712 4: 2712 
Graphics:  Device-1: VMware SVGA II Adapter driver: vmwgfx v: bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.3 driver: vmware resolution: 800x600~60Hz 
           OpenGL: renderer: SVGA3D; build v: 2.1 Mesa 18.3.3 direct render: Yes 
Audio:     Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0 v: kernel 
           bus ID: 00:05.0 
           Sound Server: ALSA v: k4.19.24-1-MANJARO 
Network:   Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: 7.3.21-k8-NAPI 
           port: d020 bus ID: 00:03.0 
           IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge driver: piix4_smbus 
           v: N/A port: d200 bus ID: 00:07.0 
Drives:    Local Storage: total: 60.00 GiB used: 6.42 GiB (10.7%) 
           ID-1: /dev/sda vendor: VirtualBox model: VBOX HARDDISK size: 60.00 GiB 
Partition: ID-1: / size: 19.10 GiB used: 6.28 GiB (32.9%) fs: ext4 dev: /dev/sda6 
           ID-2: /home size: 39.58 GiB used: 146.2 MiB (0.4%) fs: ext4 dev: /dev/sda5 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Info:      Processes: 162 Uptime: 12m Memory: 3.85 GiB used: 471.3 MiB (12.0%) Init: systemd 
           Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.30

It's probably worth trying the other display adapters - VBoxVGA is the most reliable.

I've tried all 3 options, nothing changes. The button is still grayed out.


Same problem for me. It's incredible that nobody else experienced it with a distro as tested as Manjaro!

I first installed Manjaro KDE 18.0.4 on Windows 10 host (Virtualbox 6.0.4 + proper extension pack).
Then I updated the Manjaro system packages and installed 6.0.4 guest additions from the official Virtualbox ISO, but no luck.

Then I made a clean install and then I installed kernel guest extramodules and guest utils package. No luck.

Then again I updated Virtualbox, its extension pack and the guest additions ISO to 6.0.5 (beta). I made another clean install of Manjaro KDE 18.0.4. Tried both methods. No luck.

Eventually I made another clean install of Manjaro KDE 18.0.4 and switched to testing updates. Tried both methods once again. No luck.

So... no matter what I do and no matter my determination, I can't get Virtualbox guest screen auto-resize to work.

A year ago I installed Manjaro 17 on Virtualbox 5.1 and it worked like a charm, without even installing the guest additions. What are we supposed to do now?

As @jonathon pointed out use VBoxVGA and make sure mhwd is using video-virtualbox.

I experienced the same issue, the default virtual adapter in VBox 6 changed, specifically selecting VBoxVGA during VM creation was my solution.

@philm does mhwd need to be altered to ensure VBoxSVGA doesn't default to video-vmware?


Thanks. My mistake was I've switched after the installation, but didn't run mhwd.

1 Like

Thanks, I will try that.

So how should I proceed as soon as Manjaro guest is installed? Personally I would do the following:

  1. sudo pacman -Syyu
  2. run mhwd to check that it's using video-virtualbox
  3. sudo pacman -S linux419-headers
  4. install VBox-guest-additions from the original Vbox GA ISO

Cool or not?

And also, should I create the VM as Linux 2.6 / 3.x / 4.x or Arch-Linux? I am asking since I also have a MX Linux VM which works smoothly because it was installed as Linux 2.6 / 3.x / 4.x, but it caused a bunch of issues when created as Debian.

Check your Vbox VM Display Settings and make sure it is set to VBoxVGA. If you do this before installing Manjaro then this is all you need to do, mhwd will automatically use video-virtualbox.

If your guest Manjaro OS is already installed all then just use mhwd to remove video-vmware and install video-virtualbox. Reboot.

No need for kernel header packages or running the vbox guest addition scripts on a Manjaro guest, kernel guest extramodules and guest util packages are already installed.


I tried to set the existing VM to VBoxVGA, then I ran mhwd and I found that it was already using video-virtualbox... but that simple trick didn't work.

So I made a clean installation of Manjaro using VBoxVGA right from the start: auto-resize worked out of the box!!

Then I updated the Manjaro system, switched the VM off, turned 3D acceleration on... I even added VirtualBoxVM.exe to Nvidia control panel on Windows 10 (host): Manjaro does still work flawlessly! Many many thanks for helping us out!

This helped me. Specifically:

  1. installing the correct driver and uninstalling the incorrect one

mhwd -i pci video-virtualbox
mhwd -r pci video-vmware

  1. shutdown and change the VM graphics controller to VboxVGA

I had already done everything else correctly.

Thank you.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by