Can't boot after installing Nvidia drivers

Last night I installed nvidia drivers via sudo mhwd -a pci nonfree 0300. After that finished I rebooted and I could not log in back. I get a message saying invalid environment block and after pressing any key I get another message saying setting irq mode 1 for irq 143 failed and it just halts there. After a second or so the fans also go wildly fast.

I honestly don't even know how to start a command line from there, since all I get is a the grub command line from the grub menu. Any pointers on how to solve this?

1 Like

Please post your hardware specs by using the live environment. We need to know the hardware involved:

inxi -Fxxxz
  Host: manjaro-budgie Kernel: 4.14.65-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.0 Desktop: Budgie 10.4-81-g733742a4 
  info: budgie-panel wm: budgie-wm dm: lightdm 1.26.0 Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: ZenBook Pro 15 UX550GDX_UX580GD 
  v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: UX550GDX v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: UX550GDX.301 date: 08/10/2018 
  ID-1: BAT0 charge: 12.6 Wh condition: 70.8/73.0 Wh (97%) volts: 15.7/15.7 
  model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> status: Charging 
  Device-1: hid-0003:04F3:2706.0003-battery model: ELAN Touchscreen 
  serial: N/A charge: N/A status: N/A 
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Skylake rev: A L2 cache: 9216 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
  Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 801 
  3: 800 4: 801 5: 800 6: 801 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Card-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:3e9b 
  Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8d 
  Display: x11 server: N/A driver: intel unloaded: fbdev,modesetting,vesa 
  compositor: budgie-wm resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 18.1.6 compat-v: 3.0 direct render: Yes 
  Card-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k4.14.65-1-MANJARO 
  Card-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: down mac: <filter> 
  Card-2: IMC Networks type: USB driver: uvcvideo bus ID: 1:4 
  chip ID: 13d3:5755 
  Local Storage: total: 534.69 GiB used: 1.71 GiB (0.3%) 
  ID-1: /dev/sda vendor: Micron model: 1100 MTFDDAV512TBN size: 476.94 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: A031 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 
  size: 57.75 GiB serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / size: 11.64 GiB used: 48.6 MiB (0.4%) fs: overlay dev: ERR-102 
  System Temperatures: cpu: 57.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 275 Uptime: N/A Memory: 15.52 GiB used: 806.8 MiB (5.1%) 
  Init: systemd v: 239 Compilers: gcc: N/A Shell: bash v: 4.4.23 
  running in: gnome-terminal inxi: 3.0.20

could you explain a little more, ive only been able to find info related to grub issues but it was in reference to ubuntu so i wouldnt blindly follow its direction. besides there is a manjaro wiki to restore grub bootloader. in that wiki, it explains step by step of what to do including manjaro-chroot. if this is your issue, that wiki is a quick and simple fix.

if the above does not work out, boot back into the live environment,then
manjaro-chroot -a
connect to wifi/ethernet
and post the relevant info from here:

answers to these could be helpful:
is this a new installation?
was it fully working prior to changing to nonfree drivers?
did you do something other than change drivers before this happened?
can you boot to grub? or does it fail before getting to grub?
when you boot the live environment, does it boot using the non-free option?

1 Like

You may try this tutorial for basic troubleshooting

I'll answer your questions in the order they appeared

  • It is a "new" installation (new notebook actually), it had been running for about 2 weeks and it had already been rebooted, if that matters.
  • Fully is a strong word, but it did work. There were some driver issues (this ZenBook has the screenpad, which obviously doesn't work as such), but it was my daily rig so I can definitely say it was working decently enough.
  • Not really
  • It does get to grub. Sorry for not being clear about that.
  • I haven't tried choosing non-free in the live environment, but I'll do once I get home and report back.

One detail that I skipped and might be relevant is that installing manjaro was semi painful and in the process of going crazy I tried installing ubuntu as well, to check whether it was working. In the process of that installation I seem to have left the ubuntu bootloader on my system. I'm saying this because when I change my boot sequence order I see the Windows bootloader (I'm doing dual boot with the original windows copy that came with this notebook), the manjaro bootloader (2 of them for some reason; I installed manjaro multiple times before the successful installation), and the ubuntu bootloader as well. So it might as well be an issue with the bootloader.

I'll try restoring grub by the following the link you provided. Is there something I should take into consideration when doing this in a dual boot environment?

in short, manjaro's grub can boot ubuntu but ubuntu's grub cannot boot manjaro.

no, should be fine. when you restore grub, it will detect your other os's on the system.

assuming you use UEFI:
-boot into live environment
-connnect networking (wifi/ethernet/etc..)
sudo blkid -o list -c /dev/null
-take note of your drive layout, what partition the /efi/boot is located (usually sda1, but make sure)
-in terminal do the following:
mhwd-chroot -a
-enter pw for live environment "manjaro" and if prompted select which drive/partition manjaro is installed on, it should go something like thise:

[dglt@dglt-2 ~]$ manjaro-chroot -a
[sudo] password for dglt: 
==> Mounting (ManjaroLinux) [/dev/sdb2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[dglt-2 /]# 

-you are now chrooted, and partitions mounted and now have control of your already installed manjaro. then do the following:
pacman -Syyu
pacman -S mtools os-prober
and install if they are not installed already, and then:
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub
if all goes well, your manjaro grub should come right up and you should be able to boot manjaro or windows. good luck, let me know if it works out


No luck!

I followed your response and part of because I had some unexpected messages along the way, but eventually I got to a successfuly installed message. But still, it hangs while loading manjaro (after grub) with the message setting irq mode 1 for irq 143 failed.

The message saying invalid environment block seems to have gone though.

After rebooting a second time I got an additional message. Failed to start clean up modles from old kernels. See systemctl status linux-module-cleanup.service for details.

On another note, I tried running the live environment with non-free drivers and the same issue seems to appear. It hangs while trying to boot and starts spinning the fans at full speed. So I guess what's left for me is try and uninstall the drivers? Should/can I do that from mhwd-chroot?

yes, after you connect networking
manjaro-chroot -a
mhwd -li
that will show a list of installed drivers, remove all the video drivers with
sudo mhwd -r pci video-nvidia
and any others installed and then install new ones
sudo mhwd -a pci free 0300

while your chrooted in can you post output of:
systemctl status linux-module-cleanup.service
mhwd-kernel -li

1 Like

This service is a part from kernel-alive package, probably included in Budgie(?) or manually installed. So, there maybe two different issues, video drivers and kernel update.
Try to boot to TTY and update your system with pacman.
I don't know anything about troubleshooting kernel-alive.

1 Like

\o/ that did it!

Thanks, you've all been of great help!

I should probably try and update kernel, I have a message saying that there are updates available. But given how much of a pain it was to set up I was really afraid to update anything. I guess I should eventually man up though.

so your able to boot into your manjaro install without issue now?

do a full update
sudo pacman -Syyu
use manjaro settings manager to install a new kernel, its a good idea to have 2 installed anyway in case something goes wrong with one, you can select another from grub in advances options

1 Like

I am now able to boot into my installed manjaro, yes!

It seems to be having an issue with the wifi adapter though, cause I can't connect to any wifi network anymore. :man_shrugging:

EDIT: I guess I sang too early.. I now rebooted and I get a you are in emergency mode, after logging in type journalctl to view system logs...

so you cant load a desktop environment now?
can you get to a tty, if yes do you have network support?
if yes, run a full update pacman -Syyu and install another kernel, reboot and choose the new kernel at grub from advanced options.
sudo mhwd-kernel -i linux419
or if your already using linux419, install linux418 or 414, just install a new kernel and try it.


Try some kernel fallback option at Grub menu

1 Like

Installing kernel 4.19 did the job! It's now working again (after a just-to-be-sure reboot). And wifi is back up again as well.

Again, thank you all! Amazing support from this forum!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by