Can't boot after system upgrade

Did you install these packages?
Rebooted?

Provide

pacman -Q efivar
pacman -Q efibootmgr

Sorry, forgott to tell you they were already installed :slightly_smiling_face:

$ pacman -Q efivar
efivar 37-1
$ pacman -Q efibootmgr
efibootmgr 16-1

Okay, modules for kernels in uefi and bios-legacy are built differently.
As said, you had chrooted in bios-legacy and done grub-install.
And without exiting chroot and doing other operations while in chroot will cause problems.
Reinstalling would be best and easiest. But if you want to continue to try, boot up in uefi again.
Install another kernel and see if you can boot to the new kernel (in uefi).

:neutral_face:
Just so that we are one the same page, the measures in Unable to boot won't do anything good?

But anyway, I'll try with a new kernel

when I installed the new kernel I found this in the details dialog

grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.

Probably not a surprise?

No, no surprise. You have nvme. If you remove memtest, you won't have this error. But that's not relevant to your issue. Let's finish the real problem here and not get sidetracked. When done, I can show you a topic on this removing memtest on nvme. That can wait.

Oh, no guarantees new kernel will work as you had chrooted earlier and may have messed up in chroot, as I said. uefi kernels have efivars (yes efivars, not efivar) in the kernel. It may be the issue. Of course I am not certain that's your problem.

Just checking. what's

findmnt /
findmnt /boot
findmnt /boot/efi

[EDITED]

$ findmnt /   
TARGET SOURCE         FSTYPE OPTIONS
/      /dev/nvme0n1p2 ext4   rw,noatime
$ findmnt /boot

(gives nothing)

$ findmnt /boot/efi
TARGET    SOURCE         FSTYPE OPTIONS
/boot/efi /dev/nvme0n1p1 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

Good. now one more test. I'm new to this too, but let's try this

sudo efivar-tester

ps: I think it will test if you have efivars modules

$ sudo efivar-tester
[sudo] password for liblen: 
UEFI variables not supported on this machine.

Okay, you do not have efivars modules.
You said you have efivar package installed.
Let's do this, first modprobe and then do all the commands again..

modprobe efivars

then do the long grub-install command (with --target= and debug recheck)
And do the 2 additional uefi commands (type carefully, please, pause and check for typo, or just copy and paste from above

let us know how it goes. I'm not typing the commands as I am hurrying this out and I may type a typo myself. But you don't ! :joy:

And "modprobe efivars" not "modprobe efivar"

ps: reminder: I have not done this (don't need to, before).
as usual, at your own risk. :rofl:

Hey, correct, I have efivar, not efivars. I read to fast...
I'll try what you wrote!

Meanwhile, thanks for you patientens and support @gohlip

Reminder...

there is a "uefivars-git" package on AUR. Is that the package you meant?

No!! You have package 'efivar' already installed. Not 'efivars' package. No need to install any other package.

But when doing modprobe, do 'modprobe efivars', not 'modprobe efivar'

Yes, that's confusing (and they should do something about it).
Hope this is clear. Good you ask to clarify, though.

$ modprobe efivars
modprobe: FATAL: Module efivars not found in directory /lib/modules/5.0.21-rt16-MANJARO

that's the bothering answer

You have rt kernel? not the 'normal' kernel?
What's

ls /boot/

yes I have. How so?

Forum kindly sponsored by