Can't boot anymore; amdgpu fatal error

First try to boot to prompt.

At grub menu, press 'e’
Arrow down to linux line
Arrow right past ‘quiet’ and 'splash’
Backspace to remove ‘quiet’ and ‘splash’ taking care not to remove 'rw’
Add ‘3’ (without apostrophes meaning just 3)
Press F10 or ‘ctl’ + ‘x’ to boot
login with password to prompt.

If this boots to prompt, most likely a graphic card, and fix your graphic drivers at prompt.
Easier, safer at prompt than from chroot (and chroot from Elementary won't do anyway, has to be chroot from a manjaro OS).

Good luck.

1 Like

Hello, thank you very much for your answer.
I have removed the "quiet" flag, but can't find any "splash".
I have tried it 2 times:

Removing everything after the linux IMG etc. until RW, deleting so the quiet flag and the "resume=..." parameter: this way I could see the logs and the beginning of the boot but then it randomly freezed while loading something and my screen was there full of green OK's.

The second time I removed only the quiet flag, not the resume parameter, and put the 3 in there

Froze again but at an earlier stage.

Still can't access any command line and, being honest, even if I could I don't have a clear idea of what I should do then...

Thank you

Okay, if it froze booting to prompt, it is a more serious problem than graphics, sddm,...
I don't know what else you can do and hope others here can help you.
But good luck and take care.

do you remember installing or uninstalling anything during your last WORKING manjaro session?
did you do an update on your last session?

do you have a manjaro installation media (usb/dvd) you could use to connect to network and chroot in from?
manjaro-chroot -a

@gohlip But maybe I only edited the grub file in a wrong way? There must be a video error seeing that initial log file...

@dglt Sorry I can't find a rapid way to multi-quote well.
Anyways, right now I'm typing from a live USB of Manjaro, the same Manjaro KDE one I used to install the system few days ago. Right now I chrooted into my main Manjaro and executed a pacman mirror update, pretty randomly.
What should I do for now?

Thanks both, really

EDIT: Oh I forgot to reply.
Yes I messed around with packets of normal software; flathub installations of Gimp and Inkcape, Wine and PlayOnLinux attempts to make the Adobe Creative Cloud work, snapd and various music players to find the best one...and maybe even a system update from the pamac GUI.
That's a lot of stuff maybe? It should not be very good to track down the source of my problems

1 Like

good, now you need to provide some more info. read this post and it will tell you exactly how to do that.

there may be some more specific info needed after but for now read that and post relevant info.

lets see if we can find out, first more info is needed

1 Like

I have edited the first post and now there are more logs of various commands, however there is a lot of stuff and I can't see which could and could not be more useful

could you please post output for
mhwd -li
mhwd-kernel -li

[manjaro /]# mhwd
> 0000:01:00.0 (0300:1002:67ff) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:00:02.0 (0380:8086:0152) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

[manjaro /]# mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI

Warning: No installed USB configs!
[manjaro /]# mhwd-kernel -li
Currently running: 4.19.0-3-MANJARO (linux419)
The following kernels are installed in your system:
   * linux418
   * linux419

The linux418 was installed right now in a desperate attempt to change something for next boot, but it is freshly installed and I have never used it until now. Right before this installation the only kernel was the linux419 and that's the only one I have ever used

ok so you have not tried to boot the 4.18 yet? if not, try it now and if it doesnt have any effect then chroot back in and we can try re-installing video drivers and try some kernel parameters to get it to boot

1 Like

Okay I'm rebooting and I'll let you know, anyways I'm answering right now before I have already tried to reinstall the video drivers twice from the Elementary chroot so maybe it's not the best option (?)
Anyways, I'm rebooting...I'll let you know and thank you

EDIT: Okay, I'm in. Writing right from my main Manjaro install, all my files, work and widgets there etc.
So booting from the never-used 4.18 kernel worked. But why, since I have used the 4.19 from the start and it has worked well for 4 days?

Should I consider this a permanent solution? Like, sticking to the 4.18 until some update fixes the newer ones? How should I behave now?

Thank you

yes, use what works. 4.18 is EOL iirc. you could also uninstall/reinstall 4.19 now that you have 4.18 working if you wanted to try it. also its recommended to have 2 kernels installed in case one stops working for any reason, you have a backup. its up to you.
sudo mhwd-kernel -r linux419
sudo mhwd-kernel -i linux419

also, after you are sure all is working well i highly suggest you install timeshift since its very reliable, easy to use and setup and it does periodic rsync backups as often as you set it to automatically. so in the future when something goes wrong you can use timeshift either from your install or even from a bootable usb or chroot. it has saved my installs more than a few times and im also much less concerned when making dangerous changes that i would otherwise not do if i didnt have a backup solution ready, just always try and make an honest attempt to figure out what went wrong before using a backup so you know how and why so you dont repeat it again.

1 Like

Even after being reinstalled, the linux419 managed to crash again.
I'm on 4.18 now; if it's EOL what version would you suggest?

Anyways thank you for your help and your time, I'm marking your answer as the solution.

I always go with LTS - long term support.
Before 4.19 are:


There was a talk that 4.9 may be removed from Manjaro?!?
Anyway, next I would try 4.14

Have you tried to re-install linux419 and linux-firmware? Also does the kernel trigger a initram rebuild for you?

I have installed the 4.14 and will try it. The graphical client still shows the 4.9, but I didn't try installing it.
Thank you

I don't know what a "initram rebuild" does, but I remember having given a command that did exactly this on my first run with the Elementary OS chroot (following a guide). This happened before I tried reinstalling linux419.
Because yes, after having successfully booted from the linux418 I tried reinstalling linux419 and nothing changed.
I have never touched linux-firmware.

What should I do to give it a try, what commands? And most important, in which environment?
My main manjaro running with linux418 or a live CD?


always from manjaro if you can.

pacman -Syu linux419 linux-firmware
mkinitcpio -p linux419

could you tell us what firmware version is currently installed on your system, if that does not work for you?

1 Like

I executed the 2 commands and I'm about to reboot, but I'm writing before that because I don't exactly know what you mean by firmware version (in the context of Manjaro and Linux at least).
What info should I provide to you if at the next reboot kernel 4.19 still won't work


EDIT: Even after those commands, system won't boot with 4.19.

And 4.14 doesn't work too! While I was there I tried it and I'm stuck on a black screen, but at least this time there was a blinking cursor that after some seconds stopped and now it's there doing nothing, like froze.

You could move up the branches, as it seems amdgpu and stable arent mixing right now ... or you just use what works and hang tight for updates and check again.
[if you switch to testing or unstable you will get slightly newer 4.19, firmware, etc]

Forum kindly sponsored by