Can't boot anymore; amdgpu fatal error

You could move up the branches, as it seems amdgpu and stable arent mixing right now ... or you just use what works and hang tight for updates and check again.
[if you switch to testing or unstable you will get slightly newer 4.19, firmware, etc]

It seems that I'm not the only one having problems with amdgpu right now?
Anyways, I think I'll stick to the 4.18 kernel since it seems the only recent one working (4.14 failed too) and check for updates.
Thanks!

... I dont know what else to say. Its there in the post .. and quite literally the last 30 minutes I've had this laptop open I responded to ~5 amdgpu threads...

Well, the issue is pretty straight forward. You may check which linux-firmware package might create the issue for you. So here are some firmwares you may want to try out:

sudo pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20180825.fea76a0-1-any.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20181018.d877533-1-any.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20181026.1cb4e51-1-any.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20181218.0f22c85-1-any.pkg.tar.xz

Just let us know which one made it work again.

3 Likes

could you try one more thing:

pacman -U "https://www.archlinux.org/packages/core/any/linux-firmware/download/"

This will install a more recent version of linux-firmware.

Issue is maybe, that the linux-firmware in stable does not provide amdgpu/polaris11_k_mc.bin, this was only added a few days later.

Edit: :sweat_smile: mah, to late.

5 Likes

@philm and @anon35400795, thank you both!
I solved executing

pacman -U "https://www.archlinux.org/packages/core/any/linux-firmware/download/"

Now I'm up again running from 4.19!
It's been a long day, thank you everyone so much lol

4 Likes

nice glad you hear you were able to figure it out with the help of philm and tids. i like their solution much better. :+1:

1 Like

@philm would a SRU for firmware+ucode be possible? Seems like polaris 11 and 30 (maybe others too) are broken with the current firmware in stable.

I've removed the overlay packages. I thought they were fine. A normal sudo pacman -Syyuu should fix it for existing machines. I still get error reports from the unstable branch with the new firmware. Therefore we can't do a SRU here.

I was hit by this nasty bug yesterday too. Just did a reboot and got stuck really bad. I had to borrow a Windows!! machine to create a USB drive just to find that the latest live iso has the same problem and did not help at all. With an Ubuntu live system I luckily found this thread and was able to fix the firmware.... But I got really close to give up and just install Ubuntu :unamused:
Thanks for the fix

Well, I just released v18.0.2-pre1 with the newer firmware on the ISO. With the next stable ISO that problem should be fixed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by