Can't boot Deepin after update

So I haven't turned on my laptop in 1 month. As expected, this would bring problems, as I always get them when I don't update for a long time.

After finishing the 247 updates I had I rebooted. The thing is I get stuck on the blue manjaro login with the blue bar traveling across the screen for all eternity.

I've tried multiple kernels and none of them worked, and if any of you asks me for the output of fdisk -1 please do explain how to get it because unfortunately I have no idea since I can't boot and use the terminal.

Thank you so much.

Hit an arrow key during Plymouth (that's the screen with the logo) to see what is going on in the console and you will hopefully see the errors. It's also a possibility that Plymouth itself is the problem...

I'll check and reply

It fails to start light display manager a couple of times until it stops giving errors.

When I click something during the console it just outputs: could not start bootsplash, no such file or directory.

Did you install from a manjaro-deepin ISO or did you setup Deepin yourself?

That's normal

That's not normal :wink:
Are you using regular lightdm-gtk-greeter or lightdm-deepin-greeter. (That's why I'm asking about having installed from a Manjaro-Deepin ISO)

I downloaded from here and booted from an USB so I used the ISO. I've been using it since october with minimal issues.

This is the first real one.

About your last question I can't tell for sure as I don't know how to check this without booting into the system, I'm sorry sir,

I will not be able to help you with anything else, but about not being able to boot, there are two options you have:

1 - less complicated - log into shell console - tty:


Then at the promp enter user name and password and you can then run Inxi and all the commands to get the logs. At this system update, some experienced dificulty logging to tty but succeed by trying multiple time. You don't have to use F2, you can also try F3 or F4 or F5 or F6. F7 would return you bac to working GUI but yours is not working so skip this one, just info for you.

OK, say you just can't log into tty even after multiple tries. In this case, there is another option you have, a little bit more complicated but you need to learn it anyway - to chroot into your system by using live Manjaro media and boot from it:

2 - chroot:

I will try this when I get back from work. Thank you!

Actually, while those steps works, there is now a little simplified way, follow these updated steps:

Follow at least until you update the system.

pacman -Syu

I don't know if you need to follow these last two steps, @oberon can tel you if you need or not:

mkinitcpio -P

Forum kindly sponsored by