Can't boot encrypted Manjaro after installing Windows 10.

A new option does show up at the bottom of the grub menu
20190918_083334
and running it does boot my main Manjaro desktop.

You still want me to do Test F?

Now boot this entry Manjaro -1

Let us know if this works.
I'm preparing another entry 'Manjaro -2 that will work, but I'll also explain why I don't like it.

Here it is...

$abc= raw
$pqr= decrypted

menuentry 'Manjaro - 2   Linux' --class manjaro  {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod cryptodisk
        insmod luks
        insmod gcry_rijndael
        insmod gcry_rijndael
        insmod gcry_sha256
        insmod ext2
        cryptomount hd4,gpt2
        set root=(crypto0)
        set pqr=ee80d713-9c90-4a29-94ca-64f1766ac102
        set abc=17a2a4d7-50ad-464a-a5ac-b296631a8dae
        linux   /boot/vmlinuz-4.19-x86_64 root=UUID=$pqr rw cryptdevice=UUID=$abc:luks-$abc root=/dev/mapper/luks-$abc
        initrd  /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
}        
        

Open up the same custom.cfg and add to it You can have as many entries in custom.cfg.

On why I don't like it...
WE have to use..

cryptomount hd4,gpt2

That may change.. with bios. It may become hd3,gpt2, hd2,gpt2 or hd1,gpt2 or go back to hd4,gpt2
And that is not consistent. It the entry don't work, you have to try with one of these .
But you can edit it manually at grub (press 'e') and try to boot.

I was hoping "cryptomount -u 17a2a4d7-50ad-464a-a5ac-b296631a8dae" will work so we don't have to change each time.

So we just have to have Manjaro -3 and hope it works then.

menuentry 'Manjaro - 3   Linux' --class manjaro  {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod cryptodisk
        insmod luks
        insmod gcry_rijndael
        insmod gcry_rijndael
        insmod gcry_sha256
        insmod ext2
        cryptomount -u 17a2a4d7-50ad-464a-a5ac-b296631a8dae
        set root=(crypto0)
        set pqr=ee80d713-9c90-4a29-94ca-64f1766ac102
        set abc=17a2a4d7-50ad-464a-a5ac-b296631a8dae
        linux   /boot/vmlinuz-4.19-x86_64 root=UUID=$pqr rw cryptdevice=UUID=$abc:luks-$abc root=/dev/mapper/luks-$abc
        initrd  /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
}        
        
3 Likes

All 3 Manjaro options boot to the desktop.

Manjaro 1 and 2 show pretty much the same thing when starting:
20190918_090725

Manjaro 3 says:

error: no such cryptodisk found.
Press any key to continue...

but it eventually starts without having to press any key.
20190918_090405

Okay. At this point, I'll be happy to take it.
All 3?
Yay!!! Yahoo!!!

Cheers, take care.
ps: I think the 3rd is best.

1 Like

I'm guessing the top option "Manjaro Linux" is trash now and there's no way to make it work?
Is it OK to remove Manjaro 1 and 2 or should I keep them for future troubleshooting?

I'll edit /etc/default/grub and change

GRUB_DEFAULT=0

so that it picks Manjaro 3 as the default boot option.

From what I see, it doesn't help.
There is another grub 'grub-vanilla' which I think is much better. But as to your case, I cannot be certain it will improve. In fact, I really don't know. I'd prefer someone else, like @eugen-b or @AgentS do try out first. But the latter and I don't see a need for encryption and I particularly will not do something I don't find meaningful, not that I think others shouldn't do what they want.

No. This has totally no effect. That's the beauty of custom.cfg. Nothing will destroy it. You can bring it up to the top by going to your grub.cfg and manually moving the 41_custom stanza to the top. But remember when there's an update-grub, that will revert to the bottom. And you will find severe warnings when you try to modify grub.cfg. In kde, it is almost impossible without the super super root command.

I'm thankful that you helped me on something that you don't even use, hopefully eugen-b will eventually look for a solution.

I moved the 41_custom stanza to the top but it would default to Manjaro 1, so I deleted both Manjaro 1 and 2.
I tried to increase the timeout in /etc/default/grub but it still stays at 5 seconds.

Should I make a a grub-rescue cd/usb or is not not going to work in my case?

Since it is the custom.cfg containing the working entry, there is no point in making this grub-rescue cd anymore. Just suggest you copy the working grub entry somewhere (not in the system) and should you have problems, from any grub (like the install media grub) use each line to input at the grub prompt. Of course, you have to remember the encryption password.

Did you do 'update-grub' after that? Your custom entries will remain.

And you're welcome. I've enjoyed helping out too.
Cheers.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by