Cant boot fresh install 17.1

Can you please make this forum more usable from a mobile phone! Almost impossible to post this!!

Hopefully the thread title and photos say it all....

This forum serves a pc os, not a mobile phone...


Tried installing twice, once an automatic replacement of existing partition (Debian I wasn't using and had instaled to test) and the other with manual partition selection (selected / on sda3 and /boot/efi on sda1, exactly the same as the automatic version looked like.)

Install appears to work correctly, on initial reboot Grub does not pick up and has not been updated. I have to boot into Ubuntu and do a sudo update-grub2 and then reboot and it tries to boot into Manjaro but I get the errors shown above (and on similar image here, not sure why subsequent boots seemed slightly different.)

This issue with Grub not getting updated I fear is a fault of Ubuntu, not yourself, it has been the same with every distro I have tried installing alongside, that I need to do a manual update afterwards.

Any idea why this wouldn't be booting?

This forum serves a pc os, not a mobile phone…

So when your installer gives somebody a borked system what do you expect them to ask for help from? Supporting mobile devices is just good common sense! Luckily I have other partitions with good installs but I thought it would be quicker to post the photos straight from my phone. Not so sure of that now. And if this reply is an indication of your support and care I think I will just walk straight away from Manjaro all together!!

Other image, fewer and different errors. The one in the first post was first boot attempt, subsequent ones looked like this.


I suspect this is the fix to my issue (very strange that Manjaro can't use a generic grub, and doesn't install its own when the operating system is installed. Surely that means it can never be booted if installed as a second OS??

EDIT: Unfortunately not! All that gives me is a black screen and fans running at full speed after the Manjaro splash screen and not much useful coming up on the screen at all.

But I believe the not updating the Grub is not the fault of Manjaro, so apologies for indicating it was. It's a combination of HP and Ubuntu not doing things in quite the standard way..... (Ubuntu doesn't use the standard efi boot folder, for the HP to use the one they do save to you have to set up a Custom Boot. That combination makes it miss changes written by newly installed OSes. But at least it means I know how to get it to automatically boot once it boots at all (but due to that it's not the instructions in the link above.)

My hardware is an HP Elitebook 840 G2 fitted with an i7-5500U and 16GB of RAM, if that may help you at all. I can run inxi or similar from Ubuntu if deeper system specs may be of help.

This is most probably a GPU driver issue. Therefore we need more info.
You have to login Manjaro straight to TTY and provide info (use wgetpaste):

inxi -SMGxxx
mhwd -li
cat /var/log/Xorg.0.log   ## if empty, check "ls /var/log/Xorg*"  or "ls ~/.local/share/xorg"
cat /etc/X11/xorg.conf.d/*.conf

For your boot problem provide these:

efibootmgr -v
parted -l
findmnt -s
findmnt /boot/efi

BTW thanks for the constructive critic. The forum is advertised as mobile friendly, so you might want to open a topic ( #meta:site-feedback ) about the difficulties you had with your mobile, with a couple of relevant screengrabs.
Please study some basics about Manjaro usage:
User Guide

and try the Search function, it's very powerful, after you learn how to use it.


Thanks for the detailed list of required information, sorry I didn't use wgetpaste as it wasn't installed by default and I couldn't remember which package manager Manjaro using (literally just starting to try out this distro.) I have uploaded the text as it appears after being redirected into a .txt file

I only ran the parted -l and blkid as sudo as they gave no output otherwise and you didn't instruct me to. I hope no information is missing.

Being integrated Intel graphics (i915 driver usually) I'd be surprised if it's a GPU issue as you initially suspected though.....

And apologies for not trying harder with the Search. You are 100% right I should have done!

And I'm sorry for not being aware of the fact that this is a mobile friendly forum.

Have you done what was in the post?
Check that you have Manjaro files in @esp partition (/boot/efi).
Read this Topic, it is about your exact model.
You may create a custom entry in UEFI/BIOS for Manjaro. Read how that user did it and try.

Reboot to see if it works.
If you get to Manjaro Grub (manjaro is 1st), boot to the fallback option (Advanced options).
If it goes to black screen, reboot and go to TTY.
Run startx to get to your DE.
If it fails, post what was the error and run this to get more errors and post here:

systemctl status lightdm
journalctl -b -1 -p 3

I already mention myself the fact the HP doesn't deal correctly wit EFI and that you have to do that on many Linux installs, so I know this very well and how to access the different Grubs created in different EFI folders. And yes of course I followed what was in the post before saying it didn't work for me. None of the other Linux distros I've tried have refused to boot from the Grub of another once the grub config is updated though, so never previously had to change the default one by rewriting my Custom Boot line in the BIOS and seems strange I should now..... (Assuming I ever get it to fully boot.)

I'll try and get back after performing these steps later today......

If you had done the 2 UEFI additional commands, secureboot is disabled and disabled TPM in your bios, it is likely your HP uefi firmware is flaky. If there is a firmware update for your bios, plese see if this helps.

Note too in your bpastebin there are several multiple instances of ubuntu's efibootentries.
This means that the efibootentries keeps generating new entries for it upon boot.
That is another evidence of a bad uefi firmware.
You should do something about it as well.

I can think of using that ubuntu entry to 'represent' or 'fake' manjaro for it. But you still have these multiple entries and you will need to do something about it first.

Good luck.

ps: if you find a way to resolve this problem (some of us do not have HP), tell us.
It might help others. Thanks.

Yeah I read in multiple places that it's HP's fault and their EFI implementation is not done properly on a large range of the Elitebook models. This has been reported to them by myself and other users a fair number of times over at least the last couple of years and they still yet haven't done anything about it (at least not to address it on older models.) My UEFI was updated around Jan/Feb, updated after Meltdown/Spectre came out and a fix was release for them. It appears there is a newer one now though, the website says it addresses some TPM issue. I will try updating to this newer version....

It's never stopped me managing to boot into about half a dozen different Linux ditros until this one though, on two previous versions of the UEFI/BIOS.

1 Like

Updated BIOS and changed setting to purely UEFI mode, rather than the dual UEFI/Legacy mode (which I thought I needed for booting USB keys which often use FAT32 and MPT but haven't tested.)

I have now managed to boot using the Fallback option in Advanced. I thought I had tried this before but now wonder if I only tried it from the Ubuntu Grub, not the Manjaro one like I thought I had....

Currently running all updates through the GUI updater (usually I would never use a GUI for this but.....) but will have a look see if that has helped and run through the other suggestions once it's done.

Unless there's something obvious which would allow it to boot on Fallback option but not the normal one on fresh install??

EDIT: Updates might take some time! Despite have a 30MB/s connection here it is saying it's going to take more than 6 hours to download less than 1GB! Oh well, sit back and relax..... (I hope this isn't a sign that your repos are ultra slow.)

You may interrupt downloading, recreate/change your mirrors and try again.

Update complete.

Normal Grub entry didn't boot, Fallback failed first attempt with same symptoms, Fallback worked on second attempt (haven't tried multiple normal entries but maybe that will work sometimes too....) No access to another tty when it fails to reach login screen.

dmesg on pastebin

[me@me-pc ~]$ systemctl status lightdm
● lightdm.service - Light Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor pre>
   Active: active (running) since Wed 2018-08-29 14:01:50 BST; 2min 49s ago
     Docs: man:lightdm(1)
 Main PID: 341 (lightdm)
    Tasks: 6 (limit: 4915)
   Memory: 98.4M
   CGroup: /system.slice/lightdm.service
           ├─341 /usr/bin/lightdm
           └─361 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolis>

Aug 29 14:01:50 me-pc systemd[1]: Starting Light Display Manager...
Aug 29 14:01:50 me-pc systemd[1]: Started Light Display Manager.
Aug 29 14:01:52 me-pc lightdm[556]: pam_unix(lightdm-greeter:session): session >
Aug 29 14:02:00 me-pc lightdm[626]: pam_unix(lightdm:session): session opened f>

$ journalctl -b -1 -p 3
-- Logs begin at Tue 2018-08-28 17:05:58 BST, end at Wed 2018-08-29 14:03:39 BS>
-- No entries --

$ journalctl -b -0 -p 3
-- Logs begin at Tue 2018-08-28 17:05:58 BST, end at Wed 2018-08-29 14:03:39 BS>
-- No entries --

$ journalctl -b -2 -p 3
-- Logs begin at Tue 2018-08-28 17:05:58 BST, end at Wed 2018-08-29 14:03:39 BS>
-- No entries --

Yeah I figured it would be configurable, it eventually took closer to two hours and I was fairly busy anyway. Once I have it booting smoothly I'll look into configuring the repos etc :slight_smile:

1 Like

Why do those three journalctl logs give me the same time? I thought the -b number was meant to represent previous boots? Before restarting after updating there was one for the previous boot, it had a single line of error relating to not being able to access the cron or cronjob folder (I can't remember exactly but not something that seemed it could be relevant.)

EDIT: Nevermind, the time stamps seem to be all the way back to since it was installed yesterday up to the most recent boot....

So you have GUI working (which DE?).
What is your status on your issues now?
Is Manjaro Boot loader in UEFI working?
Do you boot to GUI/lightdm or to a black screen?

Forum kindly sponsored by