Can't Boot in Manjaro

Hi guys,After I last updated my system and restarted, I am not able to boot anymore
It is stuck on a black screen

INIT: no inittab file found
Enter Runlevel

Also it broke my wireless card driver,
After I booted to bootable-iso and mounted the partition suing chroot, and tried to run an update, in case of any broken package or grub, It is not able to connect to Internet anymore, no output on ping

Internet is working in bootable-installer without any problem tho
How i am supposed to solve this...Ist time came across something like this ?
Thanks in advance guys

Try to restore the boot loader of the installed system, details are described here:

Background can be learned here:
https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

I got the same and tried different things I saw on this forum. While none of that solved the problem at first, it paved the way for the solution I found.

In my case, the problem was that something at some point caused pacman to uninstall the "systemd-sysvcompat" package and install "sysvinit instead". To fix it, I had to:

  1. Boot into a live USB session
  2. Make sure the Internet connection is working before moving on to the next step.
  3. Run "sudo manjaro-chroot -a" to chroot into the problematic system
  4. Uninstall sysvinit (I had to uninstall "openrc" and "openrc-sysvinit" first, one by one, with "pacman -r "
  5. Install systemd-sysvcompat with "pacman -S systemd-sysvcompat"
  6. Done, rebooted and that was it !

I figured that out by chrooting and checking the pacman log ... good luck !

Hi, sorry for the late reply, haven't opened the forum since then
Actually, yeah that's exactly what happened, Somehow I managed to replace the openrc with sysvinit while updating.
I figured that out, but real problem was the Internet Connection itself. It was working well in live boot session, but somehow stopped automatically immediately after chrooting to affected partition.
I tried installing by downloading the package manually and install it then, but it came with a load of extra dependencies which was a hassle in itself.
I was also a bit pressed for time back then, So eventually I just did a system reinstall :sweat_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by