Cant boot into Manjaro anymore

I tried installing Manjaro XFCE on a pendrive just for fun, and though I actually achieved it, when I went to boot again into Manjaro GNOME on my laptop, I was just defaulted to Windows.

At this point, I thought that me installing an OS on a pendrive had overwritten the grub on my laptop and put it instead on the pendrive. I still don't know if this is accurate, but I have since gotten into Manjaro using the grub from the USB.

I have tried reinstalling grub, but it didn't work
I have tried rebooting, but it didn't work

If it is useful in any way, here's the output of inxi -Fpr (I chose the flags thinking would show the most useful information but I may have chosen wrong)

[ayhon@bower ~]$ inxi -Fpr
  Host: bower Kernel: 4.19.14-1-MANJARO x86_64 bits: 64 Desktop: Gnome 3.30.2 
  Distro: Manjaro Linux 
  Type: Laptop System: Timi product: TM1703 v: XMAKB3M0P100B 
  serial: <root required> 
  Mobo: Timi model: TM1703 v: XMAKB3M0P100B serial: <root required> UEFI: Insyde 
  v: XMAKB3M0P100B date: 03/22/2018 
  ID-1: BAT0 charge: 22.2 Wh condition: 38.3/40.1 Wh (95%) 
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  L2 cache: 6144 KiB 
  Speed: 900 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 901 5: 900 6: 900 7: 900 8: 900 
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
  Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A 
  Display: x11 server: X.Org 1.20.3 driver: N/A resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 18.3.1 
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k4.19.14-1-MANJARO 
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi 
  IF: wlp2s0 state: up mac: c0:b6:f9:5d:bb:b4 
  Local Storage: total: 718.69 GiB used: 40.52 GiB (5.6%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HAHQ-00000 size: 238.47 GiB 
  ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO M.2 500GB size: 465.76 GiB 
  ID-3: /dev/sdb type: USB vendor: Toshiba model: TransMemory size: 14.45 GiB 
  ID-1: / size: 217.16 GiB used: 31.27 GiB (14.4%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 502.0 MiB used: 284 KiB (0.1%) fs: vfat dev: /dev/sda4 
  ID-3: /media/shared size: 244.08 GiB used: 2.30 GiB (0.9%) fs: vfat 
  dev: /dev/sda1 
  ID-4: /run/media/ayhon/6b537e30-c267-40d9-98c8-e994cf8a6389 size: 13.87 GiB 
  used: 6.95 GiB (50.1%) fs: ext4 dev: /dev/sdb2 
  System Temperatures: cpu: 35.0 C mobo: 32.0 C 
  Fan Speeds (RPM): N/A 
  Active pacman repo servers in: /etc/pacman.conf 
  Active pacman repo servers in: /etc/pacman.d/mirrorlist 
  Processes: 224 Uptime: 15m Memory: 7.70 GiB used: 1.30 GiB (16.9%) Shell: bash 
  inxi: 3.0.28 

Sounds like you need to

1 Like

Boot into Manjaro (your way, usb grub) and then do the 2 [UEFI - additional commands] in this link..

If need further help provide the information required at that link.

ps: you may have to change your $esp (/boot/efi) from sda4 to an existing $esp partition in nvme0n1. Do not format. But try out the above first.

1 Like

I followed the instructions
Then I got lost
Then I tried some commands from the link
And suddenly, everything works fine

Thank you!

1 Like

Good to hear. Is your Manjaro $esp on the nvme disk?
Can you please provide from terminal

sudo parted -l
findmnt /boot/efi
efibootmgr -v
sudo blkid


I don't fully understand what you mean by $esp, but the nvme disk is for Windows 10 (It's the disk that came with the laptop) and sda is for Manjaro GNOME, and as it has worked before, I'm going to assume the asnwer is no, it is not on nvme.

Either way, here is the output of the commands you asked:

sudo parted -l

[ayhon@bower ~]$ sudo parted -l
Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      1049kB  262GB  262GB  fat32              msftdata
 2      262GB   500GB  237GB  ext4
 4      500GB   500GB  527MB  fat32              msftdata

Model: Unknown (unknown)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB  16,8MB               Microsoft reserved partition  msftres
 3      123MB   254GB  254GB   ntfs         Basic data partition          msftdata
 4      254GB   254GB  488MB   ntfs                                       hidden, diag
 5      254GB   256GB  1573MB  ntfs         Basic data partition          hidden, diag

findmnt /boot/efi

/boot/efi /dev/sda4 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=is

efibootmgr -v

[ayhon@bower ~]$ efibootmgr -v
BootCurrent: 0002
Timeout: 2 seconds
BootOrder: 0002,0001,2001,2002,2003
Boot0001* Windows Boot Manager	HD(1,GPT,92cdf802-3e4b-40ef-bb9c-31b6f70526b7,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...B................
Boot0002* manjaro	HD(4,GPT,56794282-1e29-47ed-82af-d9b04f9b5485,0x3a28a800,0xfb80f)/File(\EFI\manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

sudo blkid

[ayhon@bower ~]$ sudo blkid
/dev/nvme0n1: PTUUID="96fbc164-1d52-447c-88e9-bfea456b2398" PTTYPE="gpt"
/dev/nvme0n1p1: LABEL="ESP" UUID="1A8F-0CDD" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="92cdf802-3e4b-40ef-bb9c-31b6f70526b7"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="4cf4c805-53e2-47af-a416-184b45705dd6"
/dev/nvme0n1p3: LABEL="OS" UUID="A4948F9C948F701A" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d2890d8b-a7dc-4cbc-bc1d-eab47461eadd"
/dev/nvme0n1p4: UUID="608AB0278AAFF7A4" TYPE="ntfs" PARTUUID="5668100d-bcc7-4dbe-a737-5e6e48af4c60"
/dev/nvme0n1p5: LABEL="WinRE" UUID="1E1E915D1E912EB1" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b836e044-03e2-4f23-8aea-882bf42cc2f7"
/dev/sda1: LABEL="SHARED" UUID="2CAA-C340" TYPE="vfat" PARTUUID="2a8404da-e61e-42b5-b92a-aaf70541dd1b"
/dev/sda2: UUID="d8f6568e-3528-4e69-aa40-193ba5ce9e08" TYPE="ext4" PARTUUID="2e3128d9-a2a9-426a-a992-fc139a693348"
/dev/sda4: UUID="F5D8-7A8F" TYPE="vfat" PARTUUID="56794282-1e29-47ed-82af-d9b04f9b5485"

Thanks. That is very helpful to me.
Yes, your $esp (the 'EFI' partition) for Manjaro is in sda4
While your windows $esp is in the nvme disk nvme0n1p1.

For some, the $esp mus be on the nvme disk.
It doesn't apply to yours here. You have your Manjaro $esp in a non-nvme disk.

Again, glad you have you boots back.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by