Can't boot into Manjaro: File '/vmlinuz-4.14' not found

Hello good people.

I have been running a dual boot with Windows 10 since May this year, and I just ran into a problem with booting my Manjaro Linux.
The error message I get is:

error: invalid cluster 0
error: you need to load the kernel first.
Press any key to continue...

I read on forums about this, and somewhere I got to know that I need to turn off the fast startup option on windows so that the windows does shut down properly when I want him to. After turning off this option, I again try to boot into my Manjaro, and I get a similar error message:

error: file '/vmlinuz-4.14-x86_64' not found.
error: you need to load the kernel first.
Press any key to continue...

The irony is, if the win messed up my linux with deleting its kernel, why didn't it happen in the previous 6 months of dual booting.

The thing I have tried so far, and I am not sure if this is the right thing to do, is booting with a live Manjaro, chroot-ing into my root partition of the original installation (with a missing kernel), and installing a kernel with the command "pacman -S linux". But this is unsuccessful, and I get error messages about invalid or corrupted database (PGP signature). I am not sure if I type the right commands with the right arguments.

Before proceeding to reinstall my Manjaro, I want to know if I can save my OS with installing a new kernel, or something.

Can anyone help me?
Thank you in advance.

1 Like

No kernel was deleted, just the boot loader was messed up.
Follow this and read carefully and apply the parts that correspond to your install.

You got something right :slight_smile:

You need to specific which kernel - eg. linux414

1 Like

That doesn't work either.

Do you have separate /boot partition?
I suggest you boot to manjaro live media and use "Detect EFI bootloaders" to boot to your installation. Then update the system and update grub.
If this doesn't work, boot again to live media and provide info as described at the above linked tutorial.

Detect EFI bootloaders says 'No EFI files detected'.

Is your system UEFI?
Do you use grub or rEFInd?
Have you read the tutorial?
Can you provide info?
Can you answer questions?

1 Like

My system is not UEFI.
I use grub.
I tried the tutorial, and the problem is the ($root)/boot folder is empty. Thats why I think the kernel is deleted.

eeh ... not quite ... wind$ can't write that ext4 partition without the driver for it ...
what gives from terminal
lsblk -pf

Windows wouldn't delete anything, only you can.

Check fstab and verify UUIDs with blkid.
Chroot in your system, refresh DBa and install kernels

pacman -Syy
pacman -Fyy
pacman -Ss linux41
# then install kernels
pacman -Su linux414 # or others
1 Like

Sounds serious. Looks like you have a wrong file system.
From a livecd, provide

parted -l

and the the contents of /etc/fstab of the install manjaro partition.
Oh.. please explain the partitions... like sda1 is windows. sda3 is manjaro root.....

where do i run this command from?

All suggested commands you have to run them in terminal ...

I have a 500MB partition with fat32 file system, but it does not have a boot flag, so I'm not sure. Can you help here?

And I don't know what fstab, blkid and UUIDs are, and how to check fstab and verify UUIDs with blkid. Im sorry. :slight_smile:

Here is the output:

sda5, vfat. What is this sda5 partition? /boot?
If so, sorry, you cannot have /boot in vfat.
To be sure, you are on bios-legacy with msdos partitions, right?

1 Like

Here is the output of parted -l:

Here are the partitions:
manjaro root is on /dev/sda7

The contents of /etc/fstab:

Now i wonder if you have MBR or GPT partition table with 8 partitions ... My guess is you are on MBR partition table and you created sda4 as extended partition and all the other 4 after are Logical partitions ... I might be wrong, but something is not ok there.
As @gohlip said ...

EDIT2: @dragan - you were posting the confirmation of my guess while i was typing ... What you did there is not ok.

Yes. sda5 is /boot. And yes, I am in bios-legacy mode.

Repeat message in case you did not see while repying.
Yes. you need to reinstall.
Suggest while reinstalling, do not have a separate /boot partition.
Just a root partition in ext4. swap partition is optional, if you have 8 GB ram and above, suggest you do not need a swap partition either. It will work nicely.

[edit] - heh heh, now's my turn not to see your reply.
Cheers, take care.

1 Like

Forum kindly sponsored by