Can't boot into Manjaro i3 from rEFInd

I boot into rEFInd, and when I select the option to boot into Manjaro, I'm welcomed back by the same rEFInd page.
I see in my BIOS that I have many boot options. I try all of them, but none boot into my Manjaro drive.
I can still access Windows 10, which is on a separate SSD from the one with Manjaro.

Long story:
Everything working just fine, had finally fixed some trouble I had with the volume keys in my laptop (switched from amixer to pactl) and another problem with Bluetooth (switched from blueman to blueberry), and so I locked my laptop to go to sleep.
Before closing off my laptop, I thought to myself "Wait, let's turn it off. Either way, my laptop boots pretty fast", and to prove this to myself, I proceeded to turn off my computer and turn it on again, and measure in my head how long it takes to boot back. Well, it never boots back. It just loops through the same screen, again and again.

I managed to boot into Manjaro selecting a different kernel (4.19).
How do I remove all the extra boot options from my system? (Will further elavorate in my next edit)

This are the options I see at my laptop's own boot selection (When pressing F12)

  • rEFInd Boot Manager (Samsung SSD 860 EVO M.2 500GB)
  • rEFInd Boot Manager (SAMSUNG MZVLB256HAHQ-00000)
  • ubuntu (SAMSUNG MZVLB256HAHQ-00000)
  • EFI Hard Drive (Samsung SSD 860 EVO M.2 500GB)
  • Windows Boot Manager (SAMSUNG MZVLB256HAHQ-00000)

And they all do the following:

  • rEFInd Boot Manager (Samsung SSD 860 EVO M.2 500GB)

Will boot into a rEFInd screen and prompt either Windows or Manjaro. If you select Windows, it boots into Windows, if you select Manjaro, it boots into this same rEFInd page

  • rEFInd Boot Manager (SAMSUNG MZVLB256HAHQ-00000)

Will boot iinto a different rEFInd screen that will work exactly the same as the previous one. When selecting Manjaro, it will lead to the very fist rEFInd screen (not this one)

  • ubuntu (SAMSUNG MZVLB256HAHQ-00000)
  • EFI Hard Drive (Samsung SSD 860 EVO M.2 500GB)

This 2 options will both lead you to a grub rescue command prompt

  • Windows Boot Manager (SAMSUNG MZVLB256HAHQ-00000)

Will boot into Windows.

I would like to delete the second instance of rEFInd and ubuntu (I don't have ubuntu installed, just Manjaro and Windows, althought it may be a leftover from a previous install I tried to do on a flash drive, which didn't work)
Also, I would like to fix the EFI hard drive, if that is where Manjaro is supposed to go

Mixer and Bluetooth changes shouldn't affect boot. But just try to boot using this.. You may have to use the [ More Complicated Setup] section. And yes, it will boot a refind installation ( if nothing more serious).

When/if booted, reinstall refind and do refind-update.

But be prepared if it is more than just boot issues.

1 Like

I booted into manjaro, just that with an previous kernel. Does that count?

Ok, just saw your edit. It is fine to work with a older kernel. If you mean cleaning options as in removing older kernels, just remove them, but suggest having at least 2, as you just found out.

If not referring to kernels, what options are we talking about to remove?

Detecting efi files, disabling other Distro boots can be done through the refind conf files. There are 2 such conf files. One in /boot and another in /boot/efi/refind/

1 Like

I made a new edit (EDIT 2) in which I explain what I mean. I want to eliminate the boot options which dont work.
Also, I want to be able to boot to a kernel that works.
What I mean is that I want to be able to choose Manjaro the first time and boot into Manjaro, and not have to manually select and older kernel to boot into my system

Ok, just saw your second edit. We have to stop doing this.:slightly_smiling_face:

Check with efibootmgr.
Remove unwanted entries with
sudo efibootmgr -b xxxx -B

But careful you do not remove the effective entry. It can make your system unbootable.

1 Like

And just saw your recent edit.
To make default (first) entry,
sudo efibootmgr -o xxxx,yyyy,zzzz,.....
Where xxxx is manjaro entry

1 Like

To reset hard drive boot to existing entry, removing the hard drive entry and rebooting again should do.
Should is the operative word. Some motherboards don't.

Nedf to logg off.

PS: suggest you write all before sending. I can handle it. Not necessary a one item post.

And we don't get notification or alerts for edit s. So we may miss edits.

1 Like

No, I have to stop doing this, I'm sorry :worried:
It's just that I thought that should be information that someone entering the conversation should have. But don't worry, I won't be leaving all useful information at the first post, at least not until this is solved

The thing is, I don't know which entry is Manjaro booting from. The output from efibootmgr gives me the same output I get from the BIOS (I know it's technically not BIOS, but whatever) of my computer. This is the output I'm getting

[ayhon@bower ~]$ efibootmgr
BootCurrent: 0002
Timeout: 2 seconds
BootOrder: 0002,0001,0004,0000,0003,2001,2002,2003
Boot0000* EFI Hard Drive (Samsung SSD 860 EVO M.2 500GB)
Boot0001* rEFInd Boot Manager
Boot0002* rEFInd Boot Manager
Boot0003* Windows Boot Manager
Boot0004* ubuntu
Boot2001* EFI USB Device
Boot2003* EFI Network

It says currently that I'm booting from Boot 002, but that's refind, not Manjaro.

I think I can do that with F12 in my computer, but this seems faster.

I don't know if I'm just too tired, but what do you mean by this. Will read tomorrow again

Good night :zzz:

Since you use refind and not grub, you will not have a 'manjaro' entry.
Your refind 0002 is the one that will be used.

Since 0002 is the last (working?) boot, you can remove the other one.

sudo efibootmgr -b 0001 -B

If you have no Ubuntu, you can also remove it

sudo efibootmgr -b 0004 -B

And to clean up the files, if Ubuntu files are in manjaro $esp,

sudo rm -Rf /boot/efi/ubuntu

Do not remove 0000 as that is the boot efi file.
In fact, it is good to set the refind efi to that boot file, so

sudo cp /boot/efi/refind_x64.efi /boot/efi/EFI/boot/bootx64.efi

As for 2001,2002,2003, you should just leave them there. They are the boot files for your devices.
If you remove those, they will be regenerated upon the next reboot.

ps: you can leave all untouched, they do not affect anything, but of course, tidying up is a virtue by itself.

Ok, I have no file at /boot/efi/ but I suppose it's the same file as /boot/efi/EFI/refind/refind_x64.efi.
Also, I already have a /boot/efi/EFI/boot/bootx65.efi. Do I overwrite it? (Doesn't look safe to me, but idk)

Cannot agree more

If you really mean bootx64.efi, yes, you should replace it.
That's the main intention. The old one may be copy of some old refind.efi, or even ubuntu's efi file.
The refind file should be at /boot/efi/refind/refind_x64.efi. Sorry. Make sure it is there before you copy it over.


ps: now that you've cleared the issue, and just for my understanding, why refind?
Is there a problem with grub? If no, why not systemd-boot?
It seems to me, systemd-boot is so 'direct', 'fast' and simple for a one OS system (grub can be like that, if we use most other distro grubs).

Well, 4 and 5 are so close together! :pensive:

Will do when I get back to my computer, thank you very much.

Well, I didn't choose grub because, in my opinion, it couldn't be more ugly even if they tried.
rEFInd was just the first pretty alternative I found (in r/unixporn), and I was surprised to know that Manjaro has a really cool theme for it (I think it's called refind-maia-theme or refind-theme-maia, either of them) in the official repo. I don't like the background, buy that's easy enough to change.

What is systemd-boot, and is it as aesthetically pleasing as I've found rEFInd to be? If so, I may try it. I'm getting bored of all the rEFInd complications I've had

Okay, thanks for your explanation. Of course, all reasons are valid for personal preferences and choices. In that case, you may not like systemd-boot. The menu is a stark black and white and only text. Here's a screen shot of my systemd-boot menu together with a grub theme. And by changing background, this is the grub I'm using now. And further more, systemd-boot needs some manual input to get it working IMG_20181201_200034

BTW, the bootx64.efi is good to have as the system firmware defaults to it whenever there's any problem. And some firmware selects that bootx64.efi as default regardless of any working boot entry. So it is always good to have a (working) bootx64.efi.

Cheers, take care.

1 Like

Wow, I actually like the look of systemd-boot. It's slick, and seems to have a good balance of icons and text, and they seem to be big enough.

Also, on a second note, man, you have many OSs. No wonder that you know so much about boot-stuff.

Will see if everything works after overwriting bootx64.efi.

systemd-boot is another type of bootloader. I prefer rEFInd personally.

1 Like

No. I think you got the wrong screen :laughing:
systemd-boot does not have icons. It just have black and white text only.
See the screen shot in the link.
What is here in this page is grub.

@Ayhon This is systemd-boot

1 Like

Ok, better than grub, but not something I'm into.
Is it faster than grub?

Hell yeah!

Just ran this, and it still doesn't work. I face the same problem of a never ending loop of rEFInd. Tomorrow I'll try to make a video, to see if I'm just omitting some important information.

Forum kindly sponsored by