Can't boot into Manjaro i3 from rEFInd

If you really mean bootx64.efi, yes, you should replace it.
That's the main intention. The old one may be copy of some old refind.efi, or even ubuntu's efi file.
The refind file should be at /boot/efi/refind/refind_x64.efi. Sorry. Make sure it is there before you copy it over.


ps: now that you've cleared the issue, and just for my understanding, why refind?
Is there a problem with grub? If no, why not systemd-boot?
It seems to me, systemd-boot is so 'direct', 'fast' and simple for a one OS system (grub can be like that, if we use most other distro grubs).

Well, 4 and 5 are so close together! :pensive:

Will do when I get back to my computer, thank you very much.

Well, I didn't choose grub because, in my opinion, it couldn't be more ugly even if they tried.
rEFInd was just the first pretty alternative I found (in r/unixporn), and I was surprised to know that Manjaro has a really cool theme for it (I think it's called refind-maia-theme or refind-theme-maia, either of them) in the official repo. I don't like the background, buy that's easy enough to change.

What is systemd-boot, and is it as aesthetically pleasing as I've found rEFInd to be? If so, I may try it. I'm getting bored of all the rEFInd complications I've had

Okay, thanks for your explanation. Of course, all reasons are valid for personal preferences and choices. In that case, you may not like systemd-boot. The menu is a stark black and white and only text. Here's a screen shot of my systemd-boot menu together with a grub theme. And by changing background, this is the grub I'm using now. And further more, systemd-boot needs some manual input to get it working IMG_20181201_200034

BTW, the bootx64.efi is good to have as the system firmware defaults to it whenever there's any problem. And some firmware selects that bootx64.efi as default regardless of any working boot entry. So it is always good to have a (working) bootx64.efi.

Cheers, take care.

1 Like

Wow, I actually like the look of systemd-boot. It's slick, and seems to have a good balance of icons and text, and they seem to be big enough.

Also, on a second note, man, you have many OSs. No wonder that you know so much about boot-stuff.

Will see if everything works after overwriting bootx64.efi.

systemd-boot is another type of bootloader. I prefer rEFInd personally.

1 Like

No. I think you got the wrong screen :laughing:
systemd-boot does not have icons. It just have black and white text only.
See the screen shot in the link.
What is here in this page is grub.

@Ayhon This is systemd-boot

1 Like

Ok, better than grub, but not something I'm into.
Is it faster than grub?

Hell yeah!

Just ran this, and it still doesn't work. I face the same problem of a never ending loop of rEFInd. Tomorrow I'll try to make a video, to see if I'm just omitting some important information.

It was working before running this? This command is just copying a file. It shouldn't affect booting.
Can we take a look at 'efibootmgr -v' again? Maybe we deleted something we shouldn't?
If we really cannot boot into it, use this to boot into it. Yes, this grub will boot a refind install.

On a lighter subject, systemd-boot in most circumstances will be fastest. refind, slowest. But nobody should complain about a couple of seconds. grub can be as fast as systemd-boot if grub.cfg does not have to go through the loops (if, elif, then) and checks (grubenv) that some distros impose on themselves. refind is intrinsically slow as it has to detect and work out the entries each time it boots. As for functionality, versatility and 'fixability', nothing beats grub. For example, in above problem, and if using grub, I would have ask you to provide 'echo $cmdpath' to see which efibootentry is in play. In refind and systemd-boot, I can't do that or to fix it. And ultimately use grub to fix it even if it is not a grub install.

But that's too much info for this post.

As you command.

[ayhon@bower ~]$ efibootmgr -v
BootCurrent: 0002
Timeout: 2 seconds
BootOrder: 0002,0001,0000,0003,2001,2002,2003
Boot0000* EFI Hard Drive (Samsung SSD 860 EVO M.2 500GB)	PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,0,0)/HD(1,GPT,53ab5998-18f2-41f7-8acc-daa67992f901,0x1000,0x96000)RC
Boot0001* ubuntu	HD(1,GPT,92cdf802-3e4b-40ef-bb9c-31b6f70526b7,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0002* rEFInd Boot Manager	HD(1,GPT,53ab5998-18f2-41f7-8acc-daa67992f901,0x1000,0x96000)/File(\EFI\refind\refind_x64.efi)
Boot0003* Windows Boot Manager	HD(1,GPT,92cdf802-3e4b-40ef-bb9c-31b6f70526b7,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...B................
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

Here is said video. Warning, the quality is pretty much nonexistent, but I didn't have much time (there's my excuse).

I understand that grub is really good, don't get me wrong. It is the default for something. It's just that the aesthetics doesn't seem to be in the team's priorities. I know it can be customized, but I've heard it's no simple task, and I just couldn't stand using grub any longer, that's why I chose rEFInd. However, I consider myself a practical user, and as I don't dislike the systemd-boot interface, I may change to it (when I have time). After all, it's not like the boot screen is something I'll have to see too often, I can bear with it not being literally art.

Never is information a burden too heavy to share

Btw, you know a lot about boot and boot-loaders, so I want your opinion on something. Before I knew there were prettier alternatives to grub, I was considering on just using the default boot selection on the BIOS of my laptop. Would that give me any inconvenience? Because it seems way faster, seeing as it defaults to the partition I choose, and honestly, prettier than grub.
I though that maybe there was something more to it because every distro installs grub, even if it's the only distro in the computer. I was just curious.

Can you try at boot set up key the uefi entry of hard drive. See if that boots.
If it boots, we can easily fix it without booting from install boot menu.
When booted up,

sudo refind-install
sudo cp /boot/efi/refind/refind_x64.efi /boot/efi/EFI/boot/bootx64.efi

You still have Ubuntu entry?
Didn't you remove it?

PS: will talk later on bootloaders.
Mornings make me grouchy.:laughing:

I thought I had... Apparently, it did not go away...
This is scary Canonical, please stop!

If by this you mean "Boot into Manjaro without using rEFInd, but the built in BIOS of your laptop", then I have already tried it, and it didn't work

By this I mean going to the bios boot up key..
There is a bios setup key - usually F2
and there is a boot key - usually F8 ~F12, some 'esc' key
And if this is not enabled, it can be enabled at F2.

Note your efibootmgr output has refind, windows, ubuntu :smile:, and..... hard drive
So these options should be available at that boot key.
Use the hard drive entry.
It should be something like "UEFI: Samsung 860"
There should be another one for that disk and it is not prefixed by "UEFI". Do not use this non-prefixed one as it will boot the disk in bios-legacy. Use the prefixed UEFI: Samsung.

I'll be surprised if it does not boot (but not surprised if it 'entry' is not there) You just did the copy to bootx64.efi and that's what it is. If not listed, go to F2 to boot. In uefi.

Now if you fail (hopefully not), as said somewhere you can use my link to boot to manjaro (use complicated setup - you do not have grub.cfg in your system) and when booted, as said..

sudo refind-install
sudo cp /boot/efi/refind/refind_x64.efi /boot/efi/EFI/boot/bootx64.efi

But note refind will not override an existing refind.conf.
You may want to rename the old one conf file so a new install can do a new conf file for you.
Also since refind generates entries on boot, maybe a reboot can do just that.
I had the experience before - a boot up does not give me some entries I wanted, but I think I just have too many OS's and freaked out refind. I then have to use the manual entries so I do not have this problem. A new reinstall (with new conf) resolved this. And I put less OS's in its $esp too. Oh.. my refind $esp is /boot, not /boot/efi.

Good luck.

Ok, this previously lead to grub in rescue mode, though I'll try again, because I changed the bootx64.efi.
I will follow up with the output.

So then, my $esp is /boot/efi/EFI, because all the files you mentioned were there. Well, at least refind_x64.efi

On a second note, how do I banish Ubuntu?

Hmm, surprise? This is not what we were expecting, I guess.




Yes, looks like you need to reinstall refind.
As suggested, remove (or rename) refind.conf before reinstalling refind
As mentioned earlier, if you have problem booting into Manjaro,
use this to boot up (the more complicated method).

sudo refind-install

As for the second command to copy, please physically recheck the paths of both files before issuing the copy command.
The paths should be {$esp partition}/efi/refind/refind_x64.efi
and {$esp partition}/efi/boot/bootx64.efi

Your {$esp partition} is /boot/efi
Please be careful you get the paths right.
Best to physically check them before issuing the commands.

Having a bootx64.efi (in the right path) is always good but it looks like we got the paths wrong the last time. Sorry about it.

Now that we got that out of the way, 0002 refind entry does not boot? Isn't that the working and last booted entry? So this time, when you reinstall refind, check if there is 2 entries in efibootmgr. Suggest we do not remove any if there is 2 entries. I think it will reuse the same entry which is 0002 but if there is 2 entries do not remove any, first.

I'm reluctant to remove ubuntu entry for the same reason now. :rofl:
But again, find out the path of the directory in $esp.
And remove the directory taking care of the right path.

Removing ubuntu efibootentry with "efibootmgr -b xxxx -B" without removing its $esp directory should also be good enough, but I'm wondering why ubuntu entry still appear and why the refind entry (0002) now does not boot.


Thanks for the info, I'm looking into it.
I'm in the middle of tests, so I won't be able to try this for a while. Just wanted to say that I didn't just suddenly leave the conversation.
I'm not doing it right away because I was thinking of checking the systemd-boot you mentioned, but I want to look into it before doing anything. However, as I dont have that time right now, I'm going to leave this issue on freeze until my tests are over.

Thanks for the help up until now, and see you in a couple of weeks.

Finally brought myself to finish this, and this was the solution.
Thanks for your help!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by