Can't boot Manjaro\get rid of GRUB in order to boot Manjaro

Hey everyone, I will start by saying that I am a complete noob.

I currently run win10 in legacy mode (I think? since I can't boot manjaro in UEFI).
Long story short, I used to have Linux Mint alonside my windows partition, and when I decided to get rid of it, I just wiped the partition and totally forgot about GRUB. When I couldn't boot windows (it will show "grub rescue" or something) I have just changed my boot order to "Windows load manager" or something like that, and since than I didn't have any problems. until today.

Today I have decided to try Manjaro XFCE 17.1, and when I tried to boot it in UEFI mode (via the live CD) it showed me GRUB and said "unknown file manajer". So I tried to boot the live CD in legacy mode and it worked, so I have proceeded to install it. It went fine with no major problems, and now the problems start:

First of all, it booted me up straight to windows, because I have changed the boot order in my BIOS. so I entered the BIOS and chose "ubuntu ~the name of my drive~" because I thought it was responsible for Manjaro. Apperantly not.

Since then I have tried use the supergrub2disk, with no help (altough I could boot manjaro from there). I tried to run win10 livecd with all the methods suggested (fixmbr), I have tried to install GRUB manually with the help of the wiki- and nope. Nothing works.

I have even tried ubuntu repair tool which gave me interesting results.
I used LM live CD to install it, and when I booted it in legacy mode it told me to boot in UEFI mode. Okay, I have done it AND THAN IT HAVE SEEN MANJARO.

I tried to auto repair using the tool, and it told me to install Manjaro in UEFI mode. Just to remind, when I started to boot manjaro in UEFI mode it just showed the GRUB screen and the unknown file system.

Since then I have deleted manjaro, just wiped it because I don't even know how to deal with it, which is a shame because I really liked manjaro when I used it on the live CD.

So, does any of you have any idea?
Forgot to mention that my laptop is Asus X554L, running I3-4005U but it used to run linux mint well so I don't think that issue is hardware related.

Thank to anyone who helps me, I will really appereicate it !

Manjaro v16.10 was the last edition using isolinux as bootloader for our ISO. With v17 we started to use grub2 to have a common boot experience for all boot options like BIOS and UEFI.

Thank you.

As a last try to use Manjaro, I used DD method to burn manjaro to my USB instead of ISO, and it worked!

Thank you for helping me figuring it out, now lets see if Manjaro would still install correctly

Since you've deleted Manjaro, you will need to reinstall it again. In bios-legacy.
The problem you had the first time you installed Manjaro XFCE 17.1 was that you changed your 'primary' drive (you call it 'the boot order in my BIOS') and that boots directly into Windows. {There was nothing wrong in your installation and can be fixed easily.}

After this new reinstall, if you still have problem, let us know. We'll fix it.
But it's late here, I'll may get back to you much later.

Thank you really much for your explained answer, it is not taken for granted.

Anyhow, I installed manjaro as legacy, and it did not show up in my boot options.. I have also tried using uefi, and same. What am I doing wrong? before trying to install manjaro again I even cleaned my /efi partition (excluding microsoft files of course).

and once again, thank you for trying to help!

EDIT: Installed it in UEFI mode. manually added it via my BIOS. WORKED!!

Thank all of you who helped! now to customize my system

Read this guide

1 Like

That means your windows is actually UEFI.
You had said..

Can you when booted to manjaro, provide the following..

test -d /sys/firmware/efi && echo UEFI || echo BIOS
findmnt -s
sudo parted -l
sudo blkid

Also you said

Can you explain? You added to BIOS? Not grub.cfg? Or do you have to go to boot-setup (F8~F12) to boot Windows?

Lastly, what is computer make and model?
I know you have 'fixed' your problem (and good to hear) but it is interesting to know what you have done.


So yea I thought that I had installed win10 in legacy mode (I think that this is because I was unable to boot Manjaro in UEFI mode but now I know that it wasn't related) but I wasn't..

[yuvalhadar@yuvalhadar-laptop ~]$ test -d /sys/firmware/efi && echo UEFI || echo BIOS
[yuvalhadar@yuvalhadar-laptop ~]$ findmnt -s
TARGET    SOURCE                               FSTYPE OPTIONS
/boot/efi UUID=D9EA-6780                       vfat   defaults,noatime
/         UUID=759fd633-2da7-4a43-905a-41f591fbd984
                                              ext4   defaults,noatime,discard
/tmp      tmpfs                                tmpfs  defaults,noatime,mode=1777
[yuvalhadar@yuvalhadar-laptop ~]$ sudo parted -l
[sudo] password for yuvalhadar: 
Model: ATA SanDisk SDSSDA24 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
1      1049kB  615MB  614MB   ntfs         Basic data partition          diag
2      616MB   964MB  348MB   fat32        EFI system partition          boot, esp
3      965MB   981MB  16.8MB               Microsoft reserved partition  msftres
4      981MB   195GB  194GB   ntfs         Basic data partition          msftdata
5      195GB   240GB  45.2GB  ext4

Model: ATA ST9500325AS (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
1      1049kB  500GB  500GB  primary  ntfs         boot

[yuvalhadar@yuvalhadar-laptop ~]$ sudo blkid
/dev/sdb1: UUID="2F9FA77A3890F7B0" TYPE="ntfs" PARTUUID="bd76aee8-01"
/dev/sda1: LABEL="M-bM-^@M-^OM-bM-^@M-^OM-WM-)M-WM-^WM-WM-^VM-WM-^UM-WM-(" UUID="01D37BF8D8AF7680" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d8b43970-7bf8-01d3-b818-5a6cfcbde900"
/dev/sda2: UUID="D9EA-6780" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="d9ff7a70-7bf8-01d3-3891-f76cfcbde900"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="0019fe97-d860-da5c-f8fb-df012efd3300"
/dev/sda4: UUID="01D37BFD5B5F2220" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="5b7fdd10-7bfd-01d3-88ee-b1adfebde900"
/dev/sda5: UUID="759fd633-2da7-4a43-905a-41f591fbd984" TYPE="ext4" PARTUUID="a8054e40-4d6d-4b0f-bfb8-3ac43d35daef"
[yuvalhadar@yuvalhadar-laptop ~]$ 

In my BIOS I had no entry for "manjaro bootloader" or something similar, so I added it manually- I can't remember exactly how, but it let me choose a file to boot (I don't know how to explain it) so I have entered /EFI/manjaro and chose manjaro.efi or something like that.

Anyway, after I have set it to my first boot option it worked, and manjaro booted :slight_smile:

The model of my PC is Asus X554L

Good day!

Yes, your system is uefi/gpt. That explains it.
Cheers and take care.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by