Can't boot Manjaro on Lenovo 320 15AST

I tried to install it with and without EFI partition, boot in in legacy and in efi modes. Other distros like Ubuntu, Fedora - fine (they have EFI partition).
It's just not on the list.

At ubuntu terminal, what's

parted -l
efibootmgr -v
cat /proc/cmdline

you may need root (sudo) for some above.

john@localhost:~$ parted -l
Error: Can't have a partition outside the disk!
Ignore/Cancel? ^C                                                         
Model: TSSTcorp DVD+-RW SU-208FB (scsi)
Disk /dev/sr0: 4700MB
Sector size (logical/physical): 2048B/2048B
Partition Table: unknown
Disk Flags: 

john@localhost:~$ efibootmgr -v
BootCurrent: 0002
Timeout: 2 seconds
BootOrder: 0002,0001,0000,0014,0015,0016,0017,0018,0019,001A,001B
Boot0000* Windows Boot Manager	HD(1,GPT,cdd26475-68f2-11e8-82e9-b82a72ab2fe8,0x28,0x64000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* Fedora	HD(1,GPT,cdd26475-68f2-11e8-82e9-b82a72ab2fe8,0x28,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0002* ubuntu	HD(1,GPT,cdd26475-68f2-11e8-82e9-b82a72ab2fe8,0x28,0x64000)/File(\EFI\ubuntu\shimx64.efi)
Boot0010  Setup	FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu	FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0012  Diagnostic Splash	FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013  OilDiagApp	FvFile(f8397897-e203-4a62-b977-9e7e5d94d91b)
Boot0014* ATA HDD: WDC WD3200LPVX-00V0TT0                  	PciRoot(0x0)/Pci(0x11,0x0)/Sata(0,0,0)..bYVD.A...O.*..
Boot0015* ATA HDD1:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
Boot0016* ATAPI CD: TSSTcorp DVD+/-RW SU-208FB              	PciRoot(0x0)/Pci(0x11,0x0)/Sata(1,0,0)......!N.:^G.V.T
Boot0017* USB HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot0018* PCI LAN: Realtek PXE B02 D00	BBS(Network,Realtek PXE B02 D00,0x0)............................................................................A.....................
Boot0019* USB FDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot001A* USB CD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot001B* NVMe:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a4)
john@localhost:~$ blkid
/dev/sr0: UUID="2018-05-07-18-00-47-00" LABEL="MJR17110" TYPE="iso9660" PTTYPE="dos"
john@localhost:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-0-rescue-42a71d30323a495d9a9ae9cd74b8040d root=/dev/sda3

but now there is no hard disk left and now

On topic,
You need to disable secure boot when installing Manjaro and booting it up.
Try it. Let us know.
It is also probably tied in with Microsoft.

However, you have a few things outside this topic.

  1. Your disk is aligned properly or partitioned well
    your 'parted -l' won't print with 'unknown partition table'
    Try 'sudo blkid' (not 'blkid') - see it it prints.
    Since 'parted -l' won't print, try 'sudo fdisk -l'
  2. You are booting up with shim, Can Ubuntu in your system boot without shim?
    If it cannot, your Lenovo is probably tied in with Microsoft.
  3. You are booting Ubuntu here not on a kernel but on a 'rescue' kernel?
    Why? Can you explain this? recovery? Is 'normal' Ubuntu booting?
1 Like

With EFI and secure boot off doesn't work too.

$ blkid
/dev/sr0: UUID="2018-05-07-18-00-47-00" LABEL="MJR17110" TYPE="iso9660" PTTYPE="dos"
$ su -c 'fdisk -l'
Disk /dev/sda: 298.1 GiB, 320072933376 bytes, 625142448 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: CDD1B8FA-68F2-11E8-82E9-B82A72AB2FE8

Device         Start       End   Sectors   Size Type
/dev/sda1         40    409639    409600   200M EFI System
/dev/sda2     409640   2506791   2097152     1G Linux swap
/dev/sda3    2506792  33964071  31457280    15G Linux filesystem
/dev/sda4   33964072 528422911 494458840 235.8G Linux filesystem
/dev/sda5  562229248 564326399   2097152     1G Linux swap
/dev/sda6  564326400 595783679  31457280    15G Linux filesystem
/dev/sda7  595783680 625142414  29358735    14G Linux filesystem
/dev/sda9  530520064 551491583  20971520    10G Linux filesystem
/dev/sda10 551491584 562229247  10737664   5.1G Linux filesystem
  1. How to know about shim ? There Lenovo splash screen and then list of systems.
  2. Have no idea, didn't change anything like that for Ubuntu. It is normal booting.

but now there is no hard disk left and now
don't understood that.

john100, just try...

Did not get your "sudo blkid", (so i don't know your $esp for efibootmgr)
When installing manjaro select $esp (sda1 - got your 'fdisk -l') as mount point /boot/efi - do not format.

Try it. Repeat - disable secure boot.

$ su -c 'blkid'
/dev/sda1: SEC_TYPE="msdos" LABEL="EFI" UUID="F207-6771" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="cdd26475-68f2-11e8-82e9-b82a72ab2fe8"
/dev/sda2: UUID="b2078df9-3bb8-4fd3-b86f-82014c000c20" TYPE="swap" PARTUUID="e3729c0c-68f2-11e8-82e9-b82a72ab2fe8"
/dev/sda3: UUID="2e913393-005d-4974-a8b9-35e30f93de77" TYPE="ext4" PARTUUID="ea19768a-68f2-11e8-82e9-b82a72ab2fe8"
/dev/sda4: UUID="95acbd82-9e8b-46e0-90dc-140bf6f35eba" TYPE="ext4" PARTUUID="99345764-68f3-11e8-82e9-b82a72ab2fe8"
/dev/sda5: UUID="23076214-7d4e-409b-946a-a0f1ebc73d68" TYPE="swap" PARTUUID="a935d331-c006-4f19-a2c6-c602426ec5c8"
/dev/sda6: UUID="c56ea6b1-f155-4f82-9f1c-05bcb0723add" TYPE="ext4" PARTUUID="a5453c24-3c18-456a-a8c1-a74b1e9a19cf"
/dev/sda7: UUID="47ace854-9c5e-45aa-bdaa-409a985a0526" TYPE="ext4" PARTUUID="644c16d2-9a63-4227-a9df-a19b7f605535"
/dev/sda9: UUID="0e8e769e-59ba-4d7e-bc67-6e6f44e392c3" TYPE="ext4" PARTUUID="1fa5aaaf-2ab2-4f74-998a-eff690a1660b"
/dev/sda10: UUID="44bea655-92f9-4f0b-9d9c-28d90ab8fa9e" TYPE="ext4" PARTUUID="0dddc014-7878-4514-b2f6-cd6dc0fa6ab8"
/dev/sr0: UUID="2018-05-07-18-00-47-00" LABEL="MJR17110" TYPE="iso9660" PTTYPE="dos"

Is there something ?

Tried again: EFI - didn't format it, secure boot off. Still no Manjaro on the list.

Look at this.
Does Manjaro boot this way?
Do all steps including [Additional UEFI commands]
And provide new "efibootmgr -v" output

Could you explain this. How exactly todo it ? What additional command ?


1 Like

I made it work, thank you very much.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by