Can't Boot Pinebook Pro from Micro SD Card with Image of Manjaro-ARM-xfce-pbpro-20.06.img

After having the problems described in another thread, I decided to try with a fresh installation using the instructions on the wiki. I downloaded the image from Manjaro's page, checked its sha1, extracted it, and, as recommended at the NOOB page, used Disks (gnome-disk-utility 3.26.2) to copy the image to a 32GB Samsung class 10 Micro SD card. No errors reported from any of this. After these operations, Disks says the SD card looks like the first screenshot below,
and Gparted says it looks like the second screenshot below.

Put the SD card into a usb adapter, plugged the adapter into the powered down Pinebook Pro, and powered up, and it apparently booted from the internal eMMC to the nonfunctional login screen that is discussed in my previous topic.

Put the SD card directly into the slot on the powered down PB Pro and powered up. The power led on the PBP flickered, went steady green, and stayed there, while the scren remained blank and stayed that way. At this point, I sometimes tried the escape key to test whether a nonworking gui might be obscuring a text interface, but the escape key seemed to have no effect.

Using Etcher instead of Disks to flash the image to the SD did not help.

Noticing the warning on the Pinebook Pro releases page that "If Manjaro is installed on the eMMC you may experience issues booting different installations from SD card.", I followed the link to further information, and tried to follow the suggested workaround, which is:

  1. On the SD card, open up the root partition and go to /boot/extlinux/extlinux.conf.
  2. Add the following to the APPEND line: console=ttyS2,1500000 video=eDP-1:1920x1080@60 video=HDMI-A-1:1920x1080@60 .
  3. Save the file and put the SD card into the Pinebook Pro and boot.

However, when I mounted ROOT_MNJRO on my working Linux box, and viewed it as root, I don't see anything in ROOT_MNJRO/boot/

I am definitely having a lot of fun.

2020-07-19 Disks Showing SD Card

2020-07-19 Gparted showing SD Card.

That's because it's actually in the BOOT_MNJRO/boot/, not on ROOT_MNJRO.

So try mounting BOOT_MNJRO and look in it's boot/extlinux/extlinux.conf.

1 Like

Thanks. Did not see a

BOOT_MNJRO/boot/extlinux/extlinux.conf

but did find a

BOOT_MNJRO/extlinux/extlinux.conf

to which I added the suggested entries to the APPEND line, so that the whole file contained:

LABEL Manjaro ARM
KERNEL /Image
FDT /dtbs/rockchip/rk3399-pinebook-pro.dtb
APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS2,1500000 root=LABEL=ROOT_MNJRO rw rootwait video=eDP-1:1920x1080@60 video=HDMI-A-1:1920x1080@60 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash console=ttyS2,1500000 video=eDP-1:1920x1080@60 video=HDMI-A-1:1920x1080@60

Same result.

Got some new 16GB San Disk class 10 Ultra microSDHC UHS-I cards today, wrote the same image I was using unsuccessfully to one of them, put it in the Pinebook Pro, powered up, and it booted and installed like a charm. I can't see any obvious differences in the specs from the Samsung card with the same image that would not boot, but I have not tested them with a utility.

Thanks to all for the suggestions. I learned a lot and had a lot of fun. Now, I'm looking forward to having less fun and getting more work done, at least for a little while. You can be sure I will not again try to make the fonts and icons bigger by changing the resolution.

1 Like

If you want to give that older / seemingly faulty card a run through the wringer, feed it to f3 :wink:

Thanks. I got a 503 error from and Arch site at the link but installed it from another repository on another OS. Ran well and reported average speed and no errors. Should it do more?

f3probe tries to identify fake drives, and f3write & f3read are the media test. If you ran the latter, and no errors were reported, it would seem it's just a incompatibility glitch, as the media is fine. Then again, since you used Etcher, unless you disabled the verify stage, the fact that Etcher didn't fail the MicroSD suggests some sort of incompatibility, rather faulty/fake media.

So no, probably not much more you can do, since it seems like it works fine with another microSD.

1 Like

If you really want to know if card is crap, so many are
(OK for camera or such, not as storage for computer)
(cd to card)
sudo iozone -e -I -a -s 100M -r 4k -r 16k -r 512k -r 1024k -r 16384k -i 0 -i 1 -i 2
Upper right 4 (2x2) anything under 1M/s, forget it (3M/s is about as good as it gets)
Especially when doing upgrades
Of course, always test 1st for fakes

1 Like

Thanks. f3probe reported good news. I wonder whether the fact that it is a 32 GB card rather than a 16 GB card prevented the image on it from booting.

Thanks. Did not know about this tool either.

I doubt it... first boot should resize the main partition so that it fills the card, which can take a little while, but we're only talking minutes here, not 10s of minutes or hours :wink: If that were the culprit, that would once again suggest something wrong with the card / compatibility.

Adding to wdt's excellent suggestion, this is one reason I use Samsung EVOs... they have excellent random read/write performance. If you don't want to purchase a card and find out the hard way it's no good, look for cards marked A1, as these are certified to have usable read/write performance for app (ie. random) usage, not just bulk read/write speeds.

Forum kindly sponsored by