Can't boot to manjaro after installing NVIDIA drivers

As instructed from internet, I've opened manjaro settings manager, and installed drivers for my nvidia gtx 1050 card.

After installation I got the mesage saying that installation was succesful. Then I've tried to reboot my pc. I clicked 'reboot' option. PC shut down as usual. However, when I saw the GRUB and selected 'Manajro' option, after some time command line freezed.
The last lines were:

acpi: Unsupported Event [0x86]
acpi: Unsupported Event [0x86]
acpi: Unsupported Event [0x86]
acpi: Unsupported Event [0x86]
etc... there was 10 of this

So I were not able to boot manjaro. I found out how to uninstall drivers with live USB, but this isn't a solution. I want to make use of my card.

Here is output of 'inxi -G' before installation:

Graphics:  Card-1: Intel driver: i915 v: kernel 
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A 
           Display: x11 server: X.Org 1.19.6 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.0.4 

Before I installed drivers I had to click 'e' at GRUB and add 'nouveau.modeset=0' to line starting with 'linux', otherwise I would get same error.

I've tried to install all drivers seen on image above (each time reinstalling whole system), none of them worked.
Also installation of mhwd-detected driver breaks my system.

I'm on hp omen 15-ce013nw laptop.

I intented to use Manajro as my main OS, but I can't since I don't have GPU set up...

Because you have a DUAL GPU configuration, the installation of video-nvidia is not ok, you need to follow this:

in other words, from your configuration, those in green have to be installed

This is also not working. Same error. I've tried all drivers available in mhwd, none of them worked.

:slight_smile: but did you make sure whatever modifications you made in /etc/defaul/grub you reversed back ?

For this did you added the i915.enable_rc6=0 in grub parameters ?
Also would be nice to know on what kernels versions did you boot ...

I haven't added i915.enable_rc6=0 before, but adding it doesn't help. I tried uninstalling default video-linux driver too. Also doesn't help.
I am using kernel 4.14.47-1 (which is marked as recommended)
When booting from live usb, I have same errors. For live usb only selecting driver=free and nouveau.modeset=0 works.

but did you make sure whatever modifications you made in /etc/defaul/grub you reversed back ?

I haven't made any changes to /etc/default/grub

Please also note that I'm rather new to linux, and deffinetly not familiar with part of it's features.

Probably you will have to go this way then, or something similar depending on you GPU's and if the nvidia one needs the legacy version ...

Check this out. Similar GPUs. Notice the Grub parameters used.

I've tried these stępa as explained, but stilo getting the same error :frowning:

As you said

Can you describe how you followed those steps and what were the errors?
Did you update grub after the changes?

Also provide these for checking (on your installed system only, if possible)

pacman -Qs acpi
systemctl status acpid

Give it a try to these workarounds:

You may need to combine few of them.
I'm using acpi_osi=! acpi_osi='Windows 2009' pcie_port_pm=off on my side

This worked for me too. Thanks to everyone who helped!

For someone who is having simmilar problem here is what I exacly did:

  1. Reinstall Manjaro to make sure everything is clear.
  2. Install packages from octopi:
    32 bit versions of these
  3. Add myself to 'bumblebee' group:
    sudo gpasswd --add MyUserName bumblebee
  4. Enable bumblebee daemon
    sudo systemctl enable bumblebeed.service
    sudo systemctl enable bumblebeed
  5. Go to 'Manjaro Settings Manager' -> Hardware configuration and install driver 'video-hybrid-intel-nvidia-bumblebee'
  6. Add options acpi_osi=! acpi_osi='Windows 2009' pcie_port_pm=off to grub configuration:
    sudo nano /etc/default/grub
    Change line GRUB_CMDLINE_LINUX_DEFAULT="quiet" to:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=! acpi_osi=\"Windows 2009\" pcie_port_pm=off"
  7. Reboot. This time I was able to see GUI and log in.
  8. To check if it actually works I run optirun glxgears. With my GTX 1050 I have FPS count greater than 1800

However, there is still one issue.
Before installation there was following line in output of inxi -G command:
NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A
After first reboot the N/A part changed. I was so happy about this, but:
After another reboot the driver was again N/A, however the optirun glxgears still shows above 1800 FPS.

Two questions:

  1. What does it mean? Does the driver still work now?
  2. How to fix it, so I again see driver version instead of N/A?

I think, since you have X running, some driver is probably running, so it must be an inxi issue. Even if it is intel or modesetting it should be reported.

If it is random, I have no idea. Actually, it is a reporting issue and the most reliable report IMHO is Xorg logs and journalctl.
Maybe try these for some difference

inxi -Gxxx --display :0
inxi -Gxxx --display :8
optirun inxi -Gxx

I forgot I have to run it with optirun... optirun inxi -G is fine.
Again thanks everyone for help.

I guess I'm having the same issue. My laptop is Acer e5-575g-7211. In my case, my machine randomly hangs or boots successfully. But if I uninstall video-hybrid-intel-nvidia-bumblebee, it boots with no problem. I already tried the working solution above but still the problem persists. I also have tried different options like acpi_osi='!Windows 2003/2015' from Arch Wiki to no avail.

What other possible workarounds could I try? Another thing, how can I be sure of what's causing this issue? Reviewing the logs thru journalctl after a successful boot shows no errors regarding video/graphic. All I observe is when I remove the hybrid driver, the problem goes away.


I went through hell for about 6 weeks with NVIDIA on Manjaro. I have an MSi GE72 w/ GTX1060. Start up freezes, shutdown freezes, unable to use lspci, inxi, mhwd, hardware config in the settings, etc. Eventually using the computer got near impossible.

Apparently the source if the issue is with how Manjaro handles hybrid graphics out of the box AFTER you've installed it. What I mean is that if you are installing Manjaro, everything works. Once you've installed it and reboot it, there goes the neighborhood.

Then I came across a suggestion to use this in GRUB:

GRUB_CMDLINE_LINUX_DEFAULT='acpi_osi=! acpi_osi="Windows 2009" acpi_rev_override=5'

Now I can use everything that I couldn't before. The only issue that has lingered is that using headphones is impossible. No matter what they are seen as a front speaker and using HDAJackRestask and a bunch of other suggestions does nothing, so I had to give up on the idea and use an external player - which sucks since I love my CMUS.

Anyway, hope that helps someone.

This also doesn't work. I am also nearing your 6 weeks span :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by