Can't boot Windows 10 from Bios after installing Manjaro (2 SSDs)

There is actually no reason to disconnect the drive physically while you can bring up the one-time bios boot menu by pressing the appropriate Fn-key when you power up your machine and choose Windows Boot Manager from there.

Sometimes it is easier then messed up BIOS.

For booting up from the one-time bios boot menu you would not need to change any settings in the bios proper. That is my experience. Yours may differ.

You are right you can choose booting drive, I just want to know if his win boots
he wrote

I can't even boot Windows from the bios anymore

Is there any way to know if Windows was installed in either Legacy or UEFI mode from within Manjaro?, I can't access Windows, even though I used to be able to from the Bios.
I'm fairly certain that it was installed in UEFI mode. What I find very strange is that I lost the ability to boot Windows from within the Bios only after I installed Manjaro, it doesn't happen with any other Linux distro I've tried.

Then you lost the EFI partition somehow.

You are right!
I missed that part. Sorry.

I suspect I did, but I can't get my head around how that happened nor how to fix it.

I know it will not help you, I do install windows 10 first THEN disconnect that disk and connect disk where I install Linux then shut down connect back win10 disk and boot into linux then run sudo update-grub. This is the safest way how to dual boot with two or more disks. You are then certain that bootloader for each OS is on its disk.

And of course you need to set up BIOS to boot from Linux as default...

1 Like

It does help me, this is probably the way I will prevent this from happening again, but I would really really REALLY appreciate not having to reinstall windows.

If reinstallation of Windoze in UEFI/GPT mode would have been an option then I would follow @VoDo's recommendation to disconnect the Linux disk before this installation. Afterwards you should be able to boot both systems from the Linux disk after setup in BIOS and a sudo update-grub.

Maybe @gohlip can help to fix your Windoze installation...

1 Like

Lets hope he can; the only reason I even have Windows installed is because Starcraft 2 runs like dog barf on any Linux distro I've tried since 2010 (tried d9vk, gallium nine, vanilla wine) and MK11 doesn't even get past the splash screen.

If you still have have your Windows installation media, then the following guide is, what I believe, what you need to restore your Windows EFI partition:

Disclaimer: I have never done this myself, but the article and the steps proposed seem quite reasonable

3 Likes

I have the media, what worries me is that the guide states that the EFI partition should be around 100 MB and I don't see but two partitions on that drive, a 16 MB partition, and the main Windows partition.

I'll try this in a few hours, I need some sleep, I've been going on this for way too long, and it's already 6:40 am where I'm at.

@Herzchell

Most likely, you have formatted the $esp (/boot/efi) partition (that is shared with windows) during manjaro installation.
So let's check it out.

At manjaro terminal

findmnt /boot/efi
ls /boot/efi/efi/

Most likely sdc1 (in first command)
and other than 'manjaro' and maybe 'boot', you do not have 'microsoft' listed (in 2nd command).

You will have to reinstall windows bootloader, good news is that you do not have to reinstall the whole windows, just its bootloader. Bad news is I haven't done this but from others that I read, it can be quite simple. So find out how and sorry, I cannot help on this.
After reinstalling windows bootloader, manjaro's boot will be lost (windows does this), but just use the [Simple Configfile Method] to get back the manjaro boot.

That should be fine.



Now to explain, it is better to have a separate $esp for windows and other linux $esp.
Reason being, some windows major updates may involve updating a new bootloader for windows and that will mess up linux bootloaders if sharing the same $esp. {But you can easily get back using the same method in link}.

So, in gpt, it is easier to set up (and fix) dual-boot than in a msdos/bios-legacy dual-boot which uses and shares mbr rather than using $esp's. In gpt/uefi, there is really no need to separate or disconnect disks (neither in msdos/bios-legacy) and easier to fix. In msdos/bios-legacy, I can understand (new) users disconnecting disk to prevent windows (and linux from windows) messing up the boots. But for an experienced user like Marte and Wollie, it is never necessary. It is also not necessary to have many disks to cater for many OS's, either in bios-legacy or uefi. In fact, I think it is easier for new users not to have so many disks. One is fine (disk space permitting). For experienced users, that (one or many) does not matter.

Hope that you can get beyond this that so many old users seem to get stuck on.
Marte, Wollie and I would be happy to assist.
Good luck and cheers.

2 Likes

You're right on both statements regarding the commands you provided. I will try to fix the windows bootloader with the guide that Marte provided, and get the Manjaro boot with the config file thing then I'll report back.
Thank you all.

3 Likes

I am not sure how this has happened.

Maybe the safest option would be to create a 100MB FAT32 partition flagged as esp,boot from within your Manjaro install, on your Windows disk and follow the instruction of the article from that point onward.

And perhaps to minimize the risk of messing up the other disks on your system, disconnect them prior to proceeding with this.

Please do remember that I haven't done the proposed steps on that article myself, so I am walking on a thin ice here.

1 Like

You can use the same $esp (sdc1 in manjaro) for windows if recreating a new partition is too difficult.
Suggest you do not touch that 16 MB partition.

Of course, if you can create a new $esp (suggest 200MB for windows only), that will be fine.
If you create a new $esp for windows, boot into windows and chek if it boots fine first.
Then boot into Manjaro (use the bios method) and boot into manjaro and just do
sudo update-grub

If you want to change the priority boot (windows now will be first), do
efibootmbr
sudo efibootmgr -o xxxx,yyyy

where xxxx is manjaro boot shown in first command.

2 Likes

I was not able to recover my Windows installation, but what I did do was to unplug the SSD with Manjaro as to not tamper with its bootloader.
After reinstalling Windows I ran sudo update-grub and I can see Windows now; I don't know why installing Manjaro deleted or messed with the Windows bootloader since they were (supposedly) on different drives but if it's a bug it should probably be looked at.

Also, isn't it weird that my Windows installation did not even have enough space to create a new ESP partition?

Anyway, thank you all for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by