Can't Change Wallpaper

I cannot change the desktop wallpaper.
I have tried the 'set as wallpaper' option from image---failed
tried the settings---failed
When I right click from the desktop nothing happens---no menu
Also the window title bar is missing form all apps. The desktop panel doesn't show any opened applications in it. Desktop shortcuts are not working.
So used the command xfwm4 --replace and the panel is back now but the wallpaper issue is not solved and the desktop is still not showing any menu on right click.

$ inxi -Fxxxza --no-host
System:
  Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 
  root=UUID=44345153-90c0-44ac-8b11-12d37c293b22 rw quiet apparmor=1 
  security=apparmor resume=UUID=04ad1d64-a99d-4940-8ebc-7c8e07e034d2 
  udev.log_priority=3 
  Desktop: N/A wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 15 Notebook PC 
  v: 0975120000405F00000610180 serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: Hewlett-Packard model: 2337 v: 05.24 serial: <filter> UEFI: Insyde 
  v: F.36 date: 12/18/2014 
Battery:
  ID-1: BAT1 charge: 30.2 Wh condition: 31.2/41.4 Wh (75%) volts: 17.1/14.8 
  model: COMPAL PABAS0241231 type: Li-ion serial: <filter> status: Charging 
CPU:
  Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2D 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 17565 
  Speed: 799 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 798 2: 799 
  3: 798 4: 800 
  Vulnerabilities: Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 
  620M/625M/630M/720M] 
  driver: N/A bus ID: 09:00.0 chip ID: 10de:1140 
  Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 19.1.5 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:9ca0 
  Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 5000 bus ID: 08:00.0 
  chip ID: 10ec:8136 
  IF: enp8s0 state: down mac: <filter> 
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 3000 
  bus ID: 0a:00.0 chip ID: 10ec:b723 
  IF: wlp10s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 356.64 GiB (76.6%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A350 scheme: GPT 
Partition:
  ID-1: / raw size: 60.49 GiB size: 59.29 GiB (98.02%) 
  used: 21.61 GiB (36.4%) fs: ext4 dev: /dev/sda2 
  ID-2: /home raw size: 391.60 GiB size: 384.45 GiB (98.18%) 
  used: 335.04 GiB (87.1%) fs: ext4 dev: /dev/sda3 
  ID-3: swap-1 size: 7.81 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda4 
Sensors:
  System Temperatures: cpu: 41.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 168 Uptime: 12h 50m Memory: 3.77 GiB used: 1.26 GiB (33.5%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 alt: 8 clang: 8.0.1 Shell: bash 
  v: 5.0.9 running in: xfce4-terminal inxi: 3.0.36 

This seems to be a problem related to xfdesktop.

First check if the package is installed (maybe you uninstalled it by accident?):

pacman -Qs xfdesktop

If there is no output after running the above command, xfdesktop is not installed, so you have to install it

sudo pacman -Syu xfdesktop

and reboot your system (or logout/login).


In case xfdesktop is already installed, see if you have any saved sessions in Settings Manager > Session and Startup > Saved Sessions and check if xfdesktop is present in the list of applications in that tab.
If it's not present in that list, clear any saved sessions and reboot your system (or logout/login).


Something else you can try is running xfdesktop --replace in a terminal window and see if this is going to activate xfdesktop.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by