Can't Click with Mouse or Navigate Programs with Mouse

What is the issue:
My left click doesn't seem to respond at all, right-click only works on the desktop sometimes, I can't navigate any applications using the mouse, when I hover over icons in my latte Dock they do still respond by growing in size as I hover over them.

What have I tried:
A different mouse, different USB ports, rolling back to an earlier backup with timeshift, updating using "yay - Syyu".

More details:
The issue occurs immediately after login, previously I have had no issue of this sort and they simply appeared out of nowhere. If I uplug the mouse the left click sometimes works for one click then stops working again.
My application windows don't seem to grab input from the mouse despite that being set and it previously worked fine.
If I click anything then the mouse hover over feature also stops working, I can still move the cursor around on the screen at all times, keyboard input still works fine.
I cannot take control of any applications at all (even with the keyboard) unless I use Alt+Tab to select the program I want to use, if I then click with the mouse at all then the program no longer responds to input and I have to use Alt+Tab again to gain window focus again.

This happens with more than one mouse.

I am using Manjaro KDE. Up-to-date stable version.

I never had these issues previously on the same install, and I think this is user error but I can't find a solution thus far.

I cannot use my system because of this.

Any help would be appreciated.

Have you tried a different mouse? It might broke

:+1: Welcome to Manjaro! :+1:

Does this also happen in another user that has no latte dock and a standard theme?

Also, please read this:


and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:innocent:

I have similar problem. After booting, the left click is not working. I can right click and the pointer is moving but there are places where I can't left click. Sometimes all of the area aren't clickable but there are times where it work in some areas, for example in the attached screenshot. The left browser (chrome) is unclickable while the right browser (Firefox) is clickable. There are times also where both aren't clickable.

My temporary fix for now is to restart device xinput with the following script:

#!/bin/bash

device="SteelSeries SteelSeries Rival 300 Gaming Mouse"
state=$(xinput list-props "$device" | grep "Device Enabled" | cut -f3)

if [ $state == 1 ]; then
    xinput --disable "$device"
    xinput --enable "$device"
else
    xinput --enable "$device"
fi

Sytem info and logs:

System:    Kernel: 5.6.5-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
           root=UUID=d6a069c3-c57b-4637-a422-dd82714d7a63 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: i3 4.18 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Notebook product: P15SM-A/SM1-A v: N/A serial: <filter> 
           Mobo: Notebook model: P15SM-A/SM1-A serial: <filter> UEFI: American Megatrends 
           v: 4.6.5 date: 03/27/2014 
Battery:   ID-1: BAT0 charge: 2.0 Wh condition: 12.4/77.0 Wh (16%) volts: 15.7/14.8 
           model: Notebook BAT type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Quad Core model: Intel Core i7-4810MQ bits: 64 type: MT MCP 
           arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 27 
           L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44712 
           Speed: 3344 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3344 2: 2501 3: 3153 
           4: 2655 5: 2670 6: 3471 7: 2482 8: 3216 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf 
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 
           mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
           STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: CLEVO/KAPOK 
           driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0416 
           Device-2: NVIDIA GK104M [GeForce GTX 870M] driver: N/A bus ID: 01:00.0 
           chip ID: 10de:1199 
           Display: x11 server: X.Org 1.20.8 driver: intel compositor: compton 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 20.0.4 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
           vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:0c0c 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: CLEVO/KAPOK 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
           Device-3: NVIDIA GK104 HDMI Audio driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0e0a 
           Device-4: Plantronics Plantronics .Audio 628 USB type: USB 
           driver: plantronics,snd-usb-audio,usbhid bus ID: 2-9:6 chip ID: 047f:c012 
           Sound Server: ALSA v: k5.6.5-3-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: CLEVO/KAPOK driver: r8169 v: kernel port: d000 bus ID: 05:00.2 
           chip ID: 10ec:8168 
           IF: enp5s0f2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be 
           v: kernel port: c000 bus ID: 06:00.0 chip ID: 10ec:b723 
           IF: wlp6s0 state: down mac: <filter> 
           IF-ID-1: br-3a96158791d5 state: up speed: 10000 Mbps duplex: unknown 
           mac: <filter> 
           IF-ID-2: docker0 state: down mac: <filter> 
           IF-ID-3: veth2612f7d state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-4: veth977e5ee state: up speed: 10000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 41.93 GiB (3.6%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
           block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: A3J0 scheme: GPT 
           ID-2: /dev/sdb vendor: Crucial model: CT256M550SSD1 size: 238.47 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: MU01 
           scheme: GPT 
Partition: ID-1: / raw size: 60.55 GiB size: 59.35 GiB (98.02%) used: 41.90 GiB (70.6%) 
           fs: ext4 dev: /dev/sdb7 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 240 Uptime: 1m Memory: 15.56 GiB used: 1.80 GiB (11.6%) Init: systemd 
           v: 244 Compilers: gcc: 9.3.0 Shell: zsh v: 5.8 running in: server inxi: 3.0.37 

unclickable2

It would be great to find the main issue and fix this though.

1 Like

excellent first post!

1 Like

I have found the culprit on my case and the issue is really with my mouse hardware. I have Steelseries rival 300 and there are extra buttons, one button is stuck and I haven't noticed it as I am not using that button. I just realized that something is wrong with my mouse since when I open a browser, there are times when it goes back to a history automatically, something like it's clicking the back button on its own. I have verified the issue when running sudo xev and then I saw these events running indefinitely:

ButtonPress event, serial 34, synthetic NO, window 0x3200001,
    root 0x173, subw 0x0, time 275944, (369,551), root:(1652,555),
    state 0x0, button 8, same_screen YES

ButtonRelease event, serial 34, synthetic NO, window 0x3200001,
    root 0x173, subw 0x0, time 276114, (369,551), root:(1652,555),
    state 0x0, button 8, same_screen YES

That means button 8 of my mouse is sending an event without me clicking it so I checked it and then I realized that it is stuck, I just fixed it by sticking a knife to it :smiley:
Not the problem does not occur anymore.

1 Like

Too bad you used a :dagger: instead of a :hammer: to solve your problem... :wink:

Let's see if that helps OP as well. I would never have thought of a stuck button so:

:+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by