Can't create LVM logical volume via Architect or GUI Installer

I am planning to put Manjaro on my laptop with LVM so I am practicing the installation in VirtualBox.

This is some weird behavior of Manjaro Architect in VirtualBox. I am creating a volume group and then trying to create a logical volume, when doing later it first says it cannot find the just created volume group then just afterwards it says the Logical Voulme is created.

Here are the screenshots below explaining my operations from Architect, tell me what I am doing wrong:

VirtualBox_Manjaro LVM_31_03_2020_15_12_15 VirtualBox_Manjaro LVM_31_03_2020_15_12_18 VirtualBox_Manjaro LVM_31_03_2020_15_12_25 VirtualBox_Manjaro LVM_31_03_2020_15_12_31 VirtualBox_Manjaro LVM_31_03_2020_15_12_50 VirtualBox_Manjaro LVM_31_03_2020_15_13_01 VirtualBox_Manjaro LVM_31_03_2020_15_13_09
VirtualBox_Manjaro LVM_31_03_2020_15_13_17 VirtualBox_Manjaro LVM_31_03_2020_15_13_26 VirtualBox_Manjaro LVM_31_03_2020_15_13_26_1 VirtualBox_Manjaro LVM_31_03_2020_15_13_29 VirtualBox_Manjaro LVM_31_03_2020_15_13_33 VirtualBox_Manjaro LVM_31_03_2020_15_13_37 VirtualBox_Manjaro LVM_31_03_2020_15_13_49 VirtualBox_Manjaro LVM_31_03_2020_15_13_53
VirtualBox_Manjaro LVM_31_03_2020_15_13_57 VirtualBox_Manjaro LVM_31_03_2020_15_14_01 VirtualBox_Manjaro LVM_31_03_2020_15_14_06 VirtualBox_Manjaro LVM_31_03_2020_15_14_09

Where am I going wrong ?

Is this a problem with VBOX ? Doesn't seem that way to me since other distributions have LVM installed fine.

Looks like a bug. You could just use gui tools to create your desired lvm layout and mount it in manjaro-architect?

How do I report this bug ?

Here is another one for you:

I tried creating using the GUI installer, but the volume group is never written:

Here are the screenshots:

I tried to create a Volume Group after creating an lvm_pv2 partition.

VirtualBox_Manjaro LVM_31_03_2020_17_04_24 VirtualBox_Manjaro LVM_31_03_2020_17_04_50 VirtualBox_Manjaro LVM_31_03_2020_17_05_12 VirtualBox_Manjaro LVM_31_03_2020_17_05_20 !
VirtualBox_Manjaro LVM_31_03_2020_17_05_31

Now the Volume group should be present, but when I try to create another volume group with the same name - I can. Also I cannot find my previous Volume group.
VirtualBox_Manjaro LVM_31_03_2020_17_06_02 VirtualBox_Manjaro LVM_31_03_2020_17_05_31 VirtualBox_Manjaro LVM_31_03_2020_17_06_02

There is something seriously wrong with LVM part of the installer. Both Architect and GUI.

Where and how can I raise these bugs ?

I am thinking of using LVM command line tools to create my layout.

You did just did. Unfortunately I cannot guarantee any timeline on the fix. The lvm part of the installer is finicky. Sometimes it works and sometimes it doesn't.

I was thinking gparted, gnome-disks or whatever it is that kde uses. Arch wiki also has guide for doing it by hand from the command line. Calamares doesn't do any changes before you do the actual installation.

The best place to report bugs is the gitlab issue tracker

But this forum is okay too if you make sure that the maintainer sees the issue.

Then doesn't it make sense to just do it by hand. I am going to keep Manjaro for a long time on my laptop and I dont trust the installer.

I will do that then.

It does. Manjaro-architect was designed with step by step approach so you can do any steps manually instead if your needs are different.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by