"Can't detect file type" and "Filter failed" Errors on HP LaserJet Professional P1102 after Manjaro 19.0.2 update

Maybe you need to rebuild hplip-plugin from AUR ...

On it. Will let you know how it goes.

So I went to AUR using pamac. Found the hplip-plugin version 3.20.2-1. Went on to build it.

Here's how it went:

Cloning hplip-plugin build files...
Checking hplip-plugin dependencies...
Resolving dependencies...
Checking inter-conflicts...
Building hplip-plugin...
==> Making package: hplip-plugin 3.20.2-1 (Mon Mar 9 13:33:58 2020)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading hplip-3.20.2-plugin.run...
==> Validating source files with md5sums...
hplip-3.20.2-plugin.run ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
==> Starting prepare()...
==> Entering fakeroot environment...
==> Starting package()...
/var/tmp/pamac-build-james/hplip-plugin/PKGBUILD: baris 23: cd: /var/tmp/pamac-build-james/hplip-plugin/src/hplip-3.20.2-plugin: Tidak ada berkas atau direktori seperti itu
==> ERROR: A failure occurred in package().

The third last line says that Such file or directory doesn't exist.

So it ended up with an ERROR: A failure occurred in package().

What did I do wrong?

Another thing. I went to HP's Developer Portal to find more info on hplip here: Install Instructions

And found that the hplip up until it's latest 3.20.2 version only has support for Manjaro Linux (17.1.4,18.0,18.0.4,18.1.0,18.1.2)

I don't feel like to downgrade the Manjaro version just to able to use the printer. Is there any workaround to this incompatibility issue?

Should I just wait until they release newer hplip version with support for Manjaro 19.x.x?

I seem to have the same problem my HP printer no longer works since the 15 of march, running XFCE 19 so anyone else have more info ?

HPLIP-3.20.2 version was installed on 15-03-2020. this seems to be the problem


Another user and I noticed it after the 2020-03-14 Stable Update.

My symptom: Even for a small, text document the printer takes a long time, then prints a blank page, and eventually the printer status changes to paused.

1 Like

Could you try upgrading from Stable to Testing?
My testing laptop which would not print this morning, just did after today's testing update, containing an upgrade to hplip.

$ pacman -Qi hplip
Name            : hplip
Version         : 1:3.20.3-1
Description     : Drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet
Architecture    : x86_64
URL             : https://hplipopensource.com
Licenses        : GPL2  custom
Groups          : None
Provides        : None
Depends On      : python-dbus  python-distro  ghostscript  net-snmp  foomatic-db-engine  python-gobject
Optional Deps   : cups: for printing support [installed]
                  sane: for scanner support [installed]
                  xsane: sane scanner frontend
                  python-pillow: for commandline scanning support [installed]
                  python-reportlab: for pdf output in hp-scan [installed]
                  rpcbind: for network support [installed]
                  python-pyqt5: for running GUI and hp-toolbox [installed]
                  libusb: for advanced usb support [installed]
                  wget: for network support [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 27.17 MiB
Packager        : Andreas Radke <andyrtr@archlinux.org>
Build Date      : Tue 10 Mar 2020 03:21:44 PM EDT
Install Date    : Sun 15 Mar 2020 06:06:47 PM EDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
1 Like

Thanks for the info.
I'm still on stable on the affected machine, but I only updated hplip from 1:3.20.2-1 (currently on Manjaro stable branch) to 1:3.20.3-1 (taken from arch repos).
This fixes the problem, printing works again!

So @philm please update hplip on stable!


I don't feel like moving from stable to testing, as the computer with Manjaro is my production machine.

I've also followed both yours and @Bleuzen's suggestion to update hplip. So I went on using pamac and search it. Only found hplip-minimal 3.20.3-1 on AUR.

So, I tried installing it. Got a warning about hplip-minimal 3.20.3-1 conflicting with HP Device Manager (hplip) 1:3.20.2-1.

I then uninstalled hplip 1:3.20.2-1 and installed hplip-minimal 3.20.3-1.

Still not working.

What did I do wrong?

Same problem as you

No printer since latest updates broke something

Manjaro some news please ?

Update, Thanks to Bleuzen, It's now working again, No Hp Device manger for the moment as it installs the broken hplib but I can live without that

1 Like

Not sure what hplip-minimal is. But I have taken it from arch repos.
You can go to the arch packages site and download it there:

Or directly install it with pacman:

sudo pacman -U "http://mirror.ubrco.de/archlinux/extra/os/x86_64/hplip-1:3.20.3-1-x86_64.pkg.tar.zst"

Also remove the printer from your system in printer settings before, and re-add it after the update in hplip gui.

This fixed it for me and my printer.
However, if this still does not work:
Your initial post was 8 days ago, before the latest stable update, which broke printing for @mparillo and me. Since you had this problem before this update already (and if you were on stable all the time), you may have a different issue than us.


You are the man

Many thanks this worked just nicely :slight_smile:


1 Like

Thanks for taking the time to provide a solution.

I tried as per your instruction to remove the printer, install hplip with pacman, re-add the printer after the update.

Still not working. And with the same message on the printer monitor:


I then went to the hplip gui and run the hp-doctor. I got a warning and an error:


I guess you were right. My problem is apparently the distro was not found in AUTH_TYPES and the incompatibility of hplip 3.20.3-1 to Manjaro Linux 19.0.2.

Can you point me to the right direction on how to solve this issue?

Good for you man!

Well, today I executed the [Stable Update] 2020-03-14 and as reported here, hplip 1:3.20.2-1 has made me unable to print, so I upgraded it to 1:3.20.3-1 which has fixed the issue.

1 Like

Oh well, I also had this "Filter failed" error in the past with another hp printer. In this case, yes, this is a different issue.

You can ignore this. I guess HP is only slow on including new distros in supported list, but hplip works pretty well on newest Manjaro. In some rare cases with small exceptions, but it mostly works well, as on any 'supported' distro.

Maybe. I know something you can try. This is how I 'fixed' the filter failed error on my side:
(EDIT: Ignore the first point in the linked post, this is not valid anymore! Do use latest stable update, but also with the manual hplip update. Do NOT downgrade it to the version on current stable since it is broken.)

EDIT 2: I also found another post how someone else solved it. Try installing the cups-pdf package:

sudo pacman -S cups-pdf

(source: Printing not working [and] Can't install new printer either after yesterday's update)

1 Like

No need for complicated actions. One can easily install downgrade and switch to the last working (local) version. Or temporarily switch to testing and go with 3.20.3, then back to stable.
Partial updates ? - meh - it will come to stabe.

1 Like

Executing one command isn't a complicated action.

The pacman command I posted above will install a working version from arch in just one line. Pretty easy, isn't it?

This is possible, but more complicated and less likely to work.

  1. One has to have an older working version still in cache.
  2. One has to install downgrade first and use it, which are more steps than executing one pacman command.
  3. I also tried downgrading hplip first, but this didn't work. So seems older versions are not working anyway in the combination with the other new packages, so a downgrade may be useless anyway in this case. Only upgrade did it for me.

testing currently contains some other big updates, for example GNOME 3.36, systemd, ...
This is likely to create even more issues to most users.
For example in GNOMEs case, seems it broke some extensions again with the update, which is not acceptable for most of us on a production machine.
So switching to testing is not really a solution. It is only trading this issue for other issues currently.

For now manually updating hplip seems to be the best, easiest and most overall stable option for most users.

1 Like

Everthing is fine, both is possibe. Best would be to provide a working package for stable - hint to the team.

1 Like

Thanks again for your kind effort to share your fix. However, running the cupstestppd on my printer's ppd file multiple times all showed PASS results.

Then I tried your suggestion to install cups-pdf as per @Vir's solution.

Still got the "filter failed" and "can't detect file type" errors. So I went to read @Vir's suggestions more carefully.

I search for cups-filters and found that the one installed on my machine was cups-filters-driverless.

So I run:

sudo pacman -S cups-filters

Which installs cups-filters and removed cups-filters-driverless. While my printer is still plugged in to my machine.

Installing cups-pdf and cups-filters then removing cups-filters-driverless SOLVED my printing problem. I can now hear that sweet sound of the printer warming up and start printing with no issue. For now.

Thanks again @Bleuzen for your kind instruction and also shout out to @Vir for his solution.

Forum kindly sponsored by