Can't get dual-booting with Win10 to work - grup no finding image (SOLVED (by re-installing WIN 10))

So where can I start. I've been trying to install Manjaro since around 6 hours so far alongside Windows 10.

Windows was first in MBR/BIOS mode.
Manjaro was installed in UEFI mode so that obviously didn't work out.

I got to the point where only one of those two worked, either booting straight into WIN 10 or Manjaro.

Then I went ahead and converted Win 10 MBR to GPT with gptgen.

After I did this, the Asus BIOS didn't even find the Kingston SSD first. I also can't boot into Windows anymore.

So I installed Manjaro in UEFI-mode from beginning and after updating grup, it boots into Manjaro and I can see again the SSD in BIOS.

But it still doesn't find the Windows boot to attach to grup when running sudo grup-update:
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

What is odd now is how the partitions are named after converting to GPT - check gparted:

Here are some commands I have run for troubleshooting:

I can still access the windows partition from Manjaro without problems where my files are.

Is there a way I can manually tell the system to look at sda1 for the Windows boot file?

Thanks!

and as you experience, something was borked..
I wasn't aware you can revert MBR Win to GPT Win on an installed system.

This means you installed the two in different modes (UEFI - MSDOS).
To have Manjaro see/control Win booting, WinOS has to be in the same mode.
You should have installed Manjaro in Legacy/MSDOS mode.
Now you have to make some hard decisions.

  • Re-install WinOS in UEFI mode and repair Manjaro Grub (after WinOS installation, it is expected to break Manjaro booting 1st,or at all)
  • Revert WinOS to MBR (if it is really possible) and re-install Manjaro in Legacy MSDOS mode (not UEFI)
  • Other option..?

Forum search.

There are many similar threads to yours, dual boot Manjaro and W10.

I just went ahead and reinstalled Windows, was getting slow lately anyway.

Update-grub did pick it up now and works flawless.

On to the next problem :sweat_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by