Can't get graphical user interface(sddm)

I am having an issue with manjaro kde after I updated it.
Now I am stuck at black screen with text
"Failed to start Simple Desktop Display manager"

I am able to get a shell after pressing Ctrl + Alt + F2 and able to login in it.

This is my .xinitrc file https://pastebin.com/AQkvZ5VZ

I do not have any xorg.conf file under /etc/X11/

Checking sddm service status doesn't give anything specific but one line
"/usr/bin/sddm : symbol lookup error: /usr/lib/libQt5Core.so.5: undefined symbol: _ZNSt3pmr25monotonic_buffer_resourceD1Ev, verson GLIBCXX_3.4.28"

if I run startx it also fails

but When I check it one line that fails returns
"xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)

I tried to run sudo startx still same error.

but when I run xinit it returns an error with EE tag
"parse_vt_settings: Cannot open /dev/tty0 (permision denied)"

Please help me I need my laptop working.

Hello :slightly_smiling_face:!
There seems to be some communication issue between SDDM (The login manager) and QT5 (The GUI Toolkit Engine the Login Manager uses).
I would first of all suggest to force-reinstall both sddm and QT5.
Run the following command:

sudo pacman -Syu sddm qt5-base

Additionally, could you post the output of

ls -l /usr/lib/libQt5Core.so.5

and

sudo pacman -Ss qt5-base

?

You can also use

echo $(ls -l /usr/lib/libQt5Core.so.5) > output-ls.txt

and

echo $(sudo pacman -Ss qt5-base) > output-pacman.txt

To save the command outputs to text files in your home directory where you can later pick them up with e.g. a live USB to upload them to the forum.

If force reinstalling does not help, please reply and send us the command outputs.

1 Like

Sorry Cant try it now
I had to install another OS as I needed by laptop working :wink:

By the way thank you so much for your reply
:smile: :wink:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by