Cant get into BIOS after install manjaro (Black screen)

Hi, i have a weird problem. So after install manjaro i can't get into BIOS. I use laptop, my laptop is Acer Swift 3 54G, BIOS version is 1.14.

First, I install manjaro by manual partitioning, i have 1 SSD and 1 HDD. I already have Windows 10 Installed in my SSD. So i shrink my Windows partition and create 2 new partition. 512 MB fat32 mount /boot/efi and ext4 mount / . After that i try to get into BIOS but it's only show black screen. Next, i delete 2 new partition i created before from live usb and then i can get into BIOS normally. So i thought that i did something wrong so i repeat the installation process twice but still same result.

After i delete 2 new partition again i can get into BIOS. Then i tried install manjaro with "Install Alongside" option when partitioning, and it created 1 new partition for / and mount /boot/efi to existing EFI Partition. When i try get into BIOS it's work for the 1st and 2nd time reboot and then it's black screen again.

I tried :

  1. Pressing F2
  2. Boot to currently installed manjaro and live cd too and then type "systemctl reboot --firmware-setup" in terminal.
  3. Boot to Windows 10 and go to UEFI Firmware Setting

All result is same, just black screen, it should be the time when i type my BIOS suvervisor password.

also there's 2 Windows Boot Manager in Boot Option (when i press F12, yes Boot Menu is working but not BIOS)

TL;DR Doing Dual Boot, can boot into both OS but cant get into BIOS (black screen) the time i should type my BIOS supervisor password.

can you boot on USB iso manjaro live
open a terminal and browser on this topic

inxi -Fxxxza
sudo parted -l
1 Like

inxi

System:
  Host: manjaro Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=UTC driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=0 
  misobasedir=manjaro misolabel=MANJARO_KDE_200 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor 
  Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Acer product: Swift SF314-54G v: V1.14 
  serial: <filter> 
  Mobo: KBL model: Strongbow_KL v: V1.14 serial: <filter> UEFI: Insyde 
  v: 1.14 date: 03/15/2019 
Battery:
  ID-1: BAT0 charge: 49.4 Wh condition: 49.4/50.8 Wh (97%) 
  volts: 17.1/15.3 model: SMP-SDI3320 AC14B7K type: Li-ion 
  serial: <filter> status: Not charging 
CPU:
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: CA L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 900 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 901 4: 900 5: 900 6: 900 7: 900 8: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI 
  driver: nvidia v: 440.82 bus ID: 01:00.0 chip ID: 10de:1d10 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  alternate: fbdev,intel,nouveau,nv,vesa compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) 
  v: 4.6 Mesa 20.0.5 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.6.7-1-MANJARO 
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000 
  bus ID: 02:00.0 chip ID: 8086:095a 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.40 TiB used: 690.7 MiB (0.0%) 
  ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 42AZS6AC scheme: GPT 
  ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 1J scheme: GPT 
  ID-3: /dev/sdb type: USB vendor: SanDisk model: Ultra size: 28.64 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00 
  scheme: MBR 
Partition:
  ID-1: / raw size: N/A size: 8.69 GiB used: 690.7 MiB (7.8%) fs: overlay 
  source: ERR-102 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: 46.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 245 Uptime: 2m Memory: 11.59 GiB used: 1.18 GiB (10.2%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  running in: konsole inxi: 3.0.37 

parted :

Model: ATA TOSHIBA MQ04ABF1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size   File system  Name                  Flags
 1      1049kB  355GB   355GB  ntfs         Basic data partition  msftdata
 2      355GB   1000GB  645GB  ntfs         Basic data partition  msftdata


Model: SanDisk Ultra (scsi)
Disk /dev/sdb: 30.8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3101MB  3105MB  4194kB  primary               esp


Model: ADATA SX8200PNP (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  556MB  555MB   ntfs         Basic data partition          hidden, diag
 2      556MB   661MB  105MB   fat32        EFI system partition          boot, esp
 3      661MB   677MB  16.8MB               Microsoft reserved partition  msftres
 4      677MB   375GB  374GB   ntfs         Basic data partition          msftdata
 5      375GB   512GB  137GB   ext4


all is ok , boot & esp are good
can you check then

sudo efibootmgr -v 
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0003,0001,2001,2002,2003
Boot0001* Windows Boot Manager
Boot0002* Manjaro
Boot0003* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

That was not from live USB btw, shoud i did it from Live USB ?

it's ok

so grub is on nvme .
you have grub only on boot or only USB iso ?

Sorry i dont quite understand, could you elaborate more?

I think this is the problem OP is trying to solve.
:thinking:

Yea, that one. Also with my double Windows Boot Manager too but that's not too critical.

The following will not be a solution in the long run but just a check if you can get into bios' settings. From Manjaro run: sudo systemctl reboot --firmware-setup

I can't, same result with Pressing F2 and Go to recovery - UEFI Firmware Setting in Windows 10, just black screen.

Someone said this

most likely, you can't get into bios because of preliminary health check or whatever they call it. Somehow,it stucks at disk scanning. That can be because of NTFS locks but I can't say for sure

also i did this guide, is there any effect to my problem?

This is not the first time this is a topic and you are not the first.

1 Like

Thanks
Solved using this one (from reddit)

Quick update: I seem to have found a workaround for it. Here's how:

0) After installing Arch along with installing and configuring GRUB, I restarted the machine and let it boot into the new Arch install.

    I deleted GRUB's boot entry from the UEFI boot menu using efibootmgr, then restarted the second time.

    At this point I could enter my laptop's firmware settings. I enabled Secure Boot, then selected the file grubx64.efi in the EFI partition as "trusted for executing".

    Reboot the machine, then voilĂ .
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by