Can't get Manjaro to install

I downloaded the Cinnamon Manjaro and Gnome Manjaro versions.

I couldn't get Cinnamon to even start, getting some sort of error message.

I had more luck with the Gnome version...I got that to start on my Windows 10, 64 bit version, but right at the end I got the error message "Installation failed. Boost.Python error in 'bootloader'".

I'd like to install the Cinnamon version. If I can't do that directly, can I do it via the Gnome version?

How do I get either version to finish installing?

Do I need to know any commands or passwords during installation or as soon as it's loaded?

Should I partition the drive in any particular way? My PC has two drives. I'm trying to install the distro on the empty, unused drive.


If your installation completes except with above error, try to boot into the installed OS using this.
After booting into Manjaro,

sudo pacman-mirrors -g
sudo pacman -Syyu
sudo pacman -S grub
sudo pacman grub-install /dev/sda
sudo update-grub

There are many reasons why you get this error.
You may install in uefi without mounting a /boot/efi
You may install in bios-legacy with a /boot/efi mount

If you need further help, please let us know partitioning and boot, like gpt or msdos and uefi or bios-legacy.
When you boot up livecd at grub menu (the boot menu), at grub prompt,
grub> echo $grub_platform
This will show if you booted up the livecd in uefi or bios-legacy.
To get back to menu, press 'esc'

Before installing, be sure if your system is uefi/gpt or bios-legacy/msdos
Then boot up install media in the right mode (uefi or bios-legacy) and make the corresponding mount points.

1 Like

Did you ensure your downloaded ISOs are good?
Did you write them to CD/DVD or USB?
If USB and Rufus, did you use 'DD' mode? (It is the only mode that works)
What is your computer hardware? Video card?


1 Like

Just realised that you may not boot in using configfile in the link as you may not have a grub.cfg generated due to the errors you mentioned. Sorry.

In that case after booting to the grub prompt (from boot menu) of the live media,
Do this instead to boot up

grub> search -f /boot/intel-ucode.img --set=root
grub> ls ($root)/boot/

Write down the kernel and initramfs, say vmlinuz-4.9-x86_64 and initramfs-4.9-86_64.img

grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.9-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.9-x86_64.img
grub> boot

Then continue from my previous post when booted up in Manjaro.

[I'll just note that I'm trying to install Manjaro via a USB stick...I don't think that I have a spare CD or DVD on that seems to knock out a lot of the advice in the replies to me.]

Okay, I'm trying to troubleshoot here, but I'm not very good at it. My unused drive is no longer visible on my Windows 10 screen but when I try booting into the other options, nothing happens...I get a normal Windows login screen if I choose "Windows Boot Manager" or "UEFI OS". When I choose "SATAO P1", I get a flashing, white space-bar type symbol in the top left hand corner of my screen, with the screen being black. I can't type anything into that. If I choose "SATAO P2" or "SATAO 0", the flashing white symbol moves down a few lines and I can't type anything into the black screen.

When I put in the USB 3 stick which had the file, I think, I got the message "Cannot find grldr" and "An operating system wasn't found", for the boot option of "USB Disk 3.0 PMAP". When I chose the other options, like "UEFI: USB Disk 3.0 PMAP, Partition 1", I was taken to the normal Windows 10 login screen and the next time that I accessed the boot options menu that entry had been repeated in the list. Also got a Windows login screen when I chose "UEFI: USB Disk 3.0 PMAP Partition 2", with the Partition 1 entry being added to, again.

Before that, I did try to delete the contents of my USB 3 stick to try again from scratch, which I don't think worked...and I later noticed that my unused drive had disappeared off the Windows screen (under "This PC"). Not sure if that is due to attempting to install Manjaro on it, unsuccessfully, or as the result of an operation using Easy2Boot...which I abandoned because it was too complex...but not sure if that messed with my second drive and Windows recognising it.

I made another copy (?) of the Manjaro Gnome file onto the same USB stick using the Universal USB Installer app but that gave me the message "Manjaro Gnome is not supperted". I did dowload Rufus as well as Etcher, with the latter seeming quite easy to use, but, really, I have no idea what I'm doing.

Am I meant to put anything else on the USB stick apart from the Manjaro files? What?

Under "This PC" now, with my USB stick inserted, I have these new drives now: "UUI (D:)" with 6.01 GB free of 7.33 GB and "PTNT2 (F:)", with 10 KB free of 11.5 KB.

Am I better off using another USB stick now? What should I put on it? Maybe I shouldn't use the Universal USB Installer app because it doesn't recognise Manjaro Gnome? Or Cinnamon?

gohlip - I can't get the Manjaro installation screen at the moment, but I'll try again, now that I put the Manjaro file onto the USB stick.

I'll bumble about trying a few things, but hopefully the info that I put here now can be useful and I'll check in again later.

Correct, we are all talking about the usb stick as live media.

I think you've made the usb install stick wrong. See c00ter post above. Use rufus, 'dd'.
We don't 'put' any file into usb stick. We 'burn' it or 'dd' it.

Next, as to your windows.... I think it is in uefi and gpt disk. Google and see if that is the case. If so, you need to boot up the usb stick in uefi mode. If not so, then you have to boot up usb stick in bios mode.

Suggest you read more of the wiki here and let us know if you need more clarification.

1 Like

I'm a bit short on time at the moment but I've made progress. I used Rufus and c00ter10h's
advice to use ‘DD’ mode worked, so, thanks for that.

The Gnome version of Manjaro has been installed to my unused drive, I believe. However, I can't get it to load though. When I boot into Manjaro, I get the following message:

"Welcome to GRUB! Attempting to decrypt master key. Enter passphrase".

I'm not sure what that passphrase is.

Like I said before, I did want to install the Cinnamon version of Manjaro. Can I do that via the Gnome version?

What are the differences between Cinnamon and Gnome? Some years back I was toying around with Mint, and I liked how it allowed you to download apps from a store, from memory. That appeals to me.

Anyway, short on time, so sorry if I'm asking these questions without troubleshooting or looking up answers myself.

You've installed setting up a password for grub.
Unfortunately, I think most here do not use passphrase and those who don't use it cannot help except you have to guess what you input for your grub passphrase. i think you will need to input twice for passphrase.

If you really forget, I guess you have to install again.

I don't remember setting up a password for grub...when I installed Manjaro, it asked me if I wanted to use encryption, which I chose, plus different passwords for my account and administrator account.

If it's not one of those, then I don't see where I set up the password or what that password is. Which makes me wonder, I install again, how do I stop that from repeating it?

I didn't know about inputting a password twice...I'll try again and if that doesn't work, I'll log back in here tomorrow, maybe...I just thought I'd install Linux for a I'm just dabbling in this, every now and again...not as easy as I'd hoped it would be.

P.S. when I go into the boot sequence menu, there are options for:

USB Disk 3.0 PMAP

Might have tried both with the same result...stuck at the grub password section.

I'm now going to try and install the Cinnamon version using Rufus. Did get a message from Rufus saying "256 bad block(s) found...256 write error(s)".

Not sure if that is a problem. Fortunately, Rufus downloaded some stuff that it needed to attempt to create the Cinnamon installation.

P.S. I've tried installing Cinnamon, the boot sequence loader has two options:

USB Disk 3.0 PMAP and
UEFI: USB Disk 3.0 PMAP, Partition 1

I think I got slightly further with the second option, but I'm not getting to the point where I can install it. I get the flashing white symbol in the top left corner of the screen on a black screen and I can't input any text there. Another fail.

Might try KDE version to install...but this is getting ridiculous.

the first is for boot install key USB on bios ,
the second to boot install key USB for EFI

you will have to do install without encryption ,
so give return of

sudo fdisk -l

It's made much more difficult when you install a Community Edition and then enable options during installation that you don't know the effects of (i.e. encryption).

Install an official edition (one of Xfce, KDE, GNOME) with the most basic options available (e.g. without encryption) to check the process works. Once you have a process that works, you can then tweak away until something breaks.

If it doesn't work with basic options it's much easier to troubleshoot.

Write errors are always an problem if you're trying to write something. This suggests something else is wrong - for example, a broken USB disk or port, or an incomplete or corrupted installer image download.

I remember I was quite confused when I first installed Linux, too.
What helped quite a bit was to carefully read the Manjaro User Guide.

Even after reading and getting some experience you don't have the guarantee that the installation will work. Sometimes there is no other way than trying a different distribution. But it is also a learning experience to see how different distros work.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by