Can't get my Acer swift 5 touchscreen to work

My Acer Swift-5 touchscreen, which used to work on W10, isn't working at all on Manjaro. Here's my inxi -Fx :

System:    Host: laptop Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: KDE Plasma 5.19.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Swift SF514-54T v: V1.07 serial: <root required> 
           Mobo: IL model: Yebisu_IL v: V1.07 serial: <root required> UEFI: Insyde v: 1.07 date: 09/05/2019 
Battery:   ID-1: BAT0 charge: 49.4 Wh condition: 54.8/56.0 Wh (98%) model: SMP KT00407008 AP18C7M 
           status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake rev: 5 
           L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23968 
           Speed: 1229 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 1333 2: 1336 3: 1275 4: 1299 5: 1393 
           6: 1273 7: 1257 8: 1347 
Graphics:  Device-1: Intel Iris Plus Graphics G7 vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel Smart Sound Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:   Device-1: Intel Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter driver: iwlwifi v: kernel 
           port: 3000 bus ID: 00:14.3 
           IF: wlp0s20f3 state: up mac: 08:71:90:4b:dd:ea 
Drives:    Local Storage: total: 476.94 GiB used: 13.91 GiB (2.9%) 
           ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3512GJ1 size: 476.94 GiB 
Partition: ID-1: / size: 468.16 GiB used: 13.91 GiB (3.0%) fs: ext4 dev: /dev/dm-0 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 250 Uptime: 3m Memory: 7.46 GiB used: 1.34 GiB (17.9%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.18 inxi: 3.0.37

Thanks in advance for your help!

Do you have libinput installed?

I do have it installed and everything's up-to-date.

Nobody knows how to make it work? Following what ArchWiki says about Acer Swift 5, touchscreen should work tho...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by