Can't get to display grub to access Windows

Hello everyone, after using Arch for a bit on my laptop, I installed manjaro on my desktop, as I wanted a ready to go experience.

My problem is that I cannot get grub to display when the pc starts up, and I cannot use Windows 10.
Windows is located in nvme0n1 (sabrent rocket 1tb), when installing Manjaro, i chose to install it in nvme1n1 (samsung 950pro 256gb).
I chose to wipe completely the samsung disk, and it installed a fat32 partition in /dev/nvme1n1p1: reading online, I expected it to install grub there, but it did not.

Now, question is, how do I install grub and add Windows to its boot menu? I tried following the solution posted here but the command displays this error
update-grub Generating grub configuration file ... Found theme: /usr/share/grub/themes/manjaro/theme.txt Found linux image: /boot/vmlinuz-5.4-x86_64 Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img Found memtest86+ image: /boot/memtest86+/memtest.bin /usr/bin/grub-probe: avviso: tipo di device nvme1n1 sconosciuto. done

"Avviso: tipo di device nvme1n1 sconosciuto." means "Warning: unknown device type nvme1n1. done"

This post should see you fixed up, just start from the top and follow the directions applicable to your setup.

Seeing as it looks like update grub worked, following the two uefi commands should add manjaro to your boot list. Anyone else able to chime in about the error on the end?
Edit, reading the linked post, it looks like its to do with memtest, which shouldn't affect your ability to boot into grub.

2 Likes

Hi, thanks for the answer, the post you linked did not solve the problem. Grub still does not show up at all when starting up the pc
edit:
Will boot-repoair-disk help in this?

Have you checked in your bios that manjaro is at the top of your boot priority?

You're running an EFI system and that has only one EFI partition regardless of the number of disks you have and grub should go there.

It looks like you forced grub to go to the boot sector of disk2 (nvme1n1), which is not how EFI works: there is no boot sector, just a boot partition, so re-install and mount your existing EFI partition on the first disk (which contains Windows and where grub goes and where it will find Windows) and don't force booting of the second disk...

If you give us a parted --list we can give you the exact mount points to use for everything.

--parted list does not return anything, strangely enough
So you say I should re install manjaro, and while installing select my windows ssd to have a efi partition?
I will try that now

In addition to the command asked by @Fabby the output from the following ones might shed some more light on your issue as well:

efibootmgr -v
sudo blkid
findmnt -s
findmnt /boot/efi
1 Like

parted --list

You typed it wrong...

type:

sudo parted --list

instead of:

--parted list

(per favore) :innocent:

1 Like

yeah, sorry, i actually wrote the right command, but did not think of using sudo :sweat_smile:

and the @Marte commands will help us too.

[nicola@nicola-pc ~]$ sudo parted --list
[sudo] password di nicola: 
Modello: ATA ST3750528AS (scsi)
Disco /dev/sda: 750GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine   Dimensione  File system  Nome                  Flag
 1      1049kB  750GB  750GB       ntfs         Basic data partition  msftdata


Modello: ATA ST2000DM006-2DM1 (scsi)
Disco /dev/sdb: 2000GB
Dimensione del settore (logica/fisica): 512B/4096B
Tabella delle partizioni: msdos
Flag del disco: 

Numero  Inizio  Fine    Dimensione  Tipo     File system  Flag
 1      1049kB  2000GB  2000GB      primary  ntfs


Modello: ATA Samsung SSD 840 (scsi)
Disco /dev/sdc: 120GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco: 

Numero  Inizio  Fine   Dimensione  Tipo     File system  Flag
 1      1049kB  120GB  120GB       primary  ntfs


Modello: Sabrent (nvme)
Disco /dev/nvme0n1: 1024GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system  Nome                          Flag
 1      1049kB  17,8MB  16,8MB                   Microsoft reserved partition  msftres
 2      17,8MB  1024GB  1024GB      ntfs         Basic data partition          msftdata


Modello: Samsung SSD 950 PRO 256GB (nvme)
Disco /dev/nvme1n1: 256GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine   Dimensione  File system     Nome  Flag
 1      2097kB  317MB  315MB       fat32                 avvio, esp
 2      317MB   247GB  246GB       ext4
 3      247GB   256GB  9449MB      linux-swap(v1)        swap



Here is the output of the command haha, thanks

Holy moly! It looks like you're still running in BIOS compatible mode! Are you running Windows 7??? If yes, ignore everything I said and tell us which is your boot device in the BIOS.

Also: if you're running in BIOS mode: you should not use gpt but msdos (with all the disadvantages that has)

Modello: Sabrent (nvme)
Disco /dev/nvme0n1: 1024GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system  Nome                          Flag
 1      1049kB  17,8MB  16,8MB                   Microsoft reserved partition  msftres
 2      17,8MB  1024GB  1024GB      ntfs         Basic data partition

Windows seems to be installed in legacy mode. That is why os-prober will not pick it up. The least "painful" option would be to back up your data from your Manjaro install and re-install Manjaro in legacy mode as well.

Or, choose from bios boot menu which OS to boot up.

1 Like
[nicola@nicola-pc ~]$ efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0003,0001,0002,0004,0000
Boot0000* ubuntu        VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0001* Windows Boot Manager  HD(1,GPT,d2240e1b-c6b3-45bc-bf6b-18132a61a0f7,0x1000,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...o................
Boot0002* Hard Drive    BBS(HD,,0x0)..GO..NO........u.S.a.m.s.u.n.g. .S.S.D. .8.4.0. .E.V.O. .1.2.0.G.B....................A.................................>..Gd-.;.A..MQ..L.1.S.5.D.S.N.F.B.1.2.5.0.8.1. .K. . . . ........BO..NO........a.S.a.b.r.e.n.t....................A..........................dy.*.C30.....$..Gd-.;.A..MQ..L.S.a.b.r.e.n.t........BO..NO........o.S.T.3.7.5.0.5.2.8.A.S....................A...........................>..Gd-.;.A..MQ..L.V.5.2.P.7.R.3.H. . . . . . . . . . . . ........BO..NO........u.S.T.2.0.0.0.D.M.0.0.6.-.2.D.M.1.6.4....................A.................................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .4.Z.7.Z.7.W.1.N........BO
Boot0003* manjaro       HD(1,GPT,d2240e1b-c6b3-45bc-bf6b-18132a61a0f7,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0004* UEFI OS       HD(1,GPT,d2240e1b-c6b3-45bc-bf6b-18132a61a0f7,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)..BO

[nicola@nicola-pc ~]$ sudo blkid
/dev/nvme1n1p1: UUID="8AC4-CBE4" TYPE="vfat" PARTUUID="d2240e1b-c6b3-45bc-bf6b-18132a61a0f7"
/dev/nvme1n1p2: UUID="2ebcf950-b9b3-4b42-9d47-f06feb778b0d" TYPE="ext4" PARTUUID="34328bf1-2c3a-4850-a93f-6c6ab5564b25"
/dev/nvme1n1p3: UUID="b302aee1-60a4-4445-a3b7-2f1e0daaf019" TYPE="swap" PARTUUID="2b331521-8982-4d4e-8b68-faf9a3562ab1"
/dev/nvme0n1p1: PARTLABEL="Microsoft reserved partition" PARTUUID="bbe1d965-4867-4440-ad42-c4bdae530a1e"
/dev/nvme0n1p2: UUID="2E349DF6349DC0EF" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="9b6c2f7f-0b56-4575-9156-104c880d45e1"
/dev/sda1: LABEL="Volume" UUID="C01AD4851AD479BC" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="11a5a844-0f52-47e0-8ed4-467101528c36"
/dev/sdb1: UUID="B628709E28705EF5" TYPE="ntfs" PARTUUID="b3b406a4-01"
/dev/sdc1: LABEL="Volume" UUID="CEA6ED54A6ED3E19" TYPE="ntfs" PARTUUID="b2c96e0b-01"

[nicola@nicola-pc ~]$ findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=8AC4-CBE4                            vfat   umask=0077
/         UUID=2ebcf950-b9b3-4b42-9d47-f06feb778b0d ext4   defaults,noatime
swap      UUID=b302aee1-60a4-4445-a3b7-2f1e0daaf019 swap   defaults,noatime

[nicola@nicola-pc ~]$ findmnt /boot/efi
TARGET    SOURCE         FSTYPE OPTIONS
/boot/efi /dev/nvme1n1p1 vfat   rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

Here are the outputs of the commands

Mhh, i have windows 10 installed, in my motherboard system setup the "Operating System" options is set to Windows 10 and other options says UEFI

You're running a mixed-mode BIOS/EFI system: grub will not be able to pick up Windows. I agree with @marte and you should use the BIOS to pick which OS to run...

As I'm migrating away from Ubuntu I have a triple boot system too, but I'm running W10, Ubuntu and Manjaro all in EFI mode:

$ sudo parted --list
[sudo] password for fab-root: 
Model: ATA Micron_1100_MTFD (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  106MB   105MB   fat32           EFI system partition          boot, esp
 2      106MB   123MB   16.8MB                  Microsoft reserved partition  msftres
 3      123MB   51.7GB  51.5GB  ntfs            Basic data partition          msftdata
 4      51.7GB  52.7GB  1074MB  ntfs            Basic data partition          hidden, diag
 5      52.7GB  104GB   51.5GB  ext4
 6      104GB   212GB   107GB   ext4
 7      235GB   256GB   21.5GB  linux-swap(v1)                                swap


Model: ATA Micron_1100_MTFD (scsi)
Disk /dev/sdb: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 2      106MB   51.1GB  50.9GB  ext4
 3      51.1GB  219GB   168GB   ext4


Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sdd: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  1000GB  1000GB  ntfs               msftdata
1 Like

I think I will re-install windows, it was about time...

 efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0003,0001,0002,0004,0000
Boot0000* ubuntu        VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0001* Windows Boot Manager  HD(1,GPT,d2240e1b-c6b3-45bc-bf6b-18132a61a0f7,0x1000,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...o................
Boot0002* Hard Drive    BBS(HD,,0x0)..GO..NO........u.S.a.m.s.u.n.g. .S.S.D. .8.4.0. .E.V.O. .1.2.0.G.B....................A.................................>..Gd-.;.A..MQ..L.1.S.5.D.S.N.F.B.1.2.5.0.8.1. .K. . . . ........BO..NO........a.S.a.b.r.e.n.t....................A..........................dy.*.C30.....$..Gd-.;.A..MQ..L.S.a.b.r.e.n.t........BO..NO........o.S.T.3.7.5.0.5.2.8.A.S....................A...........................>..Gd-.;.A..MQ..L.V.5.2.P.7.R.3.H. . . . . . . . . . . . ........BO..NO........u.S.T.2.0.0.0.D.M.0.0.6.-.2.D.M.1.6.4....................A.................................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .4.Z.7.Z.7.W.1.N........BO
Boot0003* manjaro       HD(1,GPT,d2240e1b-c6b3-45bc-bf6b-18132a61a0f7,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)

I'm puzzled. Where does this:

Boot0001* Windows Boot Manager HD(1,GPT,d2240e1b-c6b3-45bc-bf6b-18132a61a0f7,0x1000,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.

come from?

That's still in the NVRAM and is ignored as that partition probably does not exist any more... (Haven't double-checked the UUID)

The best @gallu can do is indeed re-install W10 in EFI mode on a GPT disk but then he'll need to do a boot-repair for his Ubuntu and Manjaro as Windows will erase all other boot managers from the NVRAM.

1 Like

Forum kindly sponsored by