Can't install Manjaro

Hi I used to use Linux Mint but after researching other distros I wanted to use Manjaro.

So I used Rufus to burn the iso for 18.04 xfce to my usb and did a live boot, similar to how i installed linux mint. So everything goes great until the install where im stuck at 93% "misc postinstall configurations". I chose to clean the drive and do a full install on my 1tb partition so i dont think space is an issue.

I have tried to read other posts with the same issue but could not find a solution or they would solve it on their own without much help for me. many people in those posts said to try "sudo -e calmares -d" which i have tried but it just says
"sudo: calmares: editing files in a writable directory is not permitted
sudo: -d: editing files in a writable directory is not permitted".

One person who made a post around a year ago said they were able to fix it by editing their resolve.conf in etc but I have no clue what to put there for my DNS and I tried adding a server I found from the nmcli tool but it just told me I dont have permissions.

Can anyone help me sorry im new to linux and using my laptop right now in case the install stops hanging?

1 Like

When you create Manjaro USB install and use Rufus, it needs to be in DD mode. You can also use Etcher with no other options and trouble.

Hi, yes I made sure to select DD mode like the user guide said

Any chance to provide inxi -Fxxxz from terminal, did you used free or nonfree drivers boot option, did you check the iso?

It's 5:00pm right now where I live in the US. This morning when I started trying to install manjaro I used etcher first and had the same issue, after an hour or two I thought maybe it was my usb so i used rufus instead (DD). it's still stuck at 93 though

I used free the first attempt, this attempt im using nonfree. i verified the checksum yes. I can use the inxi command but for some reason can't connect to the internet to copy the logs since firefox just infinitely loads on the live usb

also sorry forgot to add i am connect via ethernet

Okay I was messing with the connections and disconnected the wired connection. it finished the install as soon as I did that. I rebooted into the os on my hard disk but I can't use the internet still. I tried disconnecting and reconnecting the "wired connection 1" but it just infinitely fails to connect. I haven't had this issue with the other OS's so I really have no clue what to do

When you ask for help you should lead with the actual issue you're having, e.g. "The installation process stalls at 93%". This helps people identify the issue.

Something about the network card isn't working correctly. This is why it hung at 93% - as you probably worked out by disconnecting the network.

Have a read of this thread to find out some commands which are useful for finding out what's happening:

Given this is a networking issue you can check the logs by running

sudo journalctl -eu NetworkManager

in a terminal and then trying to connect to the network.

You'll also have to post your hardware so people know what you have, otherwise it's impossible to diagnose the issue as every piece of hardware is different.

Alternatively, if

you might consider moving back to a "working" Linux distro so you can gain confidence. Manjaro is a great distro for learning more about Linux, but others are better if you want a no-touch consumer OS.

1 Like

I was able to fix it by following this post here: No internet connection via ethernet Also, thank you for your advice, any advice is appreciated and in the future I will be sure to format better and include my hardware. I deleted the blacklist file in modprobe.d and on reboot the internet works fine. Thanks again for the help guys. I'm very grateful for the quick responses and advice.


Excellent, well found. :slight_smile:

With the inxi command you can identify the network card model and search in the forum (from another device) how to get it working. This is an example:
Network: Device-1: Realtek RTL8111/8168/8411 PCI

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by