Can't install Snap Packages

Hello Forum,

with the latest stable update snap packages are supported and I wanted to try it out. But I can't get it working.

Example Package Brave Browser:
when typing sudo snap install brave
I get the output

error: cannot communicate with server: Post http://localhost/v2/snaps/brave: dial unix /run/snapd.socket: connect: no such file or directory

same with snap find
what am I missing?

Also, it was said, that there is a plug-in available for Gnome Software (I'm running Gnome), but I can't get it working there either. I found the "Log in to Ubuntu One" .. but couldn't get passed it.

I appreciate your assistance.

1 Like

Is snapd installed if yes then is snapd running?

1 Like

It is installed, but I just noticed that it is apparently not running.

$ systemctl status snapd

● snapd.service - Snappy daemon
   Loaded: loaded (/usr/lib/systemd/system/snapd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

How do I get it going?

systemctl enable --now snapd.apparmor.service
systemctl enable --now snapd.socket

2 Likes

Is it working now... if not then restart your system

systemctl start snapd.apparmor.service

did the trick. Thank you!

run systemctl enable --now snapd.socket also... it will enable snapd at boot

after today's update snapd is disabled for some reason

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by