Can't login from lock screen- gnome 3.30

Hello there.
I am on stable branch of manjaro, using gnome.
Since a couple of days, I have the problem on my notebook that I can't log back in from the lock screen-
but it's not a complete freeze- mouse works, panel works, I just cannot log in.
Its like in:

but I dont won't to have my screen "forever" on on my laptop, so disabling energy saving options is not really an option

I also found


(not sure if external links are allowed here, if not pls remove.)
and disabled the lock screen notifications- didn't help my problem.

Gratefully looking for help.

Can you please provide the output of inxi -FzzzI have this same problem but it is a desktop with Nvidia graphics.

Blockquote

System:
Host: andi-elitebook Kernel: 4.4.162-1-MANJARO x86_64 bits: 64
Desktop: Gnome 3.30.1 Distro: Manjaro Linux
Machine:
Type: Laptop System: Hewlett-Packard product: HP EliteBook 8470p
v: A1029D1102 serial:
Mobo: Hewlett-Packard model: 179B v: KBC Version 42.32 serial:
BIOS: Hewlett-Packard v: 68ICF Ver. F.31 date: 09/24/2012
Battery:
ID-1: BAT0 charge: 57.4 Wh condition: 65.9/65.9 Wh (100%)
CPU:
Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP
L2 cache: 3072 KiB
Speed: 3181 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 3181 2: 3260
3: 2948 4: 3195
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
Display: x11 server: X.Org 1.20.2 driver: i915 resolution: 1600x900~60Hz
OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.3
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k4.4.162-1-MANJARO
Network:
Device-1: Intel 82579LM Gigabit Network driver: e1000e
IF: enp0s25 state: down mac:
Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
IF: wlo1 state: up mac:
Drives:
Local Storage: total: 357.72 GiB used: 200.05 GiB (55.9%)
ID-1: /dev/sda vendor: SanDisk model: SDSSDP064G size: 59.63 GiB
ID-2: /dev/sdb vendor: Seagate model: ST320LT007-9ZV142 size: 298.09 GiB
Partition:
ID-1: / size: 52.45 GiB used: 44.72 GiB (85.3%) fs: ext4 dev: /dev/sda2
ID-2: /boot size: 247.0 MiB used: 148.5 MiB (60.1%) fs: ext2
dev: /dev/sda1
ID-3: swap-1 size: 5.96 GiB used: 20.5 MiB (0.3%) fs: swap dev: /dev/sda5
Sensors:
System Temperatures: cpu: 52.0 C mobo: 0.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 251 Uptime: 1h 01m Memory: 7.67 GiB used: 2.21 GiB (28.8%)
Shell: bash inxi: 3.0.26

Blockquote

Its an integrated Intel graphic chip, i believe its a intel hd 4000

Oh my, can you update your kernel?
I guess the rest of the system is up to date since you have the latest Gnome.
How or why do you keep your kernel from updating???
I know not much help but you never know.

That is the latest 4.4 series kernel. It is an LTS version.

The only way the kernel gets updated to a later kernel is manually.

Do you think an update to the kernel would help my problem?

I don't know but it is easy enough to try. You can install a newer kernel. You don't have to remove your old kernel so if anything goes wrong you can always just boot the old oen up.

Just tried with 4.14 (LTS)
same behavior.

Look for any manjaro-gdm-18.0-theme-dev, manjaro-gdm-branding or manjaro-gdm-theme and remove them. Reinstall gnome-shell, reboot and make the test again. Please report back :wink:

neither of the manjaro-gdm packages was installed.
Reinstalling gnome shell did unfortunately not change anything

I see ... :frowning:
Can you check if this happens whatever you log in in Gnome Wayland or Gnome X11 ?

Did you install the gnome extension "User Theme" or "Bing wallpaper changer"?
Disable them works for me...

Yes, "bing wallpaper canger" was the problem, now i can login like i used to.

Thank you all for your kind help!

Thank you so much @Vicent_Chen, this fixed my issue too and as a bonus it fixed my laptop too.
I had a laptop that would not shut down but always would restart instead and believe it or not disabling "user themes" solved this.
Thanks again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by