Can't manage to boot on grub even with tutorials

HI Manjaro community !

I've just installed Manjaro yesterday on my desktop beside Windows 10 and it works, but, I can't manage to make the grub appear on boot, even after trying several tutorials.

Currently to access Manjaro I have to press F11 when the BIOS show on boot, select Manjaro as current boot, then the grub appear. If i don't do this, the computer boot on Windows.

I hope you will be able to help me on this little problem.

Some informations about my system and solutions I've tried to solve my problem :

  • I followed this tutorial to install manjaro

  • Windows 10 is installed on the SSD and Manjaro have its own partition on the HDD

  • When do efibootmgr on my Manjaro, Manjaro is on the top of the list

  • On the installation of Manjaro, I've created a swap partition AND a boot partition /boot/efi as explained on the tutorial I followed

  • While on W10 I've tried this command bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efibut after a reboot, I face a black screen with a command line and "grub rescue"

  • I tried to change to boot order directly on the BIOS settings, but with all order changes I've tried I faced :

    1. The black screen with grub rescue
    2. A black screen telling me that there is no boot option and I had to hard reboot to change again the boot order

That's wierd because when I manually chose Manjaro while pressing F11 at the computer boot, it shows me the holy grub :roll_eyes:

I'm sorry for my low english skills, I hope you will be able to help me make this grub appear !

Thanks in advance !

Mecadie

If you edit the boot order in your BIOS/UEFI you can select the SSD with Manjaro on it as the default boot device.

1 Like

I tried to to it but I faced the black screen telling me there is nothing to boot on :frowning:
Capture
Here is a screen shot of my drives. Manjaro is installed on the "Disque 1". (D:) is a partition for my games on Windows, F: is the /boot/efi partition, the 2Go parition is the swap partition and the last partition is Manjaro

Here is a picture of the screen I talk about when I change boot order for the HDD :
60450713_1302067243279977_2791012530833588224_n

Here are my two drives (below), when I change boot order from CT500[....] to STD1000[....] I face the black screen, any advice for this issue please ?

Regards

Sorry I forgot to upload the second picture
Capture

You do know what entering BIOS and changing boot order means yes?
Also I don't think my manjaro would want to boot an STD either :crazy_face:

Ahah to speak truly I don't know what to do now
Here is a picture of my BIOS where we can see my two drives. If I've made an efi boot partition on the second drive, why shouldn't be able to boot on it ?
60476628_307107533561875_1560801075395559424_n

It's so difficult to read pictures :sweat_smile: on most modern BIOS's you can hit F12 with a usb drive inserted and it will take a screen shot of the BIOS page you are on and save it to the USB drive. Anyway...from what I see you should hit F7 for advanced options look for the boot tab and select that drive (manjaro) as boot option 1 (one). There may also be a boot overide selection further down the BIOS page.

because on your screenshot
we see legacy activated , not UEFI

2 Likes

And that's it !

Thanks you all !

Regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by