Can't print using a printer shared from windows, getting NT_STATUS_ACCESS_DENIED error

I have a Brother DCP-J100 shared from a Windows PC. The account it's shared from does not have a password, so I disabled password protected sharing in the settings. I added the printer using CUPS network interface, but also tried within the settings. I couldn't enter the username in CUPS, but I did in the settings, leaving the password field empty.
When trying to print anything, the print job fails with Session setup failed: NT_STATUS_ACCESS_DENIED. The same error happens when trying to query the printer for the default printing parameters.
I tried sharing a directory and mounting it on Linux and it works with no problem. The command I used for mounting: sudo mount -o username=Test //DEVICE-NAME/Users win. I then got prompted for the password, which I left empty and pressed enter. The mount worked normally, I could browse it with no issues.
Samba version: 4.12.1

There's very little information here to be able to preform an RCA so:

  • If the Windows PC member of a domain instead of a workgroup: This will not be solved on a public forum
    • Read the Micro$oft docs on how to interface Linux with its domain authentication
    • Get a consultant in.
  • If a home computer, on the Windows PC:
    • If it's <Windows 8: Upgrade it to Manjaro!
      You're running an unsupported version! :innocent:
    • Note the workgroup
    • Share the printer with Everyone
    • Ensure NT LAN Manager authentication is enabled if Windows >8
    • Enable the guest account
  • On the Manjaro PC:
    • Ensure NT1 authentication is enabled in Samba

    • Workgroup is identical to the Windows PC

    • provide the output to:

      smbclient --list=* --no-pass --debuglevel=2
      

:innocent:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by