Can't save images on Firefox


Having a weird issue with Firefox Developer Edition lately. Any images I try to save with "Save Image As" fail and I'm not sure how to solve this. Could it be a permissions issue? I haven't changed anything recently.

FF 69.0b4


Hello! Are you able to download other types of files?

Also, do you have any extensions that can disable scripts? That may not be it but sometimes it breaks things in weird ways so it's worth a shot to enable them again if so.

An article from Firefox support that might help you troubleshoot your issue:

Another great source is this thread:

Open Firefox from the terminal and try again. Some errors may show up there.

@cactus was seen 2 hours after last answer.
Some news?

Thanks for the help guys. Still haven't been able to solve the issue, but I've gotten further along here.

I think my NTFS drive that my downloads folder is symlinked to is somehow mounted as read-only and I'm not sure how to fix that now.

Dual-boot with win?
Could you make a new file in dolphin?
do you know about chown?
ntfs-3g installed?

Can't make a new file in Dolphin
Tried to sudo chown but got a bunch of read-only errors
ntfs-3g is installed

Mount options:

I think yes.

Post outputs, and input, fortune teller ball is just about to be repaired :wink:

1 Like

Something like this?

This fixed it. Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by