Can't see or use Wi-Fi networks (HP Laptop, Manjaro KDE)

I'm a completely new Linux user, absolute newbie, but eager to learn. I have installed Manjaro (KDE edition) on my HP Notebook (dual-booting it alongside Windows 10.) My problem is that I can't see or connect to Wi-Fi networks, I've been searching and I don't even understand what's going on, my network manager doesn't even seem to show an icon for Wi-Fi and I see in some other screenshots from some other users that there should be a Wi-Fi icon and an airplane icon.

I can use a wired connection without any issues, but I need Wi-Fi for this laptop.

Here's a screenshot

Here are the results of $ inxi -Fxxxza --no-host

System:
  Kernel: 5.6.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=7bbbbbc4-a1ad-4070-8134-66aa45cabdd4 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP Laptop 15-da0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: HP model: 84A6 v: 80.43 serial: <filter> UEFI: Insyde v: F.22 
  date: 08/28/2019 
Battery:
  ID-1: BAT1 charge: 40.8 Wh condition: 40.8/41.0 Wh (100%) 
  volts: 12.9/11.4 model: Hewlett-Packard PABAS0241231 type: Li-ion 
  serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M275/M280 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: CA L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
  bogomips: 32012 
  Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa compositor: kwin_x11 resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) 
  v: 4.6 Mesa 20.0.6 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.6.8-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 
  bus ID: 01:00.0 chip ID: 10ec:8168 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: N/A port: 3000 bus ID: 02:00.0 
  chip ID: 10ec:c821 
Drives:
  Local Storage: total: 1.82 TiB used: 52.22 GiB (2.8%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ04ABD200 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0C scheme: GPT 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 5060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
Partition:
  ID-1: / raw size: 500.30 GiB size: 491.44 GiB (98.23%) 
  used: 8.55 GiB (1.7%) fs: ext4 dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 44.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 222 Uptime: 27m Memory: 15.55 GiB used: 1.44 GiB (9.3%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  running in: konsole inxi: 3.0.37

Any help would be greatly appreciated.

you need to install driver for your WiFi card.

Welcome to Manjaro.

This forum has a search function - don't be afraid to use it.

VoDo: you need to install driver for your WiFi card.

I see it now, thanks.

freggel.doe: Welcome to Manjaro.
This forum has a search function - don't be afraid to use it.

It works now. Sorry for the inconveniences, I'll make sure to use the search function thoroughly before making a new topic next time. Thank you both for your help.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by