Can't see Windows 10 in Grub after dual-boot install

Hi all,

I am setting up a desktop to dual-boot Windows 10 and Manjaro. Windows 10 was installed first, and I followed this guide to get Manjaro installed alongside of the computers Windows 10 install:

After following it, I have no Windows 10 option in GRUB.

I tried running these two commands:

sudo os-prober
grub-mkconfig -o /boot/grub/grub.cfg

No change.. I still have no Windows 10 option in GRUB. Here's a screenshot of my gparted:



There are quite a big number of posts that deal with this, and depending on how you installed your OS's, UEFI or Legacy, MBR or GPT, same HDD with multiple partitions, different HDD - all of those count to have the proper answer.
Personally i will not read the guide you followed, but here are a few links that might help you out.

and this

1 Like

Sorry to be a noob here, but I've looked at each of those and cannot figure out how to proceed in my particular use case.

Here is the contents of my grub file, btw:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=779ef729-7d04-4671-a56b-e0481cd3ab83"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

You don't have to edit the /etc/default/grub to get the Windows in the Boot GRUB menu. This file is useful for other flags ...

os-prober is responsible for the detection of other OS and adding it to the menu. Sometimes that OS partition must be mounted, and then just run from terminal:
sudo update-grub
that will also invoke the os-prober ... but in case you don not have a good boot for windows, it will not be detected ...

Just mounted it and ran that command.. no dice, unfortunately.

What does this mean?

Sorry, I should have been more clear. Same thing. After rebooting, GRUB lacks a Windows 10 option. Here is the output of the update-grub command:

[bitfenix@bitfenix-pc ~]$ sudo update-grub
[sudo] password for bitfenix: 
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

And none of the two tutorials from @gohlip didn't help ?
He has a post about nvme0n1 devices and those need a special care it seems, but are there in his next comments on the first link i provided

Well ... i'm out of resources here :slight_smile:

At Manjaro terminal, provide
ls /boot/efi/
ls /boot/efi/EFI/
ls /boot/efi/EFI/Mirosoft/
ls /boot/efi/EFI/Mirosoft/Boot/

Depending on DE, you may have to use 'sudo', but I don't think so.
If no output, error message, print out too.

hi gohlip, did you mean "Microsoft" or "Mirosoft" ? I tried both. Results are pasted below:

[bitfenix@bitfenix-pc ~]$ ls /boot/efi/
[bitfenix@bitfenix-pc ~]$ ls /boot/efi/EFI/
boot  Manjaro
[bitfenix@bitfenix-pc ~]$ ls /boot/efi/EFI/Microsoft/
ls: cannot access '/boot/efi/EFI/Microsoft/': No such file or directory
[bitfenix@bitfenix-pc ~]$ sudo ls /boot/efi/EFI/Microsoft/Boot/
ls: cannot access '/boot/efi/EFI/Microsoft/Boot/': No such file or directory
[bitfenix@bitfenix-pc ~]$ ls /boot/efi/EFI/Mirosoft/
ls: cannot access '/boot/efi/EFI/Mirosoft/': No such file or directory
[bitfenix@bitfenix-pc ~]$ sudo ls /boot/efi/EFI/Mirosoft/Boot/
ls: cannot access '/boot/efi/EFI/Mirosoft/Boot/': No such file or directory

Tried the suggestion in this post. No change to GRUB. Here is the output of the command:

[bitfenix@bitfenix-pc ~]$ sudo grub-install /dev/nvme0
[sudo] password for bitfenix: 
Installing for x86_64-efi platform.
Installation finished. No error reported.
[bitfenix@bitfenix-pc ~]$

You've lost your windows boot file.
You formatted /boot/efi when you installed Manjaro.
Install windows boot and then reinstall manjaro grub.


Thanks gohlip. That makes sense.

Do you happen to know of any guides for installing just Windows boot, without trashing the Windows install or the Manjaro install?

To get back windows, you do not need to reinstall the whole OS, just the boot (no trashing windows).
Now, I am not clear on the procedure to get windows boot back (because I've never have to and the procedure keeps changing with different versions of windows and between uefi and bios-legacy so I am totally unsure). Please google it and perhaps some people here can help.

The second step - to get back Manjaro boot. That you are in safe hands, humility aside. :slightly_smiling_face: It's also a simple process without messing with the Manjaro OS.
Read this up (the same link posted by @bogdancovaciu) and when booted to Manjaro, do
sudo grub-install
sudo update-grub

Plus the 2 additional commands for the UEFI part.

Good luck.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by